aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/font-shinonome/Makefile6
-rw-r--r--japanese/font-shinonome/files/pkg-install.in7
2 files changed, 8 insertions, 5 deletions
diff --git a/japanese/font-shinonome/Makefile b/japanese/font-shinonome/Makefile
index e24654df4621..cc3140fd2c70 100644
--- a/japanese/font-shinonome/Makefile
+++ b/japanese/font-shinonome/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shinonome
PORTVERSION= 0.9.11.p1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese x11-fonts
MASTER_SITES= http://openlab.jp/efont/dist/shinonome/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
@@ -44,7 +44,7 @@ FONTNAMES=\
shnmk16 shnmk16b shnmk16i shnmk16bi \
shnmk16min shnmk16minb shnmk16mini shnmk16minbi
-FONTNAME= shinonome
+FONTNAME= misc
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
@@ -65,6 +65,8 @@ do-install:
${MKDIR} ${STAGEDIR}${FONTSDIR}
cd ${STAGEDIR}${FONTSDIR} && ${LN} -s -f \
../../../${DATADIR_REL}/*.pcf.gz .
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/japanese/font-shinonome/files/pkg-install.in b/japanese/font-shinonome/files/pkg-install.in
index 1b9a41f41c84..d95521474469 100644
--- a/japanese/font-shinonome/files/pkg-install.in
+++ b/japanese/font-shinonome/files/pkg-install.in
@@ -1,16 +1,17 @@
#!/bin/sh
# $FreeBSD$
-FONTSDIR=%%FONTSDIR%%
-
case "$2" in
POST-INSTALL)
+ cd %%FONTSDIR%%
touch fonts.alias
grep -v -- "-shinonome-" fonts.alias > fonts.alias.tmp
- (cat fonts.alias.tmp; grep -v "^!!" %%FONTSALIAS%%) > fonts.alias
+ (cat fonts.alias.tmp; grep -- "-shinonome-" %%FONTSALIAS%%) \
+ > fonts.alias
rm -f fonts.alias.tmp
;;
POST-DEINSTALL)
+ cd %%FONTSDIR%%
touch fonts.alias
grep -v -- "-shinonome-" fonts.alias > fonts.alias.tmp
if [ -s fonts.alias.tmp ]; then