aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/libotr/Makefile10
-rw-r--r--security/pidgin-otr/Makefile3
2 files changed, 9 insertions, 4 deletions
diff --git a/security/libotr/Makefile b/security/libotr/Makefile
index c65e4856bc2f..3a39b7f28160 100644
--- a/security/libotr/Makefile
+++ b/security/libotr/Makefile
@@ -4,6 +4,7 @@ PORTNAME= libotr
PORTVERSION= 4.0.0
# Please do not bump PORTREVISION for this port unless you have
# confirmed via testing that it is necessary
+PORTREVISION= 1
CATEGORIES= security net-im net
MASTER_SITES= http://www.cypherpunks.ca/otr/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -34,8 +35,15 @@ MLINKS= otr_toolkit.1 otr_parse.1 \
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's#^pkgconfigdir .*#pkgconfigdir = ${PREFIX}/libdata/pkgconfig#' \
${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.am
-.include <bsd.port.mk>
+.if ${OSVERSION} >= 800000 && ${OSVERSION} < 1000000
+ ${REINPLACE_CMD} -e 's#OTR_CHECK_CFLAGS(.*stack-protector.*#dnl &#' \
+ ${WRKSRC}/configure.ac
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/pidgin-otr/Makefile b/security/pidgin-otr/Makefile
index 4d91d7de97bd..ea3fae08dab4 100644
--- a/security/pidgin-otr/Makefile
+++ b/security/pidgin-otr/Makefile
@@ -35,7 +35,4 @@ CONFIGURE_ARGS= --with-libotr-prefix=${LOCALBASE}/lib \
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
-
.include <bsd.port.mk>