aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/cvsspam/Makefile18
-rw-r--r--games/textmaze/Makefile3
-rw-r--r--german/schwobifyer/Makefile3
-rw-r--r--graphics/bmp2html/Makefile3
-rw-r--r--graphics/icat/Makefile3
-rw-r--r--mail/cyrus2courier/Makefile3
-rw-r--r--mail/delatt/Makefile3
-rw-r--r--mail/spfval/Makefile3
-rw-r--r--mail/sylpheed/Makefile11
-rw-r--r--misc/ree/Makefile10
-rw-r--r--misc/shuffle-db/Makefile3
-rw-r--r--net-im/bsflite/Makefile11
-rw-r--r--net-p2p/createtorrent/Makefile3
-rw-r--r--www/bannerfilter/Makefile17
-rw-r--r--www/linklint/Makefile4
15 files changed, 44 insertions, 54 deletions
diff --git a/devel/cvsspam/Makefile b/devel/cvsspam/Makefile
index fe1ce3867f7c..87be3ec83f58 100644
--- a/devel/cvsspam/Makefile
+++ b/devel/cvsspam/Makefile
@@ -19,7 +19,6 @@ PORTDOCS= COPYING CREDITS TODO cvsspam-doc.html cvsspam-doc.pdf
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -31,19 +30,22 @@ post-patch:
${WRKSRC}/collect_diffs.rb
do-install:
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
.for f in collect_diffs.rb cvsspam.rb record_lastdir.rb
- ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} \
+ ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
.endfor
- ${INSTALL_DATA} ${WRKSRC}/cvsspam.conf ${PREFIX}/etc/cvsspam.conf.default
-.if !exists(${PREFIX}/etc/cvsspam.conf)
- ${INSTALL_DATA} ${WRKSRC}/cvsspam.conf ${PREFIX}/etc/cvsspam.conf
+ ${INSTALL_DATA} ${WRKSRC}/cvsspam.conf \
+ ${STAGEDIR}${PREFIX}/etc/cvsspam.conf.default
+.if !exists(${STAGEDIR}${PREFIX}/etc/cvsspam.conf)
+ ${INSTALL_DATA} ${WRKSRC}/cvsspam.conf \
+ ${STAGEDIR}${PREFIX}/etc/cvsspam.conf
.endif
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/games/textmaze/Makefile b/games/textmaze/Makefile
index e23ece2efe7b..533b541337f6 100644
--- a/games/textmaze/Makefile
+++ b/games/textmaze/Makefile
@@ -21,8 +21,7 @@ PLIST_FILES= bin/textmaze
WRKSRC= ${WRKDIR}/TextMaze
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/german/schwobifyer/Makefile b/german/schwobifyer/Makefile
index 5b9b22c06fdf..ddbb3d4e3f9f 100644
--- a/german/schwobifyer/Makefile
+++ b/german/schwobifyer/Makefile
@@ -13,8 +13,7 @@ MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/schwobifyer
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/graphics/bmp2html/Makefile b/graphics/bmp2html/Makefile
index 752c4d8c1a93..7e97a75f37e7 100644
--- a/graphics/bmp2html/Makefile
+++ b/graphics/bmp2html/Makefile
@@ -20,7 +20,6 @@ DEFINES= -D_REENTRANT
PLIST_FILES= bin/bmp2html
-NO_STAGE= yes
post-patch:
@${RM} ${WRKSRC}/${PORTNAME}
@@ -31,6 +30,6 @@ do-build:
-o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.o
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/graphics/icat/Makefile b/graphics/icat/Makefile
index 5b7e232ab6e3..af6b91ead085 100644
--- a/graphics/icat/Makefile
+++ b/graphics/icat/Makefile
@@ -25,8 +25,7 @@ PLIST_FILES= bin/icat
CONFLICTS= sleuthkit-[0-9]*
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/mail/cyrus2courier/Makefile b/mail/cyrus2courier/Makefile
index 45942ef8d863..aa41e68005f8 100644
--- a/mail/cyrus2courier/Makefile
+++ b/mail/cyrus2courier/Makefile
@@ -15,12 +15,11 @@ ALL_TARGET= build
PLIST_FILES= bin/cyrus2courier
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} '/^CFLAGS*/d; /^LDFLAGS*/d; /^CC*/d' \
${WRKSRC}/src/Makefile.FreeBSD
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/mail/delatt/Makefile b/mail/delatt/Makefile
index 6b46d8889b17..00a88a729410 100644
--- a/mail/delatt/Makefile
+++ b/mail/delatt/Makefile
@@ -21,8 +21,7 @@ NO_BUILD= yes
SHEBANG_FILES= delatt
PLIST_FILES= bin/delatt
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/mail/spfval/Makefile b/mail/spfval/Makefile
index 52a009ddd643..6d56abe84033 100644
--- a/mail/spfval/Makefile
+++ b/mail/spfval/Makefile
@@ -15,8 +15,7 @@ MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/spfval
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/spfval ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/spfval ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 1861637697d0..75f0464d81db 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -40,7 +40,6 @@ ONIGURUMA_DESC= Oniguruma support
OPTIONS_DEFAULT=SSL GTKSPELL
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
@@ -124,13 +123,13 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ChangeLog INSTALL README TODO
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/${i}.ja ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${i}.ja ${STAGEDIR}${DOCSDIR}
.endfor
.endif
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${PREFIX}/share/pixmaps/
- @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed.png ${STAGEDIR}${PREFIX}/share/pixmaps/
+ @${INSTALL_DATA} ${WRKSRC}/sylpheed.desktop ${STAGEDIR}${PREFIX}/share/applications/
.include <bsd.port.mk>
diff --git a/misc/ree/Makefile b/misc/ree/Makefile
index 3eb74ea61074..60e0719a6dae 100644
--- a/misc/ree/Makefile
+++ b/misc/ree/Makefile
@@ -17,7 +17,6 @@ ONLY_FOR_ARCHS= i386 amd64
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-build:
@@ -26,12 +25,13 @@ do-build:
.endfor
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/rom-${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/fontdump ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/rom-${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/fontdump ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/misc/shuffle-db/Makefile b/misc/shuffle-db/Makefile
index e3d9962c6bcb..df5ac100c7ba 100644
--- a/misc/shuffle-db/Makefile
+++ b/misc/shuffle-db/Makefile
@@ -16,8 +16,7 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/rebuild_db
PLIST_FILES= bin/rebuild_db.py
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/rebuild_db.py ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/rebuild_db.py ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/net-im/bsflite/Makefile b/net-im/bsflite/Makefile
index 955db4e3f73f..4755a435ad88 100644
--- a/net-im/bsflite/Makefile
+++ b/net-im/bsflite/Makefile
@@ -15,7 +15,6 @@ PORTDOCS= COPYING ChangeLog README
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -24,14 +23,14 @@ post-patch:
${WRKSRC}/imcomm/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bsflite ${PREFIX}/bin
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/config-example ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bsflite ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/config-example ${STAGEDIR}${EXAMPLESDIR}
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/net-p2p/createtorrent/Makefile b/net-p2p/createtorrent/Makefile
index cc7fa41e9b5c..f7f99cb537d1 100644
--- a/net-p2p/createtorrent/Makefile
+++ b/net-p2p/createtorrent/Makefile
@@ -16,8 +16,7 @@ USE_OPENSSL= yes
PLIST_FILES= bin/createtorrent
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/www/bannerfilter/Makefile b/www/bannerfilter/Makefile
index 26fcf200ff1b..02c6b8d85d01 100644
--- a/www/bannerfilter/Makefile
+++ b/www/bannerfilter/Makefile
@@ -25,7 +25,6 @@ CONFIG_FILES= bannerfilter.conf banners.data banners.local.data \
SHEBANG_FILES= redirector.pl
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
's|^;\ \(DATA\ =\ \).*|\1${PREFIX}/etc/${PORTNAME}/|' \
@@ -35,18 +34,18 @@ post-patch:
${WRKSRC}/update.sh
do-install:
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKSRC}/redirector.pl ${PREFIX}/libexec/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/redirector.pl ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
${INSTALL_SCRIPT} ${WRKSRC}/update.sh \
- ${PREFIX}/bin/update-bannerfilter-rules
- ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ ${STAGEDIR}${PREFIX}/bin/update-bannerfilter-rules
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
.for f in ${CONFIG_FILES}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/etc/${PORTNAME}/${f}.default
-.if !exists(${PREFIX}/etc/${PORTNAME}/${f})
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/etc/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${ETCDIR}/${f}.default
+.if !exists(${STAGEDIR}${ETCDIR}/${f})
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${ETCDIR}
.endif
.endfor
- ${CP} -R ${WRKSRC}/www ${PREFIX}/${WWW_ROOT}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/www ${STAGEDIR}${PREFIX}/${WWW_ROOT}/${PORTNAME}
post-install:
@${ECHO_MSG} ""
diff --git a/www/linklint/Makefile b/www/linklint/Makefile
index a3bb80b17aba..de0f4b8c4da6 100644
--- a/www/linklint/Makefile
+++ b/www/linklint/Makefile
@@ -18,8 +18,8 @@ SHEBANG_FILES= ${DISTNAME}
PLIST_FILES= bin/linklint
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>