aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/qmqtool/Makefile33
-rw-r--r--mail/qmqtool/distinfo2
-rw-r--r--mail/qmqtool/pkg-descr11
-rw-r--r--mail/qmqtool/pkg-plist6
5 files changed, 53 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index f1170ba0ce63..13a4200b3f8e 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -393,6 +393,7 @@
SUBDIR += qmailadmin-devel
SUBDIR += qmailanalog
SUBDIR += qmailmrtg7
+ SUBDIR += qmqtool
SUBDIR += qmrtg
SUBDIR += qpopper
SUBDIR += qscan
diff --git a/mail/qmqtool/Makefile b/mail/qmqtool/Makefile
new file mode 100644
index 000000000000..ff77866492a4
--- /dev/null
+++ b/mail/qmqtool/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: qmqtool
+# Date created: Sat Apr 9 09:45:30 EDT 2005
+# Whom: Matthew Will <mwill@spingen.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmqtool
+PORTVERSION= 1.10
+CATEGORIES= mail
+MASTER_SITES= http://jeremy.kister.net/code/qmqtool/ \
+ http://mirror.spingen.com/qmqtool/
+DISTNAME= ${PORTNAME}-current
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mwill@spingen.com
+COMMENT= Tool to manipulate contents of a qmail queue
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+NO_BUILD= yes
+USE_PERL5= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/qmqtool ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for FILE in Artistic ChangeLog FAQ README
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/qmqtool/distinfo b/mail/qmqtool/distinfo
new file mode 100644
index 000000000000..e45e65142253
--- /dev/null
+++ b/mail/qmqtool/distinfo
@@ -0,0 +1,2 @@
+MD5 (qmqtool-current.tgz) = 8b2feaf7ad4e379d8802008d54f01cca
+SIZE (qmqtool-current.tgz) = 18880
diff --git a/mail/qmqtool/pkg-descr b/mail/qmqtool/pkg-descr
new file mode 100644
index 000000000000..82e82d58ae57
--- /dev/null
+++ b/mail/qmqtool/pkg-descr
@@ -0,0 +1,11 @@
+qmqtool is a qmail queue manipulation program geared towards the
+viewing and safe modification of the contents in a qmail queue.
+
+Features include finding abusers, sorting messages by sender/sender's IP,
+showing stats, requeue messages, queue consistency check, queue
+backup/restore, and others.
+
+WWW: http://jeremy.kister.net/code/qmqtool/
+Author: Jeremy Kister
+
+- Matthew Will <mwill@spingen.com>
diff --git a/mail/qmqtool/pkg-plist b/mail/qmqtool/pkg-plist
new file mode 100644
index 000000000000..ee3195208385
--- /dev/null
+++ b/mail/qmqtool/pkg-plist
@@ -0,0 +1,6 @@
+bin/qmqtool
+%%PORTDOCS%%%%DOCSDIR%%/Artistic
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%