aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/poptop/Makefile10
-rw-r--r--net/poptop/files/patch-plugins_pptpd-logwtmp.c10
2 files changed, 12 insertions, 8 deletions
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index 952a719d7fb8..bcd8dbecff69 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= poptop
PORTVERSION= 1.3.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/pptpd/pptpd-${PORTVERSION}
DISTNAME= pptpd-${PORTVERSION:S/.b/-b/}
@@ -38,10 +38,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/samples/pptpd.conf \
${PREFIX}/etc/pptpd.conf.sample
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 900007
-BROKEN= fails to build with new utmpx
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/poptop/files/patch-plugins_pptpd-logwtmp.c b/net/poptop/files/patch-plugins_pptpd-logwtmp.c
new file mode 100644
index 000000000000..4ac8d80d0537
--- /dev/null
+++ b/net/poptop/files/patch-plugins_pptpd-logwtmp.c
@@ -0,0 +1,10 @@
+--- plugins/pptpd-logwtmp.c.orig 2012-02-13 10:53:17.000000000 +0800
++++ plugins/pptpd-logwtmp.c 2012-02-13 10:53:26.000000000 +0800
+@@ -10,7 +10,6 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+ #include <unistd.h>
+-#include <utmp.h>
+ #include <string.h>
+ #include "pppd.h"
+