aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/foomatic-db-hpijs/Makefile5
-rw-r--r--print/foomatic-db-hpijs/files/patch-configure24
-rw-r--r--security/pinentry/Makefile6
3 files changed, 30 insertions, 5 deletions
diff --git a/print/foomatic-db-hpijs/Makefile b/print/foomatic-db-hpijs/Makefile
index 253b42ff86e5..63b809315327 100644
--- a/print/foomatic-db-hpijs/Makefile
+++ b/print/foomatic-db-hpijs/Makefile
@@ -19,5 +19,10 @@ RUN_DEPENDS= ${LOCALBASE}/share/foomatic/db/oldprinterids:${PORTSDIR}/print/foom
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/print/foomatic-db-hpijs/files/patch-configure b/print/foomatic-db-hpijs/files/patch-configure
index 21cd21aa9ecb..b204a43ea0f0 100644
--- a/print/foomatic-db-hpijs/files/patch-configure
+++ b/print/foomatic-db-hpijs/files/patch-configure
@@ -1,5 +1,14 @@
---- configure.orig Sat Sep 17 02:25:59 2005
-+++ configure Sat Sep 17 02:26:04 2005
+--- configure.orig Wed May 21 23:01:15 2003
++++ configure Tue Oct 18 20:23:45 2005
+@@ -9,7 +9,7 @@
+
+ # Defaults:
+ ac_help=
+-ac_default_prefix=/usr/local
++ac_default_prefix=%%PREFIX%%
+ # Any additions from configure.in:
+
+ # Initialize some variables set by options.
@@ -522,7 +522,7 @@
@@ -9,3 +18,14 @@
sysconfdir=/etc
fi
+@@ -658,8 +658,8 @@
+ fi
+
+
+-BINSEARCHPATH=/usr/bin:/bin:/usr/local/bin
+-DATASEARCHPATH=/usr/share:/usr/local/share:/usr/lib:/usr/local/lib:/opt
++BINSEARCHPATH=/usr/bin:/bin:%%LOCALBASE%%/bin
++DATASEARCHPATH=/usr/share:%%LOCALBASE%%/share:/usr/lib:%%LOCALBASE%%/lib:/opt
+
+ for ac_prog in perl
+ do
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 5e02c60b138e..5473a8e493ba 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -48,7 +48,7 @@ PLIST_SUB+= WITH_QT="@comment "
.if defined(PINENTRY_GTK)
USE_GNOME+= gtk12
PLIST_SUB+= WITH_GTK=""
-CONFIGURE_ENV+= CFLAGS=-I/usr/local/include
+CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include
.else
CONFIGURE_ARGS+=--disable-pinentry-gtk
PLIST_SUB+= WITH_GTK="@comment "
@@ -57,7 +57,7 @@ PLIST_SUB+= WITH_GTK="@comment "
.if defined(PINENTRY_GTK2)
USE_GNOME+= gtk20
PLIST_SUB+= WITH_GTK2=""
-CONFIGURE_ENV+= CFLAGS=-I/usr/local/include
+CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include
.else
CONFIGURE_ARGS+=--disable-pinentry-gtk2
PLIST_SUB+= WITH_GTK2="@comment "
@@ -65,7 +65,7 @@ PLIST_SUB+= WITH_GTK2="@comment "
.if defined(PINENTRY_CURSES)
PLIST_SUB+= WITH_CURSES=""
-CONFIGURE_ENV+= CFLAGS=-I/usr/local/include LDFLAGS=-L/usr/local/lib
+CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
.else
CONFIGURE_ARGS+=--disable-pinentry-curses
PLIST_SUB+= WITH_CURSES="@comment "