aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/AbiWord/Makefile12
-rw-r--r--editors/AbiWord/distinfo2
-rw-r--r--editors/AbiWord/pkg-plist3
-rw-r--r--editors/AbiWord2/Makefile12
-rw-r--r--editors/AbiWord2/distinfo2
-rw-r--r--editors/AbiWord2/pkg-plist3
-rw-r--r--editors/abiword-devel/Makefile12
-rw-r--r--editors/abiword-devel/distinfo2
-rw-r--r--editors/abiword-devel/pkg-plist3
-rw-r--r--editors/abiword/Makefile12
-rw-r--r--editors/abiword/distinfo2
-rw-r--r--editors/abiword/pkg-plist3
12 files changed, 40 insertions, 28 deletions
diff --git a/editors/AbiWord/Makefile b/editors/AbiWord/Makefile
index 4f498c3cb00b..3eca7f48bac2 100644
--- a/editors/AbiWord/Makefile
+++ b/editors/AbiWord/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= AbiWord
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -32,13 +32,9 @@ USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12 gnomehier
WANT_GNOME= yes
-AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
-FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
- s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
.undef WITHOUT_GNOME
@@ -61,9 +57,13 @@ BROKEN= "This port cannot be built when textproc/wv is installed because of a he
.endif
pre-configure:
- @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog
+ @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
@cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
@${RM} -f ${WRKSRC}/configure.ac
+ @cd ${WRKSRC} && ./autogen.sh && ${TRUE}
+ @${FIND} ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
+ s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/editors/AbiWord/distinfo b/editors/AbiWord/distinfo
index b72963643bfa..6dd051c40b56 100644
--- a/editors/AbiWord/distinfo
+++ b/editors/AbiWord/distinfo
@@ -1 +1 @@
-MD5 (AbiWord/abiword-1.0.3.tar.gz) = 01336526136b7fbc66328d80931710e3
+MD5 (AbiWord/abiword-1.0.4.tar.gz) = fec2f2770c29afe0d30e653b5d1d40bb
diff --git a/editors/AbiWord/pkg-plist b/editors/AbiWord/pkg-plist
index 38ab444526e6..442011e86d58 100644
--- a/editors/AbiWord/pkg-plist
+++ b/editors/AbiWord/pkg-plist
@@ -216,6 +216,7 @@ share/AbiSuite/AbiWord/strings/fi-FI.strings
share/AbiSuite/AbiWord/strings/fr-FR.strings
share/AbiSuite/AbiWord/strings/ga-IE.strings
share/AbiSuite/AbiWord/strings/gl-ES.strings
+share/AbiSuite/AbiWord/strings/he-IL.strings
share/AbiSuite/AbiWord/strings/hu-HU.strings
share/AbiSuite/AbiWord/strings/id-ID.strings
share/AbiSuite/AbiWord/strings/it-IT.strings
@@ -231,9 +232,11 @@ share/AbiSuite/AbiWord/strings/ro-RO.strings
share/AbiSuite/AbiWord/strings/ru-RU.strings
share/AbiSuite/AbiWord/strings/sk-SK.strings
share/AbiSuite/AbiWord/strings/sl-SI.strings
+share/AbiSuite/AbiWord/strings/sr-SR.strings
share/AbiSuite/AbiWord/strings/sv-SE.strings
share/AbiSuite/AbiWord/strings/tr-TR.strings
share/AbiSuite/AbiWord/strings/uk-UA.strings
+share/AbiSuite/AbiWord/strings/vi-VN.strings
share/AbiSuite/AbiWord/strings/zh-CN.strings
share/AbiSuite/AbiWord/strings/zh-HK.strings
share/AbiSuite/AbiWord/strings/zh-TW.strings
diff --git a/editors/AbiWord2/Makefile b/editors/AbiWord2/Makefile
index 4f498c3cb00b..3eca7f48bac2 100644
--- a/editors/AbiWord2/Makefile
+++ b/editors/AbiWord2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= AbiWord
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -32,13 +32,9 @@ USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12 gnomehier
WANT_GNOME= yes
-AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
-FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
- s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
.undef WITHOUT_GNOME
@@ -61,9 +57,13 @@ BROKEN= "This port cannot be built when textproc/wv is installed because of a he
.endif
pre-configure:
- @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog
+ @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
@cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
@${RM} -f ${WRKSRC}/configure.ac
+ @cd ${WRKSRC} && ./autogen.sh && ${TRUE}
+ @${FIND} ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
+ s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/editors/AbiWord2/distinfo b/editors/AbiWord2/distinfo
index b72963643bfa..6dd051c40b56 100644
--- a/editors/AbiWord2/distinfo
+++ b/editors/AbiWord2/distinfo
@@ -1 +1 @@
-MD5 (AbiWord/abiword-1.0.3.tar.gz) = 01336526136b7fbc66328d80931710e3
+MD5 (AbiWord/abiword-1.0.4.tar.gz) = fec2f2770c29afe0d30e653b5d1d40bb
diff --git a/editors/AbiWord2/pkg-plist b/editors/AbiWord2/pkg-plist
index 38ab444526e6..442011e86d58 100644
--- a/editors/AbiWord2/pkg-plist
+++ b/editors/AbiWord2/pkg-plist
@@ -216,6 +216,7 @@ share/AbiSuite/AbiWord/strings/fi-FI.strings
share/AbiSuite/AbiWord/strings/fr-FR.strings
share/AbiSuite/AbiWord/strings/ga-IE.strings
share/AbiSuite/AbiWord/strings/gl-ES.strings
+share/AbiSuite/AbiWord/strings/he-IL.strings
share/AbiSuite/AbiWord/strings/hu-HU.strings
share/AbiSuite/AbiWord/strings/id-ID.strings
share/AbiSuite/AbiWord/strings/it-IT.strings
@@ -231,9 +232,11 @@ share/AbiSuite/AbiWord/strings/ro-RO.strings
share/AbiSuite/AbiWord/strings/ru-RU.strings
share/AbiSuite/AbiWord/strings/sk-SK.strings
share/AbiSuite/AbiWord/strings/sl-SI.strings
+share/AbiSuite/AbiWord/strings/sr-SR.strings
share/AbiSuite/AbiWord/strings/sv-SE.strings
share/AbiSuite/AbiWord/strings/tr-TR.strings
share/AbiSuite/AbiWord/strings/uk-UA.strings
+share/AbiSuite/AbiWord/strings/vi-VN.strings
share/AbiSuite/AbiWord/strings/zh-CN.strings
share/AbiSuite/AbiWord/strings/zh-HK.strings
share/AbiSuite/AbiWord/strings/zh-TW.strings
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index 4f498c3cb00b..3eca7f48bac2 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= AbiWord
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -32,13 +32,9 @@ USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12 gnomehier
WANT_GNOME= yes
-AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
-FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
- s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
.undef WITHOUT_GNOME
@@ -61,9 +57,13 @@ BROKEN= "This port cannot be built when textproc/wv is installed because of a he
.endif
pre-configure:
- @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog
+ @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
@cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
@${RM} -f ${WRKSRC}/configure.ac
+ @cd ${WRKSRC} && ./autogen.sh && ${TRUE}
+ @${FIND} ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
+ s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/editors/abiword-devel/distinfo b/editors/abiword-devel/distinfo
index b72963643bfa..6dd051c40b56 100644
--- a/editors/abiword-devel/distinfo
+++ b/editors/abiword-devel/distinfo
@@ -1 +1 @@
-MD5 (AbiWord/abiword-1.0.3.tar.gz) = 01336526136b7fbc66328d80931710e3
+MD5 (AbiWord/abiword-1.0.4.tar.gz) = fec2f2770c29afe0d30e653b5d1d40bb
diff --git a/editors/abiword-devel/pkg-plist b/editors/abiword-devel/pkg-plist
index 38ab444526e6..442011e86d58 100644
--- a/editors/abiword-devel/pkg-plist
+++ b/editors/abiword-devel/pkg-plist
@@ -216,6 +216,7 @@ share/AbiSuite/AbiWord/strings/fi-FI.strings
share/AbiSuite/AbiWord/strings/fr-FR.strings
share/AbiSuite/AbiWord/strings/ga-IE.strings
share/AbiSuite/AbiWord/strings/gl-ES.strings
+share/AbiSuite/AbiWord/strings/he-IL.strings
share/AbiSuite/AbiWord/strings/hu-HU.strings
share/AbiSuite/AbiWord/strings/id-ID.strings
share/AbiSuite/AbiWord/strings/it-IT.strings
@@ -231,9 +232,11 @@ share/AbiSuite/AbiWord/strings/ro-RO.strings
share/AbiSuite/AbiWord/strings/ru-RU.strings
share/AbiSuite/AbiWord/strings/sk-SK.strings
share/AbiSuite/AbiWord/strings/sl-SI.strings
+share/AbiSuite/AbiWord/strings/sr-SR.strings
share/AbiSuite/AbiWord/strings/sv-SE.strings
share/AbiSuite/AbiWord/strings/tr-TR.strings
share/AbiSuite/AbiWord/strings/uk-UA.strings
+share/AbiSuite/AbiWord/strings/vi-VN.strings
share/AbiSuite/AbiWord/strings/zh-CN.strings
share/AbiSuite/AbiWord/strings/zh-HK.strings
share/AbiSuite/AbiWord/strings/zh-TW.strings
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 4f498c3cb00b..3eca7f48bac2 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= AbiWord
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.abisource.com/downloads/Version-${PORTVERSION}/lf/
@@ -32,13 +32,9 @@ USE_REINPLACE= yes
USE_GNOMENG= yes
USE_GNOME= gtk12 gnomehier
WANT_GNOME= yes
-AUTOMAKE= ${WRKSRC}/autogen.sh && ${FIXME}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -liconv"
MAKEFILE= GNUmakefile
-FIXME= find ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
- s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
.if defined(PACKAGE_BUILDING) || defined(PARALLEL_PACKAGE_BUILD)
.undef WITHOUT_GNOME
@@ -61,9 +57,13 @@ BROKEN= "This port cannot be built when textproc/wv is installed because of a he
.endif
pre-configure:
- @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog
+ @cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS ChangeLog INSTALL
@cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
@${RM} -f ${WRKSRC}/configure.ac
+ @cd ${WRKSRC} && ./autogen.sh && ${TRUE}
+ @${FIND} ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
+ s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/editors/abiword/distinfo b/editors/abiword/distinfo
index b72963643bfa..6dd051c40b56 100644
--- a/editors/abiword/distinfo
+++ b/editors/abiword/distinfo
@@ -1 +1 @@
-MD5 (AbiWord/abiword-1.0.3.tar.gz) = 01336526136b7fbc66328d80931710e3
+MD5 (AbiWord/abiword-1.0.4.tar.gz) = fec2f2770c29afe0d30e653b5d1d40bb
diff --git a/editors/abiword/pkg-plist b/editors/abiword/pkg-plist
index 38ab444526e6..442011e86d58 100644
--- a/editors/abiword/pkg-plist
+++ b/editors/abiword/pkg-plist
@@ -216,6 +216,7 @@ share/AbiSuite/AbiWord/strings/fi-FI.strings
share/AbiSuite/AbiWord/strings/fr-FR.strings
share/AbiSuite/AbiWord/strings/ga-IE.strings
share/AbiSuite/AbiWord/strings/gl-ES.strings
+share/AbiSuite/AbiWord/strings/he-IL.strings
share/AbiSuite/AbiWord/strings/hu-HU.strings
share/AbiSuite/AbiWord/strings/id-ID.strings
share/AbiSuite/AbiWord/strings/it-IT.strings
@@ -231,9 +232,11 @@ share/AbiSuite/AbiWord/strings/ro-RO.strings
share/AbiSuite/AbiWord/strings/ru-RU.strings
share/AbiSuite/AbiWord/strings/sk-SK.strings
share/AbiSuite/AbiWord/strings/sl-SI.strings
+share/AbiSuite/AbiWord/strings/sr-SR.strings
share/AbiSuite/AbiWord/strings/sv-SE.strings
share/AbiSuite/AbiWord/strings/tr-TR.strings
share/AbiSuite/AbiWord/strings/uk-UA.strings
+share/AbiSuite/AbiWord/strings/vi-VN.strings
share/AbiSuite/AbiWord/strings/zh-CN.strings
share/AbiSuite/AbiWord/strings/zh-HK.strings
share/AbiSuite/AbiWord/strings/zh-TW.strings