aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/go-compress/Makefile3
-rw-r--r--databases/gomdb/Makefile3
-rw-r--r--databases/gosqlite3/Makefile3
-rw-r--r--databases/levigo/Makefile3
-rw-r--r--databases/radix.v2/Makefile3
-rw-r--r--databases/redigo/Makefile3
-rw-r--r--devel/go-bayesian/Makefile3
-rw-r--r--devel/go-cobra/Makefile3
-rw-r--r--devel/go-codec/Makefile3
-rw-r--r--devel/go-cpuid/Makefile3
-rw-r--r--devel/go-crc32/Makefile3
-rw-r--r--devel/go-faker/Makefile3
-rw-r--r--devel/go-form/Makefile3
-rw-r--r--devel/go-go.uuid/Makefile3
-rw-r--r--devel/go-goregen/Makefile3
-rw-r--r--devel/go-hashicorp-logutils/Makefile3
-rw-r--r--devel/go-logrus/Makefile3
-rw-r--r--devel/go-metrics/Makefile3
-rw-r--r--devel/go-nuid/Makefile3
-rw-r--r--devel/go-pflag/Makefile3
-rw-r--r--devel/go-raw/Makefile3
-rw-r--r--devel/go-runewidth/Makefile3
-rw-r--r--devel/go-slices/Makefile3
-rw-r--r--devel/go-uuid/Makefile3
-rw-r--r--devel/go-yaml/Makefile3
-rw-r--r--net/go-amqp/Makefile3
-rw-r--r--net/go-httppath/Makefile3
-rw-r--r--net/go-httptreemux/Makefile3
-rw-r--r--net/go-nats/Makefile3
-rw-r--r--net/go.net/Makefile3
-rw-r--r--security/go.crypto/Makefile3
-rw-r--r--security/goptlib/Makefile3
-rw-r--r--textproc/go.text/Makefile3
-rw-r--r--www/go-fasthttp/Makefile3
-rw-r--r--www/unit-go/Makefile3
-rw-r--r--www/webgo/Makefile3
36 files changed, 108 insertions, 0 deletions
diff --git a/archivers/go-compress/Makefile b/archivers/go-compress/Makefile
index 62df9d4ec5a1..0ed2b278da30 100644
--- a/archivers/go-compress/Makefile
+++ b/archivers/go-compress/Makefile
@@ -12,6 +12,9 @@ COMMENT= Go optimised compression packages
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
BUILD_DEPENDS= go-cpuid>=0:devel/go-cpuid \
go-crc32>=0:devel/go-crc32
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/databases/gomdb/Makefile b/databases/gomdb/Makefile
index b5b41864218e..54da4b291e6d 100644
--- a/databases/gomdb/Makefile
+++ b/databases/gomdb/Makefile
@@ -10,6 +10,9 @@ COMMENT= Go wrapper for LMDB - OpenLDAP Lightning Memory-Mapped Database
LICENSE= BSD3CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
BUILD_DEPENDS= go:lang/go
ONLY_FOR_ARCHS= i386 amd64
diff --git a/databases/gosqlite3/Makefile b/databases/gosqlite3/Makefile
index 4adc16cd4d97..a0f92bbcd6d6 100644
--- a/databases/gosqlite3/Makefile
+++ b/databases/gosqlite3/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= LOCAL/jlaffaye
MAINTAINER= lichray@gmail.com
COMMENT= Go interface for SQLite3
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USES= compiler go
LIB_DEPENDS+= libsqlite3.so:databases/sqlite3
diff --git a/databases/levigo/Makefile b/databases/levigo/Makefile
index 6d098004ce8c..ab0e07130687 100644
--- a/databases/levigo/Makefile
+++ b/databases/levigo/Makefile
@@ -10,6 +10,9 @@ COMMENT= Levigo is a Go wrapper for LevelDB
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
BUILD_DEPENDS= go:lang/go
LIB_DEPENDS= libleveldb.so:databases/leveldb
diff --git a/databases/radix.v2/Makefile b/databases/radix.v2/Makefile
index b2eb3b98c881..bc039a2b0ee0 100644
--- a/databases/radix.v2/Makefile
+++ b/databases/radix.v2/Makefile
@@ -9,6 +9,9 @@ COMMENT= Redis client for Go
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= mediocregopher
GH_TAGNAME= ae04b3eb3731f94789205d1268e0759371166605
diff --git a/databases/redigo/Makefile b/databases/redigo/Makefile
index 62230e2a89ec..2b2de4a9c2c5 100644
--- a/databases/redigo/Makefile
+++ b/databases/redigo/Makefile
@@ -12,6 +12,9 @@ COMMENT= Go client for the Redis database
LICENSE= APACHE20
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= garyburd
USES= go
diff --git a/devel/go-bayesian/Makefile b/devel/go-bayesian/Makefile
index 88d7dda00095..f89124cd87ff 100644
--- a/devel/go-bayesian/Makefile
+++ b/devel/go-bayesian/Makefile
@@ -11,6 +11,9 @@ COMMENT= Naive Bayesian classification for Go
LICENSE= BSD3CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= jbrukh
GH_TAGNAME= a65fd1effddb7bd71c6bb6ca1876e045a7aeac6e
diff --git a/devel/go-cobra/Makefile b/devel/go-cobra/Makefile
index b7499fc6680f..165e548c1fc1 100644
--- a/devel/go-cobra/Makefile
+++ b/devel/go-cobra/Makefile
@@ -11,6 +11,9 @@ COMMENT= Commander for modern Go CLI interactions
LICENSE= APACHE20
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/github.com/spf13/pflag.a:devel/go-pflag
USE_GITHUB= yes
diff --git a/devel/go-codec/Makefile b/devel/go-codec/Makefile
index 58ee18a2a79f..a2d85a94a041 100644
--- a/devel/go-codec/Makefile
+++ b/devel/go-codec/Makefile
@@ -11,6 +11,9 @@ COMMENT= Idiomatic codec and rpc lib
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= ugorji
GH_PROJECT= go
diff --git a/devel/go-cpuid/Makefile b/devel/go-cpuid/Makefile
index d5a8095fcc3a..a68c3cad745c 100644
--- a/devel/go-cpuid/Makefile
+++ b/devel/go-cpuid/Makefile
@@ -12,6 +12,9 @@ COMMENT= Cpuid provides information about the CPU running the current program
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= klauspost
USES= go
diff --git a/devel/go-crc32/Makefile b/devel/go-crc32/Makefile
index 2157abb35e3a..095b531a12ff 100644
--- a/devel/go-crc32/Makefile
+++ b/devel/go-crc32/Makefile
@@ -12,6 +12,9 @@ COMMENT= CRC32 hash with x64 optimizations for go
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= klauspost
USES= go
diff --git a/devel/go-faker/Makefile b/devel/go-faker/Makefile
index 19b5e7c14ca1..5216eb40d0cf 100644
--- a/devel/go-faker/Makefile
+++ b/devel/go-faker/Makefile
@@ -11,6 +11,9 @@ COMMENT= Generate fake data in go
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= manveru
GH_TAGNAME= 717f7cf83fb78669bfab612749c2e8ff63d5be11
diff --git a/devel/go-form/Makefile b/devel/go-form/Makefile
index 2bcc3a1679cf..3d35e9de81cc 100644
--- a/devel/go-form/Makefile
+++ b/devel/go-form/Makefile
@@ -11,6 +11,9 @@ COMMENT= Form Encoding & Decoding Package for Go
LICENSE= BSD3CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= ajg
GH_TAGNAME= 7ff89c75808766205bfa4411abb436c98c33eb5e
diff --git a/devel/go-go.uuid/Makefile b/devel/go-go.uuid/Makefile
index 5ed0d73258d3..ed23f010e715 100644
--- a/devel/go-go.uuid/Makefile
+++ b/devel/go-go.uuid/Makefile
@@ -12,6 +12,9 @@ COMMENT= UUID package for Go
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= satori
USES= go
diff --git a/devel/go-goregen/Makefile b/devel/go-goregen/Makefile
index 0a91a03c13bf..fa8274b6a7b7 100644
--- a/devel/go-goregen/Makefile
+++ b/devel/go-goregen/Makefile
@@ -11,6 +11,9 @@ COMMENT= randexp for Go
LICENSE= APACHE20
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= zach-klippenstein
GH_TAGNAME= 795b5e3961ea1912fde60af417ad85e86acc0d6a
diff --git a/devel/go-hashicorp-logutils/Makefile b/devel/go-hashicorp-logutils/Makefile
index 5330c1a5dae2..23c1ea087a5f 100644
--- a/devel/go-hashicorp-logutils/Makefile
+++ b/devel/go-hashicorp-logutils/Makefile
@@ -11,6 +11,9 @@ COMMENT= Utilities for slightly better logging in Go (Golang)
LICENSE= BSD2CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USES= go
USE_GITHUB= yes
GH_ACCOUNT= hashicorp
diff --git a/devel/go-logrus/Makefile b/devel/go-logrus/Makefile
index f729c1fc71b1..0a538b04fadf 100644
--- a/devel/go-logrus/Makefile
+++ b/devel/go-logrus/Makefile
@@ -12,6 +12,9 @@ COMMENT= Structured, pluggable logging for Go
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= Sirupsen
USES= go
diff --git a/devel/go-metrics/Makefile b/devel/go-metrics/Makefile
index 0f2e59d9573a..516ca3a587fa 100644
--- a/devel/go-metrics/Makefile
+++ b/devel/go-metrics/Makefile
@@ -9,6 +9,9 @@ COMMENT= Golang library for exporting performance and runtime metrics
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= armon
GH_TAGNAME= fbf75676ee9c0a3a23eb0a4d9220a3612cfbd1ed
diff --git a/devel/go-nuid/Makefile b/devel/go-nuid/Makefile
index bced1d9da6cd..b38e5a4b7477 100644
--- a/devel/go-nuid/Makefile
+++ b/devel/go-nuid/Makefile
@@ -11,6 +11,9 @@ COMMENT= NATS unique identifier generator library
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USES= go
USE_GITHUB= yes
GH_ACCOUNT= nats-io
diff --git a/devel/go-pflag/Makefile b/devel/go-pflag/Makefile
index 7b14f83e8495..8cb3f4a266c2 100644
--- a/devel/go-pflag/Makefile
+++ b/devel/go-pflag/Makefile
@@ -11,6 +11,9 @@ COMMENT= Drop-in replacement for Go's flag package
LICENSE= BSD3CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= spf13
GH_TAGNAME= 367864438f1b1a3c7db4da06a2f55b144e6784e0
diff --git a/devel/go-raw/Makefile b/devel/go-raw/Makefile
index ee9f53067c5a..44f71244a651 100644
--- a/devel/go-raw/Makefile
+++ b/devel/go-raw/Makefile
@@ -8,6 +8,9 @@ PKGNAMEPREFIX= go-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Go library for high-level interface to unsafe and reflection packages
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
#LICENSE= MIT based, but with no-evil clause
USES= go
diff --git a/devel/go-runewidth/Makefile b/devel/go-runewidth/Makefile
index 67a148bf0f5a..f0a0b84f150f 100644
--- a/devel/go-runewidth/Makefile
+++ b/devel/go-runewidth/Makefile
@@ -11,6 +11,9 @@ COMMENT= Go library to get the fixed width of a character or string
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USES= go
USE_GITHUB= yes
GH_ACCOUNT= mattn
diff --git a/devel/go-slices/Makefile b/devel/go-slices/Makefile
index 84e74954c6d1..dbc172b164b5 100644
--- a/devel/go-slices/Makefile
+++ b/devel/go-slices/Makefile
@@ -8,6 +8,9 @@ PKGNAMEPREFIX= go-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Go library for slice-based datatypes
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
#LICENSE= MIT based, with no-evli clause
BUILD_DEPENDS= go-raw>0:devel/go-raw
diff --git a/devel/go-uuid/Makefile b/devel/go-uuid/Makefile
index 9ee02386cba3..9ab3367170ae 100644
--- a/devel/go-uuid/Makefile
+++ b/devel/go-uuid/Makefile
@@ -12,6 +12,9 @@ COMMENT= Go library to generates and inspects UUIDs based on RFC 4122
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USES= go
REVISION= 35bc42037350
WRKSRC= ${WRKDIR}/go-uuid-${REVISION}
diff --git a/devel/go-yaml/Makefile b/devel/go-yaml/Makefile
index fe7fc11299ae..792750b0d0a6 100644
--- a/devel/go-yaml/Makefile
+++ b/devel/go-yaml/Makefile
@@ -11,6 +11,9 @@ COMMENT= YAML support for the Go language
LICENSE= LGPL3
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= go-yaml
GH_TAGNAME= a83829b6f1293c91addabc89d0571c246397bbf4
diff --git a/net/go-amqp/Makefile b/net/go-amqp/Makefile
index 1a345a1a27b0..01fb5c4d8164 100644
--- a/net/go-amqp/Makefile
+++ b/net/go-amqp/Makefile
@@ -10,6 +10,9 @@ COMMENT= Go library for AMQP client with RabbitMQ extensions
LICENSE= BSD2CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USES= go
USE_GITHUB= yes
GH_ACCOUNT= streadway
diff --git a/net/go-httppath/Makefile b/net/go-httppath/Makefile
index e9e9dce20c26..66797de9db9b 100644
--- a/net/go-httppath/Makefile
+++ b/net/go-httppath/Makefile
@@ -10,6 +10,9 @@ COMMENT= Utilities for HTTP Path manipulation
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= dimfeld
GH_TAGNAME= c8e499c3ef3c3e272ed8bdcc1ccf39f73c88debc
diff --git a/net/go-httptreemux/Makefile b/net/go-httptreemux/Makefile
index 8e295a39a755..ba0512bd071f 100644
--- a/net/go-httptreemux/Makefile
+++ b/net/go-httptreemux/Makefile
@@ -11,6 +11,9 @@ COMMENT= High-speed, flexible, tree-based HTTP router for Go
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/github.com/dimfeld/httppath.a:net/go-httppath
USE_GITHUB= yes
diff --git a/net/go-nats/Makefile b/net/go-nats/Makefile
index 8b695bb87230..9aa0cb131879 100644
--- a/net/go-nats/Makefile
+++ b/net/go-nats/Makefile
@@ -10,6 +10,9 @@ COMMENT= Go client for NATS
LICENSE= MIT
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
BUILD_DEPENDS= go-nuid>=0:devel/go-nuid
USES= go
diff --git a/net/go.net/Makefile b/net/go.net/Makefile
index ef839ebfc9b9..0293f91db6e5 100644
--- a/net/go.net/Makefile
+++ b/net/go.net/Makefile
@@ -11,6 +11,9 @@ COMMENT= Additional Net packages for Go
LICENSE= BSD3CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/golang.org/x/text/cases.a:textproc/go.text \
go.crypto>=20160709:security/go.crypto
diff --git a/security/go.crypto/Makefile b/security/go.crypto/Makefile
index 8332ff9e6672..d7c918c36071 100644
--- a/security/go.crypto/Makefile
+++ b/security/go.crypto/Makefile
@@ -9,6 +9,9 @@ COMMENT= Additional cryptography packages for Go
LICENSE= BSD3CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= golang
GH_PROJECT= crypto
diff --git a/security/goptlib/Makefile b/security/goptlib/Makefile
index 375844b9b261..68159eb2cada 100644
--- a/security/goptlib/Makefile
+++ b/security/goptlib/Makefile
@@ -8,6 +8,9 @@ MASTER_SITES= http://c-s.li/ports/
MAINTAINER= cs@FreeBSD.org
COMMENT= Go pluggable transports library
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USES= go
GO_PKGNAME= git.torproject.org/pluggable-transports/${PORTNAME}.git
GO_TARGET= ${GO_PKGNAME}
diff --git a/textproc/go.text/Makefile b/textproc/go.text/Makefile
index 193d6e897e24..e452a02611e6 100644
--- a/textproc/go.text/Makefile
+++ b/textproc/go.text/Makefile
@@ -10,6 +10,9 @@ COMMENT= Additional textproc packages for Go
LICENSE= BSD3CLAUSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USE_GITHUB= yes
GH_ACCOUNT= golang
GH_PROJECT= text
diff --git a/www/go-fasthttp/Makefile b/www/go-fasthttp/Makefile
index 3ebad20c003a..567495bf57c4 100644
--- a/www/go-fasthttp/Makefile
+++ b/www/go-fasthttp/Makefile
@@ -12,6 +12,9 @@ COMMENT= Fast HTTP package for Go, tuned for high performance
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
BUILD_DEPENDS= go-compress>=0:archivers/go-compress \
go-cpuid>=0:devel/go-cpuid \
go-crc32>=0:devel/go-crc32
diff --git a/www/unit-go/Makefile b/www/unit-go/Makefile
index aabda43a63d9..0fa1b369ee06 100644
--- a/www/unit-go/Makefile
+++ b/www/unit-go/Makefile
@@ -5,6 +5,9 @@ PKGNAMESUFFIX= -go
COMMENT= Go module for NGINX Unit
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
USES= go
PLIST_FILES= # reset to empty
diff --git a/www/webgo/Makefile b/www/webgo/Makefile
index 11174e59b533..a5da62b4eb89 100644
--- a/www/webgo/Makefile
+++ b/www/webgo/Makefile
@@ -11,6 +11,9 @@ DISTNAME= ${PORTNAME}-${SVNVERSION}
MAINTAINER= wen@FreeBSD.org
COMMENT= Simplest way to write web applications in the Go programming language
+DEPRECATED= Go libraries should not be packaged
+EXPIRATION_DATE= 2019-03-31
+
SVNVERSION= 20120419
USES= go