aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/rudiments/Makefile8
-rw-r--r--devel/rudiments/files/patch-include_rudiments_serialportprofile.h18
2 files changed, 19 insertions, 7 deletions
diff --git a/devel/rudiments/Makefile b/devel/rudiments/Makefile
index 248713db20da..6611519cda77 100644
--- a/devel/rudiments/Makefile
+++ b/devel/rudiments/Makefile
@@ -24,10 +24,4 @@ CONFIGURE_ARGS= --with-ssl-includes=-I${OPENSSLINC} \
--disable-pcre
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800045
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/rudiments/files/patch-include_rudiments_serialportprofile.h b/devel/rudiments/files/patch-include_rudiments_serialportprofile.h
new file mode 100644
index 000000000000..84af87654eb2
--- /dev/null
+++ b/devel/rudiments/files/patch-include_rudiments_serialportprofile.h
@@ -0,0 +1,18 @@
+--- include/rudiments/serialportprofile.h
++++ include/rudiments/serialportprofile.h
+@@ -129,9 +129,15 @@
+
+ #ifdef TABDLY
+ enum tabdelay_t {
++ #ifdef TAB0
+ td_none=TAB0,
++ #endif
++ #ifdef TAB1
+ td_depends=TAB1,
++ #endif
++ #ifdef TAB2
+ td_100=TAB2
++ #endif
+ };
+ #endif
+