aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/py-wolframalpha/Makefile20
-rw-r--r--net/py-wolframalpha/distinfo2
-rw-r--r--net/py-wolframalpha/pkg-descr3
4 files changed, 26 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 829401f163aa..6c506ee96325 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -917,6 +917,7 @@
SUBDIR += py-twitter-tools
SUBDIR += py-txamqp
SUBDIR += py-urllib3
+ SUBDIR += py-wolframalpha
SUBDIR += py-xmlrpc
SUBDIR += py-xmlrpclib
SUBDIR += py-yadis
diff --git a/net/py-wolframalpha/Makefile b/net/py-wolframalpha/Makefile
new file mode 100644
index 000000000000..5761fd47b303
--- /dev/null
+++ b/net/py-wolframalpha/Makefile
@@ -0,0 +1,20 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wolframalpha
+PORTVERSION= 1.2
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Python Client for Wolfram Alpha
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hgtools>0:${PORTSDIR}/devel/py-hgtools \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:${PORTSDIR}/devel/py-pytest-runner
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4:${PORTSDIR}/devel/py-six
+
+USES= python:2 zip
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-wolframalpha/distinfo b/net/py-wolframalpha/distinfo
new file mode 100644
index 000000000000..7286309a1920
--- /dev/null
+++ b/net/py-wolframalpha/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wolframalpha-1.2.zip) = 71b5fc99e7b34d86becb3836b67a909b9515cf48b35fb217b794bae099de3bcc
+SIZE (wolframalpha-1.2.zip) = 6318
diff --git a/net/py-wolframalpha/pkg-descr b/net/py-wolframalpha/pkg-descr
new file mode 100644
index 000000000000..e20e13de0a47
--- /dev/null
+++ b/net/py-wolframalpha/pkg-descr
@@ -0,0 +1,3 @@
+Python Client built against the Wolfram|Alpha v2.0 API
+
+WWW: https://bitbucket.org/jaraco/wolframalpha