aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/fstrm/Makefile35
-rw-r--r--devel/fstrm/distinfo2
-rw-r--r--devel/fstrm/pkg-descr10
-rw-r--r--devel/fstrm/pkg-plist15
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2948ea7ef3a7..e1c326434ee7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -471,6 +471,7 @@
SUBDIR += frama-c
SUBDIR += freeocl
SUBDIR += frink
+ SUBDIR += fstrm
SUBDIR += ftjam
SUBDIR += ftnchek
SUBDIR += fuel
diff --git a/devel/fstrm/Makefile b/devel/fstrm/Makefile
new file mode 100644
index 000000000000..9faa68430189
--- /dev/null
+++ b/devel/fstrm/Makefile
@@ -0,0 +1,35 @@
+# Created by: Leo Vandewoestijne <freebsd@dns-lab.com>
+# $FreeBSD$
+
+PORTNAME= fstrm
+PORTVERSION= 0.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= freebsd@dns-lab.com
+COMMENT= Implementation of the Frame Streams data transport protocol in C
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
+
+USE_GITHUB= yes
+GH_ACCOUNT= farsightsec
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= automake autoconf:env libtoolize
+USE_LDCONFIG= yes
+USES= libtool gmake pkgconfig
+
+OPTIONS_DEFINE= DOXYGEN
+DOXYGEN_DESC= Use doxygen for docs
+DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+DOXYGEN_ALL_TARGET= html-local
+
+PORTDOCS= *
+
+run-autotools:
+ cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ./autogen.sh
+
+.include <bsd.port.mk>
diff --git a/devel/fstrm/distinfo b/devel/fstrm/distinfo
new file mode 100644
index 000000000000..2589b8c16928
--- /dev/null
+++ b/devel/fstrm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fstrm-v0.2.0_GH0.tar.gz) = bb171e886b2e3aaf1920b6c003f69705bd038703884546ff627f4740bd391c19
+SIZE (fstrm-v0.2.0_GH0.tar.gz) = 184435
diff --git a/devel/fstrm/pkg-descr b/devel/fstrm/pkg-descr
new file mode 100644
index 000000000000..7a29d4f2aad4
--- /dev/null
+++ b/devel/fstrm/pkg-descr
@@ -0,0 +1,10 @@
+fstrm is an optimized C implementation of Frame Streams that
+includes a fast, lockless circular queue implementation
+and exposes library interfaces for setting up a dedicated
+Frame Streams I/O thread and asynchronously submitting data
+frames for transport from worker threads. It was originally
+written to facilitate the addition of high speed binary
+logging to DNS servers written in C using the dnstap
+log format.
+
+WWW: https://github.com/farsightsec/fstrm
diff --git a/devel/fstrm/pkg-plist b/devel/fstrm/pkg-plist
new file mode 100644
index 000000000000..d8803dd41432
--- /dev/null
+++ b/devel/fstrm/pkg-plist
@@ -0,0 +1,15 @@
+bin/fstrm_capture
+bin/fstrm_dump
+include/fstrm.h
+include/fstrm/control.h
+include/fstrm/file.h
+include/fstrm/iothr.h
+include/fstrm/rdwr.h
+include/fstrm/reader.h
+include/fstrm/unix_writer.h
+include/fstrm/writer.h
+lib/libfstrm.a
+lib/libfstrm.so
+lib/libfstrm.so.0
+lib/libfstrm.so.0.0.0
+libdata/pkgconfig/libfstrm.pc