aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-VM-EC2-Security-CredentialCache/Makefile23
-rw-r--r--net/p5-VM-EC2-Security-CredentialCache/distinfo2
-rw-r--r--net/p5-VM-EC2-Security-CredentialCache/pkg-descr6
-rw-r--r--net/p5-VM-EC2-Security-CredentialCache/pkg-plist2
5 files changed, 34 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4232b823a213..8947308068fb 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -761,6 +761,7 @@
SUBDIR += p5-URI-Template-Restrict
SUBDIR += p5-URI-ws
SUBDIR += p5-VM-EC2
+ SUBDIR += p5-VM-EC2-Security-CredentialCache
SUBDIR += p5-Validate-Net
SUBDIR += p5-WebService-Dropbox
SUBDIR += p5-WebService-Prowl
diff --git a/net/p5-VM-EC2-Security-CredentialCache/Makefile b/net/p5-VM-EC2-Security-CredentialCache/Makefile
new file mode 100644
index 000000000000..9a2242232649
--- /dev/null
+++ b/net/p5-VM-EC2-Security-CredentialCache/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= VM-EC2-Security-CredentialCache
+PORTVERSION= 0.21
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Cache credentials respecting expriation time for IAM roles
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-DateTime-Format-ISO8601>=0:${PORTSDIR}/devel/p5-DateTime-Format-ISO8601 \
+ p5-VM-EC2>=0:${PORTSDIR}/net/p5-VM-EC2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/net/p5-VM-EC2-Security-CredentialCache/distinfo b/net/p5-VM-EC2-Security-CredentialCache/distinfo
new file mode 100644
index 000000000000..ac9c8ee8f8bc
--- /dev/null
+++ b/net/p5-VM-EC2-Security-CredentialCache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (VM-EC2-Security-CredentialCache-0.21.tar.gz) = 4ad05e5524984314b9c708b0e7bd8a63dfdd6ecfc423c6fb301e2e30d130931b
+SIZE (VM-EC2-Security-CredentialCache-0.21.tar.gz) = 9617
diff --git a/net/p5-VM-EC2-Security-CredentialCache/pkg-descr b/net/p5-VM-EC2-Security-CredentialCache/pkg-descr
new file mode 100644
index 000000000000..8a29577b104d
--- /dev/null
+++ b/net/p5-VM-EC2-Security-CredentialCache/pkg-descr
@@ -0,0 +1,6 @@
+This module provides a cache for an EC2's IAM credentials represented by
+VM::EC2::Security::Credentials. Rather than retriving the credentials for every
+possible call that uses them, cache them until they expire and retreive them
+again if they have expired.
+
+WWW: http://search.cpan.org/dist/VM-EC2-Security-CredentialCache/
diff --git a/net/p5-VM-EC2-Security-CredentialCache/pkg-plist b/net/p5-VM-EC2-Security-CredentialCache/pkg-plist
new file mode 100644
index 000000000000..6ee7d66eb735
--- /dev/null
+++ b/net/p5-VM-EC2-Security-CredentialCache/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/VM/EC2/Security/CredentialCache.pm
+%%PERL5_MAN3%%/VM::EC2::Security::CredentialCache.3.gz