aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/p5-GPS-OID/Makefile3
-rw-r--r--astro/p5-Starlink-AST/Makefile3
-rw-r--r--biology/p5-Bio-SCF/Makefile3
-rw-r--r--biology/p5-bioperl/Makefile3
-rw-r--r--databases/p5-Test-Cukes/Makefile9
-rw-r--r--devel/p5-Exporter-Easy/Makefile9
-rw-r--r--devel/p5-ExtUtils-LibBuilder/Makefile9
-rw-r--r--devel/p5-File-ShareDir-PathClass/Makefile9
-rw-r--r--devel/p5-Find-Lib/Makefile9
-rw-r--r--devel/p5-Import-Into/Makefile3
-rw-r--r--devel/p5-MooX-Types-MooseLike-Numeric/Makefile3
-rw-r--r--devel/p5-MooseX-MultiMethods/Makefile9
-rw-r--r--devel/p5-MooseX-Types-VariantTable/Makefile9
-rw-r--r--devel/p5-Sub-Exporter-ForMethods/Makefile9
-rw-r--r--devel/p5-Test-Script-Run/Makefile9
-rw-r--r--devel/p5-Tree-Binary/Makefile3
-rw-r--r--graphics/p5-Google-Chart/Makefile9
-rw-r--r--graphics/p5-Graphics-GnuplotIF/Makefile9
-rw-r--r--math/p5-GIS-Distance-Lite/Makefile3
-rw-r--r--math/p5-Math-Random-ISAAC-XS/Makefile3
-rw-r--r--math/p5-Math-Random-ISAAC/Makefile9
-rw-r--r--math/p5-Statistics-Benford/Makefile9
-rw-r--r--misc/p5-Geo-Coder-Multiple/Makefile3
-rw-r--r--misc/p5-List-Util-WeightedRoundRobin/Makefile8
-rw-r--r--net/p5-Net-LDAP-Server/Makefile9
-rw-r--r--net/p5-Rose-URI/Makefile9
-rw-r--r--science/p5-Geo-ReadGRIB/Makefile9
-rw-r--r--security/p5-Jifty-Plugin-OpenID/Makefile9
-rw-r--r--textproc/p5-LaTeX-Pod/Makefile9
-rw-r--r--textproc/p5-LaTeX-ToUnicode/Makefile9
-rw-r--r--textproc/p5-Pod-HtmlEasy/Makefile9
-rw-r--r--textproc/p5-XML-Hash-LX/Makefile9
32 files changed, 86 insertions, 141 deletions
diff --git a/astro/p5-GPS-OID/Makefile b/astro/p5-GPS-OID/Makefile
index ec37bb8a0181..996c8a3db59c 100644
--- a/astro/p5-GPS-OID/Makefile
+++ b/astro/p5-GPS-OID/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wen@FreeBSD.org
COMMENT= Package for GPS PRN - Object ID conversions
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GPS::OID.3
diff --git a/astro/p5-Starlink-AST/Makefile b/astro/p5-Starlink-AST/Makefile
index a5f3bfcbf22f..c731055b012c 100644
--- a/astro/p5-Starlink-AST/Makefile
+++ b/astro/p5-Starlink-AST/Makefile
@@ -14,7 +14,8 @@ COMMENT= Interface to the Starlink AST library
BUILD_DEPENDS= p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta
RUN_DEPENDS= p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Starlink::AST.3 \
Starlink::AST::PGPLOT.3 \
diff --git a/biology/p5-Bio-SCF/Makefile b/biology/p5-Bio-SCF/Makefile
index e80819d3319f..fc9ac1ff9afd 100644
--- a/biology/p5-Bio-SCF/Makefile
+++ b/biology/p5-Bio-SCF/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Bio::SCF.3
diff --git a/biology/p5-bioperl/Makefile b/biology/p5-bioperl/Makefile
index 69ce1c3dc892..d876b0575614 100644
--- a/biology/p5-bioperl/Makefile
+++ b/biology/p5-bioperl/Makefile
@@ -58,7 +58,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
#CONFLICTS= p5-bioperl-1.[13579]*
-PERL_MODBUILD= YES
+USES= perl5
+USE_PERL5= modbuild
MAN1= bp_aacomp.pl.1 \
bp_biblio.pl.1 \
diff --git a/databases/p5-Test-Cukes/Makefile b/databases/p5-Test-Cukes/Makefile
index b9a69a7ea4cd..c967f7f32d7a 100644
--- a/databases/p5-Test-Cukes/Makefile
+++ b/databases/p5-Test-Cukes/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-Cukes
-# Date created: 26 Aug, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Test-Cukes
PORTVERSION= 0.10
@@ -20,7 +16,8 @@ BUILD_DEPENDS= p5-Any-Moose>=0.10:${PORTSDIR}/devel/p5-Any-Moose \
p5-Try-Tiny>=0.07:${PORTSDIR}/lang/p5-Try-Tiny
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Cukes.3
diff --git a/devel/p5-Exporter-Easy/Makefile b/devel/p5-Exporter-Easy/Makefile
index 556efa6a9cfb..e75cbfb7f97b 100644
--- a/devel/p5-Exporter-Easy/Makefile
+++ b/devel/p5-Exporter-Easy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Exporter-Easy
-# Date created: 23 Jan, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Exporter-Easy
PORTVERSION= 0.16
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wen@FreeBSD.org
COMMENT= Takes the drudgery out of Exporting symbols
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Exporter::Easy.3 Exporter::Easiest.3
diff --git a/devel/p5-ExtUtils-LibBuilder/Makefile b/devel/p5-ExtUtils-LibBuilder/Makefile
index f14d245a0b8e..9dd32aa09c97 100644
--- a/devel/p5-ExtUtils-LibBuilder/Makefile
+++ b/devel/p5-ExtUtils-LibBuilder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ExtUtils::LibBuilder
-# Date created: 16 Feb 2011
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ExtUtils-LibBuilder
PORTVERSION= 0.04
@@ -16,7 +12,8 @@ COMMENT= Perl module to build C libraries
BUILD_DEPENDS= p5-ExtUtils-CBuilder>=0.27:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= ExtUtils::LibBuilder.3
diff --git a/devel/p5-File-ShareDir-PathClass/Makefile b/devel/p5-File-ShareDir-PathClass/Makefile
index 04cf5512dbaf..a81f5bbbd01a 100644
--- a/devel/p5-File-ShareDir-PathClass/Makefile
+++ b/devel/p5-File-ShareDir-PathClass/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-File-ShareDir-PathClass
-# Date created: Aug 10, 2011
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= File-ShareDir-PathClass
PORTVERSION= 1.112440
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= File::ShareDir::PathClass.3
diff --git a/devel/p5-Find-Lib/Makefile b/devel/p5-Find-Lib/Makefile
index 23117522953b..8ca8d9bd05be 100644
--- a/devel/p5-Find-Lib/Makefile
+++ b/devel/p5-Find-Lib/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Find-Lib
-# Date created: 16 Nov, 2009
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Find-Lib
PORTVERSION= 1.04
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wen@FreeBSD.org
COMMENT= Helper to smartly find libs to use in the filesystem tree
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Find::Lib.3
diff --git a/devel/p5-Import-Into/Makefile b/devel/p5-Import-Into/Makefile
index 05a5fef4f77d..ac8d1d32590d 100644
--- a/devel/p5-Import-Into/Makefile
+++ b/devel/p5-Import-Into/Makefile
@@ -14,7 +14,8 @@ COMMENT= Import packages into other packages
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Import::Into.3
diff --git a/devel/p5-MooX-Types-MooseLike-Numeric/Makefile b/devel/p5-MooX-Types-MooseLike-Numeric/Makefile
index eabcd8382285..67ea96059e31 100644
--- a/devel/p5-MooX-Types-MooseLike-Numeric/Makefile
+++ b/devel/p5-MooX-Types-MooseLike-Numeric/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= p5-MooX-Types-MooseLike>=0.23:${PORTSDIR}/devel/p5-MooX-Types-Moo
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Fatal>=0.003:${PORTSDIR}/devel/p5-Test-Fatal
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooX::Types::MooseLike::Numeric.3
diff --git a/devel/p5-MooseX-MultiMethods/Makefile b/devel/p5-MooseX-MultiMethods/Makefile
index a19248e4136d..ec7c4ba4b259 100644
--- a/devel/p5-MooseX-MultiMethods/Makefile
+++ b/devel/p5-MooseX-MultiMethods/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-MooseX-MultiMethods
-# Date created: Dec 28, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= MooseX-MultiMethods
PORTVERSION= 0.10
@@ -24,7 +20,8 @@ RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooseX::MultiMethods.3 \
MooseX::MultiMethods::Meta::Method.3
diff --git a/devel/p5-MooseX-Types-VariantTable/Makefile b/devel/p5-MooseX-Types-VariantTable/Makefile
index a2aa32d76467..cd47f5d040a8 100644
--- a/devel/p5-MooseX-Types-VariantTable/Makefile
+++ b/devel/p5-MooseX-Types-VariantTable/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-MooseX-Types-VariantTable
-# Date created: Dec 26, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= MooseX-Types-VariantTable
PORTVERSION= 0.04
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-MooseX-Types-Structured>=0.12:${PORTSDIR}/devel/p5-MooseX-Types-
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooseX::Types::VariantTable::Declare.3 \
MooseX::Types::VariantTable.3
diff --git a/devel/p5-Sub-Exporter-ForMethods/Makefile b/devel/p5-Sub-Exporter-ForMethods/Makefile
index 15463a3e3bc4..6daff2a8e61e 100644
--- a/devel/p5-Sub-Exporter-ForMethods/Makefile
+++ b/devel/p5-Sub-Exporter-ForMethods/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Sub-Exporter-ForMethods
-# Date created: May 27, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Sub-Exporter-ForMethods
PORTVERSION= 0.100050
@@ -18,7 +14,8 @@ RUN_DEPENDS= p5-Sub-Name>=0:${PORTSDIR}/devel/p5-Sub-Name \
p5-Sub-Exporter>=0.978:${PORTSDIR}/devel/p5-Sub-Exporter
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sub::Exporter::ForMethods.3
diff --git a/devel/p5-Test-Script-Run/Makefile b/devel/p5-Test-Script-Run/Makefile
index ecbafc7a54b1..c32cbee88ac8 100644
--- a/devel/p5-Test-Script-Run/Makefile
+++ b/devel/p5-Test-Script-Run/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Test-Script-Run
-# Date created: Dec 14, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Test-Script-Run
PORTVERSION= 0.05
@@ -18,7 +14,8 @@ RUN_DEPENDS= p5-IPC-Run3>=0:${PORTSDIR}/devel/p5-IPC-Run3 \
p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Script::Run.3
diff --git a/devel/p5-Tree-Binary/Makefile b/devel/p5-Tree-Binary/Makefile
index 360e52346b79..5492f528ee8b 100644
--- a/devel/p5-Tree-Binary/Makefile
+++ b/devel/p5-Tree-Binary/Makefile
@@ -25,6 +25,7 @@ MAN3= Tree::Binary.3 Tree::Binary::Search.3 \
Tree::Binary::Visitor::PreOrderTraversal.3 \
Tree::Binary::VisitorFactory.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Google-Chart/Makefile b/graphics/p5-Google-Chart/Makefile
index fda84da36060..28d757753246 100644
--- a/graphics/p5-Google-Chart/Makefile
+++ b/graphics/p5-Google-Chart/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Google-Chart
-# Date created: 30 January 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Google-Chart
PORTVERSION= 0.05014
@@ -40,6 +36,7 @@ MAN3= Google::Chart.3 Google::Chart::Axis.3 \
Google::Chart::Margin.3 \
Google::Chart::Types.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/graphics/p5-Graphics-GnuplotIF/Makefile b/graphics/p5-Graphics-GnuplotIF/Makefile
index acd839f481c8..68b27f43b640 100644
--- a/graphics/p5-Graphics-GnuplotIF/Makefile
+++ b/graphics/p5-Graphics-GnuplotIF/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Graphics-GnuplotIF
-# Date Created: Oct 21, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Graphics-GnuplotIF
PORTVERSION= 1.7
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wen@FreeBSD.org
COMMENT= A dynamic Perl interface to gnuplot
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Graphics::GnuplotIF.3
diff --git a/math/p5-GIS-Distance-Lite/Makefile b/math/p5-GIS-Distance-Lite/Makefile
index 5e5ee3df7529..3a615e248a84 100644
--- a/math/p5-GIS-Distance-Lite/Makefile
+++ b/math/p5-GIS-Distance-Lite/Makefile
@@ -14,7 +14,8 @@ COMMENT= Calculate geographic distances in geodetic WGS84 format
RUN_DEPENDS= p5-Math-Complex>1.0.3:${PORTSDIR}/math/p5-Math-Complex
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GIS::Distance::Lite.3 \
diff --git a/math/p5-Math-Random-ISAAC-XS/Makefile b/math/p5-Math-Random-ISAAC-XS/Makefile
index c251e09fae6f..391d2b2d09e4 100644
--- a/math/p5-Math-Random-ISAAC-XS/Makefile
+++ b/math/p5-Math-Random-ISAAC-XS/Makefile
@@ -14,7 +14,8 @@ COMMENT= C implementation of the ISAAC PRNG Algorithm
BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Math::Random::ISAAC::XS.3
diff --git a/math/p5-Math-Random-ISAAC/Makefile b/math/p5-Math-Random-ISAAC/Makefile
index 51d962a1725a..c58a6f8c2e35 100644
--- a/math/p5-Math-Random-ISAAC/Makefile
+++ b/math/p5-Math-Random-ISAAC/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math::Random::ISAAC
-# Date created: 07 Dec, 2009
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Math-Random-ISAAC
PORTVERSION= 1.004
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-Math-Random-ISAAC-XS>0:${PORTSDIR}/math/p5-Math-Random-ISAAC-XS
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::Random::ISAAC::PP.3 \
Math::Random::ISAAC.3
diff --git a/math/p5-Statistics-Benford/Makefile b/math/p5-Statistics-Benford/Makefile
index e1fff6b20428..c2a7414467db 100644
--- a/math/p5-Statistics-Benford/Makefile
+++ b/math/p5-Statistics-Benford/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Statistics-Benford
-# Date created: 03 May, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Statistics-Benford
PORTVERSION= 0.08
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wen@FreeBSD.org
COMMENT= Calculate the deviation from Benford's Law
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Statistics::Benford.3
diff --git a/misc/p5-Geo-Coder-Multiple/Makefile b/misc/p5-Geo-Coder-Multiple/Makefile
index 7badd8db8133..95b59e310df8 100644
--- a/misc/p5-Geo-Coder-Multiple/Makefile
+++ b/misc/p5-Geo-Coder-Multiple/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl module to tie together multiple Geo::Coder modules
RUN_DEPENDS= p5-List-Util-WeightedRoundRobin>=0:${PORTSDIR}/misc/p5-List-Util-WeightedRoundRobin
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::Coder::Multiple.3
diff --git a/misc/p5-List-Util-WeightedRoundRobin/Makefile b/misc/p5-List-Util-WeightedRoundRobin/Makefile
index 6601ca5ba9c6..5c5f04069286 100644
--- a/misc/p5-List-Util-WeightedRoundRobin/Makefile
+++ b/misc/p5-List-Util-WeightedRoundRobin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-List-Util-WeightedRoundRobin
-# Date created: 12th march, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= List-Util-WeightedRoundRobin
PORTVERSION= 0.4
@@ -15,6 +11,8 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= Creates a list based on weighted input
PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= List::Util::WeightedRoundRobin.3
diff --git a/net/p5-Net-LDAP-Server/Makefile b/net/p5-Net-LDAP-Server/Makefile
index c7190c763cae..55167203f5b5 100644
--- a/net/p5-Net-LDAP-Server/Makefile
+++ b/net/p5-Net-LDAP-Server/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Net-LDAP-Server
-# Date created: 2nd Oct, 2009
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Net-LDAP-Server
PORTVERSION= 0.43
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-Convert-ASN1>=0.22:${PORTSDIR}/converters/p5-Convert-ASN1 \
p5-perl-ldap>=0.39:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::LDAP::Server.3
diff --git a/net/p5-Rose-URI/Makefile b/net/p5-Rose-URI/Makefile
index 042f4583378f..63e8be5b55ec 100644
--- a/net/p5-Rose-URI/Makefile
+++ b/net/p5-Rose-URI/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Rose-URI
-# Date created: 18 Nov, 2010
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Rose-URI
PORTVERSION= 1.00
@@ -18,7 +14,8 @@ RUN_DEPENDS= p5-Rose-Object>=0.854:${PORTSDIR}/devel/p5-Rose-Object \
p5-URI>0:${PORTSDIR}/net/p5-URI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Rose::URI.3
diff --git a/science/p5-Geo-ReadGRIB/Makefile b/science/p5-Geo-ReadGRIB/Makefile
index 7061cfff745f..df101b9172b4 100644
--- a/science/p5-Geo-ReadGRIB/Makefile
+++ b/science/p5-Geo-ReadGRIB/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Geo-ReadGRIB
-# Date created: 2009-03-18
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Geo-ReadGRIB
PORTVERSION= 1.21
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wen@FreeBSD.org
COMMENT= Perl module provides read access to GRIB files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Geo::ReadGRIB.3 \
Geo::ReadGRIB::Place.3 \
diff --git a/security/p5-Jifty-Plugin-OpenID/Makefile b/security/p5-Jifty-Plugin-OpenID/Makefile
index 0524c44064e5..c6b38b589c89 100644
--- a/security/p5-Jifty-Plugin-OpenID/Makefile
+++ b/security/p5-Jifty-Plugin-OpenID/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Jifty-Plugin-OpenID
-# Date created: 14 June, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Jifty-Plugin-OpenID
PORTVERSION= 1.02
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-Jifty>=0:${PORTSDIR}/www/p5-Jifty \
p5-LWPx-ParanoidAgent>=0:${PORTSDIR}/www/p5-LWPx-ParanoidAgent
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Jifty::Plugin::OpenID::View.3 \
Jifty::Plugin::OpenID.3 \
diff --git a/textproc/p5-LaTeX-Pod/Makefile b/textproc/p5-LaTeX-Pod/Makefile
index 4c96a93a49c3..8e33cde73012 100644
--- a/textproc/p5-LaTeX-Pod/Makefile
+++ b/textproc/p5-LaTeX-Pod/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: LaTeX-Pod
-# Date created: 10 July, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= LaTeX-Pod
PORTVERSION= 0.21
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-LaTeX-TOM>=0.9:${PORTSDIR}/textproc/p5-LaTeX-TOM \
p5-boolean>=0.20:${PORTSDIR}/devel/p5-boolean
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= latex2pod.1
MAN3= LaTeX::Pod.3
diff --git a/textproc/p5-LaTeX-ToUnicode/Makefile b/textproc/p5-LaTeX-ToUnicode/Makefile
index 448b19bf858c..d64d9ae6fcc5 100644
--- a/textproc/p5-LaTeX-ToUnicode/Makefile
+++ b/textproc/p5-LaTeX-ToUnicode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-LaTeX-ToUnicode
-# Date created: March 16, 2011
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= LaTeX-ToUnicode
PORTVERSION= 0.03
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wen@FreeBSD.org
COMMENT= Convert LaTeX commands to Unicode
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= LaTeX::ToUnicode::Tables.3 \
LaTeX::ToUnicode.3
diff --git a/textproc/p5-Pod-HtmlEasy/Makefile b/textproc/p5-Pod-HtmlEasy/Makefile
index ea88fac819f3..67aa7761c971 100644
--- a/textproc/p5-Pod-HtmlEasy/Makefile
+++ b/textproc/p5-Pod-HtmlEasy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Pod-HtmlEasy
-# Date created: 21 Jan, 201
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Pod-HtmlEasy
PORTVERSION= 1.0108
@@ -24,7 +20,8 @@ BUILD_DEPENDS= p5-version>=0.72:${PORTSDIR}/devel/p5-version \
p5-Pod-Escapes>=0:${PORTSDIR}/textproc/p5-Pod-Escapes
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= pod2indexed_html.pl.1
MAN3= Pod::HtmlEasy.3
diff --git a/textproc/p5-XML-Hash-LX/Makefile b/textproc/p5-XML-Hash-LX/Makefile
index 2c5fcda1a551..c0364b98395d 100644
--- a/textproc/p5-XML-Hash-LX/Makefile
+++ b/textproc/p5-XML-Hash-LX/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-XML-Hash-LX
-# Date created: 09 Dec, 2009
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= XML-Hash-LX
PORTVERSION= 0.0603
@@ -18,7 +14,8 @@ BUILD_DEPENDS= p5-lib-abs>=0.90:${PORTSDIR}/devel/p5-lib-abs \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::Hash::LX.3