aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--www/Makefile1
-rw-r--r--www/hs-yesod/Makefile39
-rw-r--r--www/hs-yesod/distinfo2
-rw-r--r--www/hs-yesod/pkg-descr8
5 files changed, 51 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 837dfc3eadfb..2adbaea18719 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -291,6 +291,7 @@ xmonad_port= x11-wm/hs-xmonad # executable
xmonad-contrib_port= x11-wm/hs-xmonad-contrib
xss-sanitize_port= www/hs-xss-sanitize
yaml_port= textproc/hs-yaml
+yesod_port= www/hs-yesod
yesod-auth_port= www/hs-yesod-auth
yesod-core_port= www/hs-yesod-core
yesod-form_port= www/hs-yesod-form
diff --git a/www/Makefile b/www/Makefile
index af200e412d74..f4d2a87d7499 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -316,6 +316,7 @@
SUBDIR += hs-warp
SUBDIR += hs-webkit
SUBDIR += hs-xss-sanitize
+ SUBDIR += hs-yesod
SUBDIR += hs-yesod-auth
SUBDIR += hs-yesod-core
SUBDIR += hs-yesod-form
diff --git a/www/hs-yesod/Makefile b/www/hs-yesod/Makefile
new file mode 100644
index 000000000000..985a3eb7e39a
--- /dev/null
+++ b/www/hs-yesod/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: hs-yesod
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= yesod
+PORTVERSION= 0.9.4.1
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Creation of type-safe, RESTful web applications
+
+LICENSE= BSD
+
+USE_CABAL= attoparsec>=0.10 blaze-builder>=0.2.1.4 blaze-html>=0.4.1.3 \
+ hamlet>=0.10 http-types>=0.6.1 monad-control>=0.2 \
+ parsec>=2.1 shakespeare-css>=0.10 shakespeare-js>=0.10 \
+ shakespeare-text>=0.10 text>=0.11 transformers>=0.2.2 \
+ unix-compat>=0.2 wai>=0.4 wai-extra>=0.4.6 warp>=0.4 \
+ yesod-auth>=0.7 yesod-core>=0.9.3.4 yesod-form>=0.3 \
+ yesod-json>=0.2.2 yesod-persistent>=0.2
+
+EXECUTABLE= yesod
+
+OPTIONS= THREADED "Multi-threaded execution" on
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+.include <bsd.port.options.mk>
+
+.if defined(WITH_THREADED)
+CONFIGURE_ARGS+= --flags="threaded"
+.else
+CONFIGURE_ARGS+= --flags="-threaded"
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-yesod/distinfo b/www/hs-yesod/distinfo
new file mode 100644
index 000000000000..099257ba50cd
--- /dev/null
+++ b/www/hs-yesod/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/yesod-0.9.4.1.tar.gz) = d80c32a373f40014eb79fa95621da1fa10a243c10a836808805a451a52258d35
+SIZE (cabal/yesod-0.9.4.1.tar.gz) = 32368
diff --git a/www/hs-yesod/pkg-descr b/www/hs-yesod/pkg-descr
new file mode 100644
index 000000000000..d7f676dfee21
--- /dev/null
+++ b/www/hs-yesod/pkg-descr
@@ -0,0 +1,8 @@
+A RESTful web framework with strong compile-time guarantees of correctness.
+It also affords space efficient code, highly concurrent loads, and
+portability to many deployment backends (via the wai package), from CGI
+to stand-alone serving. Yesod also focuses on developer productivity.
+Yesod integrates well with tools for all your basic web development (wai,
+persistent, and shakespeare/hamlet).
+
+WWW: http://www.yesodweb.com/