aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-im/libpurple/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 5b3012edb0fe..db5997f5728b 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= libpurple
PORTVERSION= 2.13.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= net-im
MASTER_SITES= SF/pidgin/Pidgin/${PORTVERSION}
DISTNAME= pidgin-${PORTVERSION}
@@ -24,7 +24,7 @@ INSTALL_TARGET= install-strip
.if !defined(PIDGIN_SLAVE)
# Pidgin slave ports that require the following functionality, must explicitly
# set these macros themselves.
-USES+= iconv python:2.7 shebangfix
+USES+= iconv shebangfix
USE_LDCONFIG= yes
SHEBANG_FILES= libpurple/purple-remote \
libpurple/purple-url-handler
@@ -206,11 +206,12 @@ CONFIGURE_ARGS+= --disable-gtkspell
.endif
.if ${PORT_OPTIONS:MDBUS}
+USES+= python
LIB_DEPENDS+= libdbus-glib-1.so:devel/dbus-glib
.if !defined(PIDGIN_SLAVE)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
.endif
-CONFIGURE_ARGS+= --enable-dbus
+CONFIGURE_ARGS+= --enable-dbus --with-python=${PYTHON_CMD}
PLIST_SUB+= DBUS=""
.else
CONFIGURE_ARGS+= --disable-dbus