aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/rbnamazu/Makefile10
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile3
-rw-r--r--ports-mgmt/portupgrade/Makefile3
-rw-r--r--sysutils/portupgrade-devel/Makefile3
-rw-r--r--sysutils/portupgrade/Makefile3
-rw-r--r--textproc/ruby-rdtool/Makefile9
6 files changed, 14 insertions, 17 deletions
diff --git a/japanese/rbnamazu/Makefile b/japanese/rbnamazu/Makefile
index 0a09e1d33d66..0a5e31c45219 100644
--- a/japanese/rbnamazu/Makefile
+++ b/japanese/rbnamazu/Makefile
@@ -13,8 +13,6 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse
-
USE_RUBY= yes
.if !defined(NOPORTDOCS)
USE_RUBY_RD= yes
@@ -25,6 +23,12 @@ NO_BUILD= yes
MODULES= rbnamazu.rb nmzqr.rb nmzqr.tab.rb nmzdoc.rb
RD_DOCS= rbnamazu.rd.ja rbnamazu.rd.en
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} < 1.7
+RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/namazu.rb ${PREFIX}/bin/
${LN} -sf namazu.rb ${PREFIX}/bin/rbnamazu
@@ -45,4 +49,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index dfbffb257bcd..f585d322f3f1 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -55,8 +55,7 @@ INSTALL_TARGET+= install-doc
.include <bsd.port.pre.mk>
.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
- ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
pre-install:
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index dfbffb257bcd..f585d322f3f1 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -55,8 +55,7 @@ INSTALL_TARGET+= install-doc
.include <bsd.port.pre.mk>
.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
- ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
pre-install:
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index dfbffb257bcd..f585d322f3f1 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -55,8 +55,7 @@ INSTALL_TARGET+= install-doc
.include <bsd.port.pre.mk>
.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
- ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
pre-install:
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index dfbffb257bcd..f585d322f3f1 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -55,8 +55,7 @@ INSTALL_TARGET+= install-doc
.include <bsd.port.pre.mk>
.if ${RUBY_VER} < 1.7
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
- ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/features/ruby18/file.so:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
pre-install:
diff --git a/textproc/ruby-rdtool/Makefile b/textproc/ruby-rdtool/Makefile
index fe442dc129f9..2d8d6374c5b9 100644
--- a/textproc/ruby-rdtool/Makefile
+++ b/textproc/ruby-rdtool/Makefile
@@ -15,9 +15,7 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= ${DEPEND_RUBY_AMSTD} \
- racc:${PORTSDIR}/devel/ruby-racc \
- ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse
-RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse
+ racc:${PORTSDIR}/devel/ruby-racc
USE_RUBY= yes
@@ -32,9 +30,8 @@ DOCS_JA= README.ja.html doc/rd-draft.rd.ja doc/rd-draft.ja.html
.include <bsd.port.pre.mk>
.if ${RUBY_VER} < 1.7
-BUILD_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/strscan.so:${PORTSDIR}/lang/ruby16-shim-ruby18
-RUN_DEPENDS+= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/lang/ruby16-shim-ruby18 \
- ${RUBY_SITEARCHLIBDIR}/strscan.so:${PORTSDIR}/lang/ruby16-shim-ruby18
+BUILD_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
+RUN_DEPENDS+= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
.endif
do-configure: