aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Alzabo/Makefile2
-rw-r--r--devel/p5-Class-AlzaboWrapper/Makefile2
-rw-r--r--devel/p5-Class-Container/Makefile2
-rw-r--r--devel/p5-DateTime-Calendar-Discordian/Makefile2
-rw-r--r--devel/p5-DateTime-Calendar-Mayan/Makefile6
-rw-r--r--devel/p5-DateTime-Event-Easter/Makefile2
-rw-r--r--devel/p5-DateTime-Event-NameDay/Makefile6
-rw-r--r--devel/p5-DateTime-Format-Baby/Makefile2
-rw-r--r--devel/p5-DateTime-Format-Bork/Makefile4
-rw-r--r--devel/p5-DateTime-Format-Epoch/Makefile2
-rw-r--r--devel/p5-DateTime-Format-ICal/Makefile4
-rw-r--r--devel/p5-DateTime-Format-Mail/Makefile6
-rw-r--r--devel/p5-DateTime-Format-Natural/Makefile2
-rw-r--r--devel/p5-DateTime-Format-Strptime/Makefile2
-rw-r--r--devel/p5-Log-Dispatch-FileRotate/Makefile2
-rw-r--r--devel/p5-Log-Dispatch-FileShared/Makefile2
-rw-r--r--devel/p5-POE-API-Hooks/Makefile4
-rw-r--r--devel/p5-Params-CallbackRequest/Makefile2
-rw-r--r--math/p5-Statistics-Contingency/Makefile2
-rw-r--r--net-mgmt/p5-Nagios-Plugin/Makefile2
-rw-r--r--net/p5-Net-Amazon-EC2/Makefile2
-rw-r--r--net/p5-Net-Analysis/Makefile2
-rw-r--r--net/p5-POE-Component-ControlPort/Makefile2
-rw-r--r--security/p5-Authen-Simple/Makefile2
-rw-r--r--textproc/p5-AI-Categorizer/Makefile2
-rw-r--r--www/p5-Apache-Session-Wrapper/Makefile2
-rw-r--r--www/p5-CGI-Application-Dispatch-Server/Makefile2
-rw-r--r--www/p5-RT-Client-REST/Makefile2
28 files changed, 37 insertions, 37 deletions
diff --git a/devel/p5-Alzabo/Makefile b/devel/p5-Alzabo/Makefile
index 2cf673db7587..d1e271e4a23c 100644
--- a/devel/p5-Alzabo/Makefile
+++ b/devel/p5-Alzabo/Makefile
@@ -16,7 +16,7 @@ COMMENT= A data modelling tool and RDBMS-OO mapper
BUILD_DEPENDS= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-Class-AlzaboWrapper/Makefile b/devel/p5-Class-AlzaboWrapper/Makefile
index 4a540dbc2335..fcad25ddfbc9 100644
--- a/devel/p5-Class-AlzaboWrapper/Makefile
+++ b/devel/p5-Class-AlzaboWrapper/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Higher level wrapper around Alzabo Row and Table objects
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}//Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
${SITE_PERL}/Alzabo.pm:${PORTSDIR}/devel/p5-Alzabo
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-Class-Container/Makefile b/devel/p5-Class-Container/Makefile
index a76bce0db2cc..4fca486102e3 100644
--- a/devel/p5-Class-Container/Makefile
+++ b/devel/p5-Class-Container/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dsh@vlink.ru
COMMENT= Glues object frameworks together transparently
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Calendar-Discordian/Makefile b/devel/p5-DateTime-Calendar-Discordian/Makefile
index 9522d7c111ef..e108bf075324 100644
--- a/devel/p5-DateTime-Calendar-Discordian/Makefile
+++ b/devel/p5-DateTime-Calendar-Discordian/Makefile
@@ -16,7 +16,7 @@ COMMENT= Perl extension for the Discordian Calendar
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
${SITE_PERL}/DateTime/Locale.pm:${PORTSDIR}/devel/p5-DateTime-Locale \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Calendar-Mayan/Makefile b/devel/p5-DateTime-Calendar-Mayan/Makefile
index 40924c655548..586729f20902 100644
--- a/devel/p5-DateTime-Calendar-Mayan/Makefile
+++ b/devel/p5-DateTime-Calendar-Mayan/Makefile
@@ -7,17 +7,17 @@
PORTNAME= DateTime-Calendar-Mayan
PORTVERSION= 0.06.01
-DISTVERSION= ${PORTVERSION:C/\.(..)$/\1/}
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= perl@FreeBSD.org
COMMENT= The Mayan Long Count, Haab, and Tzolkin calendars
-BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Event-Easter/Makefile b/devel/p5-DateTime-Event-Easter/Makefile
index 06b996137fa0..fdc875574d69 100644
--- a/devel/p5-DateTime-Event-Easter/Makefile
+++ b/devel/p5-DateTime-Event-Easter/Makefile
@@ -18,7 +18,7 @@ COMMENT= Returns Easter events for DateTime objects
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
${SITE_PERL}/DateTime/Calendar/Julian.pm:${PORTSDIR}/devel/p5-DateTime-Calendar-Julian \
${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Event-NameDay/Makefile b/devel/p5-DateTime-Event-NameDay/Makefile
index c74d0493f9e6..0ed6c49820d3 100644
--- a/devel/p5-DateTime-Event-NameDay/Makefile
+++ b/devel/p5-DateTime-Event-NameDay/Makefile
@@ -15,12 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl DateTime extension to work with namedays from various countries
-BUILD_DEPENDS= ${RUN_DEPENDS} \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set \
${SITE_PERL}/DateTime/Calendar/Christian.pm:${PORTSDIR}/devel/p5-DateTime-Calendar-Christian \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Format-Baby/Makefile b/devel/p5-DateTime-Format-Baby/Makefile
index 9638c71af39d..ed5c07ca02f5 100644
--- a/devel/p5-DateTime-Format-Baby/Makefile
+++ b/devel/p5-DateTime-Format-Baby/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Parse and format baby-style time
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/devel/p5-DateTime-Format-Bork/Makefile b/devel/p5-DateTime-Format-Bork/Makefile
index 458071342fbf..d16f4cc6f42e 100644
--- a/devel/p5-DateTime-Format-Bork/Makefile
+++ b/devel/p5-DateTime-Format-Bork/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Formats datetimes for that guy from The Muppet Show
-BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
${SITE_PERL}/DateTime/Format/Builder.pm:${PORTSDIR}/devel/p5-DateTime-Format-Builder
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Format-Epoch/Makefile b/devel/p5-DateTime-Format-Epoch/Makefile
index 68889497ce00..800a95a8f896 100644
--- a/devel/p5-DateTime-Format-Epoch/Makefile
+++ b/devel/p5-DateTime-Format-Epoch/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Convert DateTimes to/from epoch seconds
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/devel/p5-DateTime-Format-ICal/Makefile b/devel/p5-DateTime-Format-ICal/Makefile
index a0351e0b55a6..b3d5a0cd7356 100644
--- a/devel/p5-DateTime-Format-ICal/Makefile
+++ b/devel/p5-DateTime-Format-ICal/Makefile
@@ -14,12 +14,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Parse and format ICal datetime and duration strings
-BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone \
${SITE_PERL}/DateTime/Event/ICal.pm:${PORTSDIR}/devel/p5-DateTime-Event-ICal \
${SITE_PERL}/DateTime/Span.pm:${PORTSDIR}/devel/p5-DateTime-Set \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Format-Mail/Makefile b/devel/p5-DateTime-Format-Mail/Makefile
index 171469ff8d13..89ba27933f7a 100644
--- a/devel/p5-DateTime-Format-Mail/Makefile
+++ b/devel/p5-DateTime-Format-Mail/Makefile
@@ -7,17 +7,17 @@
PORTNAME= DateTime-Format-Mail
PORTVERSION= 0.30.01
-DISTVERSION= ${PORTVERSION:C/\.(..)$/\1/}
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= perl@FreeBSD.org
COMMENT= Convert between DateTime and RFC2822/822 formats
-BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Format-Natural/Makefile b/devel/p5-DateTime-Format-Natural/Makefile
index 05bf3609d9d4..a47fabfd392c 100644
--- a/devel/p5-DateTime-Format-Natural/Makefile
+++ b/devel/p5-DateTime-Format-Natural/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= \
${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Format-Strptime/Makefile b/devel/p5-DateTime-Format-Strptime/Makefile
index af2192001557..069417e65866 100644
--- a/devel/p5-DateTime-Format-Strptime/Makefile
+++ b/devel/p5-DateTime-Format-Strptime/Makefile
@@ -17,7 +17,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Parse and format strp and strf time patterns
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone \
${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/devel/p5-Log-Dispatch-FileRotate/Makefile b/devel/p5-Log-Dispatch-FileRotate/Makefile
index f2a1239ec7d3..a92bd45b7822 100644
--- a/devel/p5-Log-Dispatch-FileRotate/Makefile
+++ b/devel/p5-Log-Dispatch-FileRotate/Makefile
@@ -16,7 +16,7 @@ COMMENT= A Log::Dispatch plug-in for files that archive/rotate themselves
BUILD_DEPENDS= ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/p5-Log-Dispatch-FileShared/Makefile b/devel/p5-Log-Dispatch-FileShared/Makefile
index 888b6a44dee2..6d03633293d5 100644
--- a/devel/p5-Log-Dispatch-FileShared/Makefile
+++ b/devel/p5-Log-Dispatch-FileShared/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= A Log::Dispatch output class for logging to shared files
BUILD_DEPENDS= ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-POE-API-Hooks/Makefile b/devel/p5-POE-API-Hooks/Makefile
index 6539694de868..85bad35f721e 100644
--- a/devel/p5-POE-API-Hooks/Makefile
+++ b/devel/p5-POE-API-Hooks/Makefile
@@ -9,14 +9,14 @@ PORTNAME= POE-API-Hooks
PORTVERSION= 1.0500
CATEGORIES= devel perl5
MASTER_SITES= CPAN
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/0+$//}
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/0+$//}
MAINTAINER= skv@FreeBSD.org
COMMENT= Implement lightweight hooks into POE
BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Params-CallbackRequest/Makefile b/devel/p5-Params-CallbackRequest/Makefile
index c1133e94233f..80ed61c65b49 100644
--- a/devel/p5-Params-CallbackRequest/Makefile
+++ b/devel/p5-Params-CallbackRequest/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Provide callbacks to method and function parameters
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/math/p5-Statistics-Contingency/Makefile b/math/p5-Statistics-Contingency/Makefile
index abd38d708281..086aee9917a0 100644
--- a/math/p5-Statistics-Contingency/Makefile
+++ b/math/p5-Statistics-Contingency/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Calculate precision, recall, F1, accuracy, etc
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net-mgmt/p5-Nagios-Plugin/Makefile b/net-mgmt/p5-Nagios-Plugin/Makefile
index 0b1779969d11..ab5f658d3160 100644
--- a/net-mgmt/p5-Nagios-Plugin/Makefile
+++ b/net-mgmt/p5-Nagios-Plugin/Makefile
@@ -17,7 +17,7 @@ COMMENT= Modules to streamline writing Nagios plugins
PERL_CONFIGURE= 5.8.0+
BUILD_DEPENDS+= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/Math/Calc/Units.pm:${PORTSDIR}/math/p5-Math-Calc-Units \
${SITE_PERL}/Config/Tiny.pm:${PORTSDIR}/devel/p5-Config-Tiny
RUN_DEPENDS+= ${BUILD_DEPENDS}
diff --git a/net/p5-Net-Amazon-EC2/Makefile b/net/p5-Net-Amazon-EC2/Makefile
index 00e9d47ba80d..7fc678ac3b3c 100644
--- a/net/p5-Net-Amazon-EC2/Makefile
+++ b/net/p5-Net-Amazon-EC2/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= glarkin@FreeBSD.org
COMMENT= Perl interface to the Amazon Elastic Compute Cloud
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
p5-Digest-HMAC>=1.01:${PORTSDIR}/security/p5-Digest-HMAC \
diff --git a/net/p5-Net-Analysis/Makefile b/net/p5-Net-Analysis/Makefile
index 31e83f2afea0..72cac0544609 100644
--- a/net/p5-Net-Analysis/Makefile
+++ b/net/p5-Net-Analysis/Makefile
@@ -16,7 +16,7 @@ COMMENT= Modules for analysing network traffic
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/Pcap.pm:${PORTSDIR}/net/p5-Net-Pcap \
${SITE_PERL}/NetPacket.pm:${PORTSDIR}/net/p5-NetPacket \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/net/p5-POE-Component-ControlPort/Makefile b/net/p5-POE-Component-ControlPort/Makefile
index 4358a526b723..cd6215729e7a 100644
--- a/net/p5-POE-Component-ControlPort/Makefile
+++ b/net/p5-POE-Component-ControlPort/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= hideo@lastamericanempire.com
COMMENT= Network control port for POE applications
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+RUN_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/${PERL_ARCH}/Authen/Libwrap.pm:${PORTSDIR}/security/p5-Authen-Libwrap \
${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
BUILD_DEPENDS= ${RUN_DEPENDS}
diff --git a/security/p5-Authen-Simple/Makefile b/security/p5-Authen-Simple/Makefile
index 5505c30327cb..8799def796dd 100644
--- a/security/p5-Authen-Simple/Makefile
+++ b/security/p5-Authen-Simple/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Ac
${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= Authen::Simple.3 \
diff --git a/textproc/p5-AI-Categorizer/Makefile b/textproc/p5-AI-Categorizer/Makefile
index ab9313e1ded4..fd6a46e7e7c9 100644
--- a/textproc/p5-AI-Categorizer/Makefile
+++ b/textproc/p5-AI-Categorizer/Makefile
@@ -16,7 +16,7 @@ COMMENT= Automatic Text Categorization
BUILD_DEPENDS= ${SITE_PERL}/Class/Container.pm:${PORTSDIR}/devel/p5-Class-Container \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/Statistics/Contingency.pm:${PORTSDIR}/math/p5-Statistics-Contingency \
${SITE_PERL}/Lingua/Stem.pm:${PORTSDIR}/textproc/p5-Lingua-Stem \
${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
diff --git a/www/p5-Apache-Session-Wrapper/Makefile b/www/p5-Apache-Session-Wrapper/Makefile
index 3d13c0a27842..5132e96be14b 100644
--- a/www/p5-Apache-Session-Wrapper/Makefile
+++ b/www/p5-Apache-Session-Wrapper/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= A simple wrapper around Apache::Session
BUILD_DEPENDS= ${SITE_PERL}/Class/Container.pm:${PORTSDIR}/devel/p5-Class-Container \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
${SITE_PERL}/Apache/Session.pm:${PORTSDIR}/www/p5-Apache-Session
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/www/p5-CGI-Application-Dispatch-Server/Makefile b/www/p5-CGI-Application-Dispatch-Server/Makefile
index eaffd5846381..db83d55760cd 100644
--- a/www/p5-CGI-Application-Dispatch-Server/Makefile
+++ b/www/p5-CGI-Application-Dispatch-Server/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/CGI/Application/Dispatch.pm:${PORTSDIR}/www/p5-CGI-Application-Dispatch \
${SITE_PERL}/HTTP/Server/Simple/CGI.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple \
${SITE_PERL}/HTTP/Server/Simple/Static.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple-Static \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
PERL_MODBUILD= 5.8.0+
diff --git a/www/p5-RT-Client-REST/Makefile b/www/p5-RT-Client-REST/Makefile
index aa038f46cf82..e8043acd4dc3 100644
--- a/www/p5-RT-Client-REST/Makefile
+++ b/www/p5-RT-Client-REST/Makefile
@@ -17,7 +17,7 @@ COMMENT= Perl modules designed to talk to RT installation using REST protocol
BUILD_DEPENDS= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
${SITE_PERL}/HTTP/Cookies.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS= ${BUILD_DEPENDS}