aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/motor/Makefile8
-rw-r--r--devel/py-kqueue/Makefile5
-rw-r--r--devel/uclmmbase/Makefile9
-rw-r--r--editors/biew/Makefile6
-rw-r--r--editors/mp/Makefile6
-rw-r--r--editors/ne/Makefile8
-rw-r--r--emulators/basiliskII/Makefile9
-rw-r--r--emulators/rtc/Makefile4
-rw-r--r--emulators/vmware-guestd5/Makefile9
-rw-r--r--emulators/vmware-guestd6/Makefile17
10 files changed, 11 insertions, 70 deletions
diff --git a/devel/motor/Makefile b/devel/motor/Makefile
index 7244ced93b1c..729fdfcf7e7e 100644
--- a/devel/motor/Makefile
+++ b/devel/motor/Makefile
@@ -30,12 +30,6 @@ PLIST_SUB= NLS="@comment "
MAN1= motor.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|zxvf|&o|' ${WRKSRC}/share/Makefile.in
@@ -45,4 +39,4 @@ post-install:
@(cd ${WRKSRC} ; ${INSTALL_DATA} FAQ README ${DOCSDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-kqueue/Makefile b/devel/py-kqueue/Makefile
index 6f5789174ad6..68a2f1651b1b 100644
--- a/devel/py-kqueue/Makefile
+++ b/devel/py-kqueue/Makefile
@@ -15,7 +15,7 @@ DISTNAME= PyKQueue-${PORTVERSION}
EXTRACT_SUFX= .tbz
MAINTAINER= ports2@dclg.ca
-COMMENT= Python interface to kqueue(2) and kevent(2) system calls
+COMMENT= Python interface to kqueue(2) and kevent(2) system calls
USE_BZIP2= yes
USE_PYTHON= yes
@@ -25,9 +25,6 @@ MAKE_ENV= MAINCC=${CC}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400018
-IGNORE="requires new kqueue API"
-.endif
.if ${OSVERSION} >= 500000 && ${OSVERSION} < 500010
IGNORE="requires new kqueue API"
.endif
diff --git a/devel/uclmmbase/Makefile b/devel/uclmmbase/Makefile
index be31746d0869..3060c90dd97a 100644
--- a/devel/uclmmbase/Makefile
+++ b/devel/uclmmbase/Makefile
@@ -17,6 +17,7 @@ COMMENT= Common subroutines for UCL mbone applications
WRKSRC= ${WRKDIR}/common
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+CONFIGURE_ARGS= --enable-ipv6
post-configure:
@for f in ${FILESDIR}/*.bsd ; do \
@@ -34,10 +35,4 @@ post-build test:
do-install:
cd ${WRKSRC}/src && ${MAKE_ENV} ${MAKE} install
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 400014
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/biew/Makefile b/editors/biew/Makefile
index 8a31b48be1b9..1344f9e80b86 100644
--- a/editors/biew/Makefile
+++ b/editors/biew/Makefile
@@ -34,12 +34,6 @@ PLIST_DIRS= share/biew
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400010
-LIB_DEPENDS= ncurses.5:${PORTSDIR}/devel/ncurses
-HOST_CFLAGS+= -D__FreeBSD_version=${OSVERSION} -I${LOCALBASE}/include
-HOST_LD+= -L${LOCALBASE}/lib
-.endif
-
OST_CFLAGS= ${CFLAGS} -DPREFIX="\'\"${PREFIX}\"\'"
MAKEFILE= makefile
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index a3d842456739..68392de7c198 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -27,11 +27,7 @@ MAN1= mp.1
.include <bsd.port.pre.mk>
-.if defined(WITH_CURSES)
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
-.endif
-.else
+.if !defined(WITH_CURSES)
CONFIGURE_ARGS+= --without-curses
.endif
diff --git a/editors/ne/Makefile b/editors/ne/Makefile
index 859d5dbefd94..cb9fd7b20203 100644
--- a/editors/ne/Makefile
+++ b/editors/ne/Makefile
@@ -23,12 +23,6 @@ ALL_TARGET= ne
MAKE_ARGS= CFLAGS="${CFLAGS} -DNOWCHAR" CC="${CC}" \
GLOBALDIR="${DATADIR}"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses:${PORTSDIR}/devel/ncurses
-.endif
-
WRKSRC= ${WRKDIR}/${DISTNAME}/src
MAN1= ne.1
@@ -48,4 +42,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC:S/src//}doc/ne.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/basiliskII/Makefile b/emulators/basiliskII/Makefile
index 3307b85e5f67..350b9e1279f1 100644
--- a/emulators/basiliskII/Makefile
+++ b/emulators/basiliskII/Makefile
@@ -28,14 +28,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
MAN1= BasiliskII.1
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 400012
-CFLAGS+= -fpermissive
-.endif
+CFLAGS= -fpermissive
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index 4d6196b21059..2cce0c14ad19 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -34,10 +34,6 @@ SRC_BASE?= /usr/src
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400013
-IGNORE= needs a system more recent than 400013
-.endif
-
.if ${OSVERSION} < 500104
PLIST_SUB+= MAKEDEV=""
.else
diff --git a/emulators/vmware-guestd5/Makefile b/emulators/vmware-guestd5/Makefile
index f3f2f86344e3..57ee3e26a3c0 100644
--- a/emulators/vmware-guestd5/Makefile
+++ b/emulators/vmware-guestd5/Makefile
@@ -53,11 +53,7 @@ BUILD_VER= 19175
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
@@ -94,10 +90,7 @@ PLIST_SUB+= VMWARE_VMMEMCTL:="@comment "
.endif
.if defined(WITH_VMWARE_VMXNET)
-.if (${OSVERSION} >= 480000) && (${OSVERSION} < 500000) && (${BITS} == 32)
-PLIST_SUB+= VMWARE_VMXNET:=""
-VMWARE_VMXNET_PATH= 4.9/vmxnet.ko
-.elif (${OSVERSION} >= 500000) && (${OSVERSION} < 600000)
+.if (${OSVERSION} < 600000)
PLIST_SUB+= VMWARE_VMXNET:=""
.if ${BITS} == 32
VMWARE_VMXNET_PATH= 5.3-i386/vmxnet.ko
diff --git a/emulators/vmware-guestd6/Makefile b/emulators/vmware-guestd6/Makefile
index 6a9fb070249c..4c4957f25201 100644
--- a/emulators/vmware-guestd6/Makefile
+++ b/emulators/vmware-guestd6/Makefile
@@ -55,11 +55,7 @@ BUILD_VER= 55017
LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
.endif
-.if ${OSVERSION} < 500000
-MOUNT_DEV?= /dev/acd0c
-.else
MOUNT_DEV?= /dev/acd0
-.endif
MOUNT_PT?= /mnt
MOUNT= /sbin/mount
UMOUNT= /sbin/umount
@@ -69,7 +65,7 @@ BITS?= 32
.else # ${ARCH} == amd64
BITS?= 64
.endif
-.if ((${OSVERSION} >= 500000) && (${OSVERSION} < 530000)) && (${ARCH} == i386)
+.if (${OSVERSION} < 530000) && (${ARCH} == i386)
OSSFX?= -50
.elif ${OSVERSION} < 600000
OSSFX?=
@@ -106,16 +102,7 @@ PLIST_SUB+= VMWARE_VMMEMCTL="@comment "
.endif
.if defined(WITH_VMWARE_VMXNET)
-.if (${OSVERSION} >= 300000) && (${OSVERSION} < 400000) && (${BITS} == 32)
-PLIST_SUB+= VMWARE_VMXNET=""
-VMWARE_VMXNET_PATH= 3.2/vmxnet.ko
-.elif (${OSVERSION} >= 400000) && (${OSVERSION} < 480000) && (${BITS} == 32)
-PLIST_SUB+= VMWARE_VMXNET=""
-VMWARE_VMXNET_PATH= 4.0/vmxnet.ko
-.elif (${OSVERSION} >= 480000) && (${OSVERSION} < 500000) && (${BITS} == 32)
-PLIST_SUB+= VMWARE_VMXNET=""
-VMWARE_VMXNET_PATH= 4.9/vmxnet.ko
-.elif (${OSVERSION} >= 500000) && (${OSVERSION} < 600000)
+.if (${OSVERSION} >= 500000) && (${OSVERSION} < 600000)
PLIST_SUB+= VMWARE_VMXNET=""
.if ${BITS} == 32
.if ${OSVERSION} < 530000