aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/files/patch-bug138070636
-rw-r--r--www/firefox-esr/Makefile2
-rw-r--r--www/firefox-esr/files/patch-bug138070636
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/files/patch-bug138070636
6 files changed, 111 insertions, 3 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 691ca98cc09e..6be8bb7f0ad0 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 52.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1380706 b/mail/thunderbird/files/patch-bug1380706
new file mode 100644
index 000000000000..0fe688458ae6
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1380706
@@ -0,0 +1,36 @@
+commit 10b55207992c
+Author: Kai Engert <kaie@kuix.de>
+Date: Fri Jul 14 15:31:30 2017 +0200
+
+ Bug 1380706, PSM should depend on mozStorage, as a workaround for a sqlite3_config race, r=keeler
+---
+ security/manager/ssl/nsNSSComponent.cpp | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git security/manager/ssl/nsNSSComponent.cpp security/manager/ssl/nsNSSComponent.cpp
+index f51f8af47d51..a82c1ed61fba 100644
+--- mozilla/security/manager/ssl/nsNSSComponent.cpp
++++ mozilla/security/manager/ssl/nsNSSComponent.cpp
+@@ -13,6 +13,7 @@
+ #include "SharedSSLState.h"
+ #include "cert.h"
+ #include "certdb.h"
++#include "mozStorageCID.h"
+ #include "mozilla/ArrayUtils.h"
+ #include "mozilla/Assertions.h"
+ #include "mozilla/Casting.h"
+@@ -2032,6 +2033,14 @@ nsNSSComponent::Init()
+ return NS_ERROR_NOT_AVAILABLE;
+ }
+
++ // To avoid a sqlite3_config race in NSS init, as a workaround for
++ // bug 730495, we require the storage service to get initialized first.
++ nsCOMPtr<nsISupports> storageService =
++ do_GetService(MOZ_STORAGE_SERVICE_CONTRACTID);
++ if (!storageService) {
++ return NS_ERROR_NOT_AVAILABLE;
++ }
++
+ MOZ_LOG(gPIPNSSLog, LogLevel::Debug, ("Beginning NSS initialization\n"));
+
+ nsresult rv = InitializePIPNSSBundle();
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 5db849131787..51094e3647b8 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 52.6.0
DISTVERSIONSUFFIX=esr
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/files/patch-bug1380706 b/www/firefox-esr/files/patch-bug1380706
new file mode 100644
index 000000000000..5f7e57663145
--- /dev/null
+++ b/www/firefox-esr/files/patch-bug1380706
@@ -0,0 +1,36 @@
+commit 10b55207992c
+Author: Kai Engert <kaie@kuix.de>
+Date: Fri Jul 14 15:31:30 2017 +0200
+
+ Bug 1380706, PSM should depend on mozStorage, as a workaround for a sqlite3_config race, r=keeler
+---
+ security/manager/ssl/nsNSSComponent.cpp | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git security/manager/ssl/nsNSSComponent.cpp security/manager/ssl/nsNSSComponent.cpp
+index f51f8af47d51..a82c1ed61fba 100644
+--- security/manager/ssl/nsNSSComponent.cpp
++++ security/manager/ssl/nsNSSComponent.cpp
+@@ -13,6 +13,7 @@
+ #include "SharedSSLState.h"
+ #include "cert.h"
+ #include "certdb.h"
++#include "mozStorageCID.h"
+ #include "mozilla/ArrayUtils.h"
+ #include "mozilla/Assertions.h"
+ #include "mozilla/Casting.h"
+@@ -2032,6 +2033,14 @@ nsNSSComponent::Init()
+ return NS_ERROR_NOT_AVAILABLE;
+ }
+
++ // To avoid a sqlite3_config race in NSS init, as a workaround for
++ // bug 730495, we require the storage service to get initialized first.
++ nsCOMPtr<nsISupports> storageService =
++ do_GetService(MOZ_STORAGE_SERVICE_CONTRACTID);
++ if (!storageService) {
++ return NS_ERROR_NOT_AVAILABLE;
++ }
++
+ MOZ_LOG(gPIPNSSLog, LogLevel::Debug, ("Beginning NSS initialization\n"));
+
+ nsresult rv = InitializePIPNSSBundle();
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index ee6ca5350405..41c2be457d70 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -3,8 +3,8 @@
PORTNAME= seamonkey
DISTVERSION= 2.49.1
-PORTREVISION= 8
MOZILLA_VER= 52 # above + 3
+PORTREVISION= 9
CATEGORIES?= www mail news editors irc ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build4/source
diff --git a/www/seamonkey/files/patch-bug1380706 b/www/seamonkey/files/patch-bug1380706
new file mode 100644
index 000000000000..0fe688458ae6
--- /dev/null
+++ b/www/seamonkey/files/patch-bug1380706
@@ -0,0 +1,36 @@
+commit 10b55207992c
+Author: Kai Engert <kaie@kuix.de>
+Date: Fri Jul 14 15:31:30 2017 +0200
+
+ Bug 1380706, PSM should depend on mozStorage, as a workaround for a sqlite3_config race, r=keeler
+---
+ security/manager/ssl/nsNSSComponent.cpp | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git security/manager/ssl/nsNSSComponent.cpp security/manager/ssl/nsNSSComponent.cpp
+index f51f8af47d51..a82c1ed61fba 100644
+--- mozilla/security/manager/ssl/nsNSSComponent.cpp
++++ mozilla/security/manager/ssl/nsNSSComponent.cpp
+@@ -13,6 +13,7 @@
+ #include "SharedSSLState.h"
+ #include "cert.h"
+ #include "certdb.h"
++#include "mozStorageCID.h"
+ #include "mozilla/ArrayUtils.h"
+ #include "mozilla/Assertions.h"
+ #include "mozilla/Casting.h"
+@@ -2032,6 +2033,14 @@ nsNSSComponent::Init()
+ return NS_ERROR_NOT_AVAILABLE;
+ }
+
++ // To avoid a sqlite3_config race in NSS init, as a workaround for
++ // bug 730495, we require the storage service to get initialized first.
++ nsCOMPtr<nsISupports> storageService =
++ do_GetService(MOZ_STORAGE_SERVICE_CONTRACTID);
++ if (!storageService) {
++ return NS_ERROR_NOT_AVAILABLE;
++ }
++
+ MOZ_LOG(gPIPNSSLog, LogLevel::Debug, ("Beginning NSS initialization\n"));
+
+ nsresult rv = InitializePIPNSSBundle();