aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/rtb/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index d64c88c31ce8..ee220720327d 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -16,11 +16,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gsed:textproc/gsed
-USES= gettext gmake perl5 pkgconfig python:2.7 tar:bzip2
+USES= compiler gettext gmake perl5 pkgconfig python:2.7 tar:bzip2
USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rtb-dir=${PREFIX}/lib/${PORTNAME}
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib