aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--converters/ytnef/Makefile26
-rw-r--r--converters/ytnef/distinfo5
-rw-r--r--converters/ytnef/files/patch-src__ytnef__main.c25
-rw-r--r--converters/ytnef/pkg-descr2
-rw-r--r--converters/ytnef/pkg-plist (renamed from devel/libytnef/pkg-plist)4
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libytnef/Makefile18
-rw-r--r--devel/libytnef/distinfo2
-rw-r--r--devel/libytnef/files/patch-ytnef.c58
-rw-r--r--devel/libytnef/pkg-descr16
11 files changed, 22 insertions, 136 deletions
diff --git a/MOVED b/MOVED
index f66703ba278d..a1d670495433 100644
--- a/MOVED
+++ b/MOVED
@@ -9166,3 +9166,4 @@ net-p2p/gnunet||2017-03-27|Has expired: Broken for more than 6 months
print/abc2mtex||2017-03-27|Has expired: Depends on expiring print/musixtex
ftp/bareftp||2017-03-27|Has expired: Broken for more than 6 months
www/rubygem-jquery-rails4|www/rubygem-jquery-rails|2017-03-27|Remove PKGNAMESUFFIX
+devel/libytnef|converters/ytnef|2017-03-29|Merged into converters/ytnef
diff --git a/converters/ytnef/Makefile b/converters/ytnef/Makefile
index 0cebfb2b6ddc..8e0cd9dcdeb0 100644
--- a/converters/ytnef/Makefile
+++ b/converters/ytnef/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= ytnef
-PORTVERSION= 2.6
-PORTREVISION= 2
+PORTVERSION= 1.9.2
+DISTVERSIONPREFIX= v
+PORTEPOCH= 1
CATEGORIES= converters mail
-MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Unpack data in MS Outlook TNEF format
@@ -13,25 +13,25 @@ COMMENT= Unpack data in MS Outlook TNEF format
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libytnef.so:devel/libytnef
RUN_DEPENDS= p5-MIME-Tools>=0:mail/p5-MIME-Tools
-USES= perl5 shebangfix
-SHEBANG_FILES= src/ytnef/*.pl
+USE_GITHUB= yes
+GH_ACCOUNT= Yeraze
+
+USES= autoreconf libtool pathfix perl5 shebangfix
+SHEBANG_FILES= ytnef/ytnefprocess
USE_PERL5= run
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-PORTDOCS= AUTHORS NEWS README
-PLIST_FILES= bin/ytnef bin/ytnefprint bin/ytnefprocess.pl
+PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share|' \
- ${WRKSRC}/src/ytnef/*.pl
+ @${REINPLACE_CMD} -e 's|/usr/bin|${PREFIX}/bin|' \
+ ${WRKSRC}/ytnef/ytnefprocess
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/converters/ytnef/distinfo b/converters/ytnef/distinfo
index 79fcb161c550..fd773d5913a5 100644
--- a/converters/ytnef/distinfo
+++ b/converters/ytnef/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ytnef-2.6.tar.gz) = 9addfcb7c412cdc3a2dc0c350e2130816633a35b3de37f1047d55e345dea99dc
-SIZE (ytnef-2.6.tar.gz) = 94146
+TIMESTAMP = 1490808908
+SHA256 (Yeraze-ytnef-v1.9.2_GH0.tar.gz) = 48f7d7272ba74b267d3f98a1b14c81fef54cfb53460346d7c36a9604df1f95ad
+SIZE (Yeraze-ytnef-v1.9.2_GH0.tar.gz) = 300945
diff --git a/converters/ytnef/files/patch-src__ytnef__main.c b/converters/ytnef/files/patch-src__ytnef__main.c
deleted file mode 100644
index f743542d9d18..000000000000
--- a/converters/ytnef/files/patch-src__ytnef__main.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/ytnef/main.c.orig 2004-06-04 18:40:47.000000000 +0400
-+++ src/ytnef/main.c 2014-04-01 22:00:33.027598870 +0400
-@@ -68,7 +68,7 @@
- case 'v': verbose++;
- break;
- case 'h': PrintHelp();
-- return;
-+ return 0;
- case 'f': savefiles = 1;
- filepath = argv[i+1];
- i++;
-@@ -103,11 +103,12 @@
- TNEF.Debug = verbose;
- if (TNEFParseFile(argv[i], &TNEF) == -1) {
- printf("ERROR processing file\n");
-- continue;
-+ return 1;
- }
- ProcessTNEF(TNEF);
- TNEFFree(&TNEF);
- }
-+ return 0;
- }
-
- void ProcessTNEF(TNEFStruct TNEF) {
diff --git a/converters/ytnef/pkg-descr b/converters/ytnef/pkg-descr
index 79ca18bd5228..00f3d3eddd24 100644
--- a/converters/ytnef/pkg-descr
+++ b/converters/ytnef/pkg-descr
@@ -11,4 +11,4 @@ use Microsoft Outlook to view them.
Now supports winmail.dat Outlook files
-WWW: http://ytnef.sourceforge.net/
+WWW: https://github.com/Yeraze/ytnef
diff --git a/devel/libytnef/pkg-plist b/converters/ytnef/pkg-plist
index 42987e987d93..0b1ad9a4131c 100644
--- a/devel/libytnef/pkg-plist
+++ b/converters/ytnef/pkg-plist
@@ -1,3 +1,6 @@
+bin/ytnef
+bin/ytnefprint
+bin/ytnefprocess
include/mapi.h
include/mapidefs.h
include/mapitags.h
@@ -8,3 +11,4 @@ lib/libytnef.a
lib/libytnef.so
lib/libytnef.so.0
lib/libytnef.so.0.0.0
+libdata/pkgconfig/libytnef.pc
diff --git a/devel/Makefile b/devel/Makefile
index cbcc501d403b..ed0783aeda1b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1496,7 +1496,6 @@
SUBDIR += libxalloc
SUBDIR += libxo
SUBDIR += libxs
- SUBDIR += libytnef
SUBDIR += libzookeeper
SUBDIR += libzrtpcpp
SUBDIR += libzvbi
diff --git a/devel/libytnef/Makefile b/devel/libytnef/Makefile
deleted file mode 100644
index 87e4bc0aed69..000000000000
--- a/devel/libytnef/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-# Created by: Rodrigo Graeff <delphus@gmail.com>
-# $FreeBSD$
-
-PORTNAME= libytnef
-PORTVERSION= 1.5
-PORTREVISION= 3
-CATEGORIES= devel mail
-MASTER_SITES= SF/ytnef/${PORTNAME}/${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Unpack data in MS Outlook TNEF format
-
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USES= libtool
-USE_LDCONFIG= yes
-
-.include <bsd.port.mk>
diff --git a/devel/libytnef/distinfo b/devel/libytnef/distinfo
deleted file mode 100644
index 09045fdac33e..000000000000
--- a/devel/libytnef/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (libytnef-1.5.tar.gz) = 1b22a1e42e047c41a41917e89544992c33d30e9bd798b5b8ca7ef1eb75e1752e
-SIZE (libytnef-1.5.tar.gz) = 212412
diff --git a/devel/libytnef/files/patch-ytnef.c b/devel/libytnef/files/patch-ytnef.c
deleted file mode 100644
index 31a054a83c24..000000000000
--- a/devel/libytnef/files/patch-ytnef.c
+++ /dev/null
@@ -1,58 +0,0 @@
---- ytnef.c.orig 2004-08-26 19:09:05.000000000 +0200
-+++ ytnef.c 2013-05-27 14:30:52.142061290 +0200
-@@ -426,6 +426,13 @@ void TNEFFillMapi(TNEFStruct *TNEF, BYTE
- d += num + ((num % 4) ? (4 - num%4) : 0);
- break;
-
-+ case PT_CLSID:
-+ vl->size = 16; /* Size of struct GUID */
-+ vl->data = calloc(vl->size, sizeof(WORD));
-+ memcpy(vl->data, &d, vl->size);
-+ d += 16; /* Size of struct GUID */
-+ break;
-+
- case PT_I2:
- // Read in 2 bytes, but proceed by 4 bytes
- vl->size = 2;
-@@ -455,6 +462,8 @@ void TNEFFillMapi(TNEFStruct *TNEF, BYTE
- memcpy(vl->data, &temp_ddword, vl->size);
- d+=8;
- break;
-+ default:
-+ fprintf(stderr, "%s: Fatal BUG: unknown MAPI ID type (%u), (%u)\n", __func__, PROP_TYPE(mp->id), mp->id);
- }
- if (count == (mp->count-1)) {
- count = -1;
-@@ -565,7 +574,7 @@ void TNEFPrintDate(dtr Date) {
- int TNEFHexBreakdown STD_ARGLIST {
- int i;
- if (TNEF->Debug == 0)
-- return;
-+ return 0;
-
- printf("%s: [%i bytes] \n", TNEFList[id].name, size);
-
-@@ -574,13 +583,14 @@ int TNEFHexBreakdown STD_ARGLIST {
- if ((i+1)%16 == 0) printf("\n");
- }
- printf("\n");
-+ return 0;
- }
-
- // -----------------------------------------------------------------------------
- int TNEFDetailedPrint STD_ARGLIST {
- int i;
- if (TNEF->Debug == 0)
-- return;
-+ return 0;
-
- printf("%s: [%i bytes] \n", TNEFList[id].name, size);
-
-@@ -588,6 +598,7 @@ int TNEFDetailedPrint STD_ARGLIST {
- printf("%c", data[i]);
- }
- printf("\n");
-+ return 0;
- }
-
- // -----------------------------------------------------------------------------
diff --git a/devel/libytnef/pkg-descr b/devel/libytnef/pkg-descr
deleted file mode 100644
index 6acae59fe950..000000000000
--- a/devel/libytnef/pkg-descr
+++ /dev/null
@@ -1,16 +0,0 @@
-This is the library needed to YTNEF application
-
-This program decodes those annoying application/ms-tnef MIME attachments that
-Microsoft mail servers helpfully use to encapsulate your already MIME encoded
-attachments.
-
-Due to the proliferation of Microsoft Outlook and Exchange mail servers,
-more and more mail is encapsulated into this format.
-
-The YTNEF program allows one to unpack the attachments which were encapsulated
-into the YTNEF attachment. Thus alleviating the need to use Microsoft Outlook
-to view them.
-
-Now supports winmail.dat Outlook files
-
-WWW: http://ytnef.sourceforge.net/