aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/datadraw/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/devel/datadraw/Makefile b/devel/datadraw/Makefile
index fefde522aa1a..ce4d0d57e64f 100644
--- a/devel/datadraw/Makefile
+++ b/devel/datadraw/Makefile
@@ -12,11 +12,14 @@ COMMENT= Feature rich persistent database generator
LICENSE= GPLv2
+OPTIONS_DEFINE= DOCS
+
HAS_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
ALL_TARGET= # empty
+PORTDOCS= *
+CONFIGURE_ARGS= --prefix=\$${DESTDIR}${PREFIX}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000013
@@ -26,13 +29,9 @@ post-patch:
${REINPLACE_CMD} -e "s/bison/byacc/g" ${WRKSRC}/configure
.endif
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-
post-install:
- @${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/www/* ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/manual.pdf ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${CP} -R ${WRKSRC}/www/* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/manual.pdf ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>