aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/fpc-fcl-db/Makefile3
-rw-r--r--devel/fpc-fcl-fpcunit/Makefile5
-rw-r--r--devel/fpc-fcl-image/Makefile3
-rw-r--r--devel/fpc-fcl-net/Makefile2
-rw-r--r--devel/fpc-fcl-registry/Makefile5
-rw-r--r--lang/fpc/Makefile.units4
6 files changed, 15 insertions, 7 deletions
diff --git a/devel/fpc-fcl-db/Makefile b/devel/fpc-fcl-db/Makefile
index 3315d13f2f6d..31f4ce6fe712 100644
--- a/devel/fpc-fcl-db/Makefile
+++ b/devel/fpc-fcl-db/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-db
@@ -18,6 +18,7 @@ BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
${UNITSDIR}/mysql/Package.fpc:${PORTSDIR}/databases/fpc-mysql \
${UNITSDIR}/odbc/Package.fpc:${PORTSDIR}/databases/fpc-odbc \
${UNITSDIR}/oracle/Package.fpc:${PORTSDIR}/databases/fpc-oracle \
+ ${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
${UNITSDIR}/postgres/Package.fpc:${PORTSDIR}/databases/fpc-postgres \
${UNITSDIR}/sqlite/Package.fpc:${PORTSDIR}/databases/fpc-sqlite
diff --git a/devel/fpc-fcl-fpcunit/Makefile b/devel/fpc-fcl-fpcunit/Makefile
index 9d5ec9bd97d0..9712c9384c91 100644
--- a/devel/fpc-fcl-fpcunit/Makefile
+++ b/devel/fpc-fcl-fpcunit/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-fpcunit
@@ -14,7 +14,8 @@ COMMENT= Free Pascal Component Library
BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
- ${UNITSDIR}/fcl-xml/Package.fpc:${PORTSDIR}/devel/fpc-fcl-xml
+ ${UNITSDIR}/fcl-xml/Package.fpc:${PORTSDIR}/devel/fpc-fcl-xml \
+ ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb
UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/devel/fpc-fcl-image/Makefile b/devel/fpc-fcl-image/Makefile
index 900e3f3a9991..6393a3b5134a 100644
--- a/devel/fpc-fcl-image/Makefile
+++ b/devel/fpc-fcl-image/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-image
@@ -18,6 +18,7 @@ BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb \
${UNITSDIR}/pasjpeg/Package.fpc:${PORTSDIR}/graphics/fpc-pasjpeg \
${UNITSDIR}/paszlib/Package.fpc:${PORTSDIR}/archivers/fpc-paszlib \
+ ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
${UNITSDIR}/libpng/Package.fpc:${PORTSDIR}/graphics/fpc-libpng
UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
diff --git a/devel/fpc-fcl-net/Makefile b/devel/fpc-fcl-net/Makefile
index ceb95c02350a..4e07b8b649f2 100644
--- a/devel/fpc-fcl-net/Makefile
+++ b/devel/fpc-fcl-net/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-net
diff --git a/devel/fpc-fcl-registry/Makefile b/devel/fpc-fcl-registry/Makefile
index fb79abf3e405..cac008441309 100644
--- a/devel/fpc-fcl-registry/Makefile
+++ b/devel/fpc-fcl-registry/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
PKGNAMESUFFIX= -fcl-registry
@@ -15,7 +15,8 @@ COMMENT= Free Pascal Component Library
BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc \
${UNITSDIR}/fcl-base/Package.fpc:${PORTSDIR}/devel/fpc-fcl-base \
${UNITSDIR}/fcl-xml/Package.fpc:${PORTSDIR}/devel/fpc-fcl-xml \
- ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync
+ ${UNITSDIR}/libasync/Package.fpc:${PORTSDIR}/net/fpc-libasync \
+ ${UNITSDIR}/netdb/Package.fpc:${PORTSDIR}/net/fpc-netdb
UNITSDIR= ${LOCALBASE}/lib/fpc/${PORTVERSION}/units/${BUILDNAME}
MASTERDIR= ${.CURDIR}/../../lang/fpc
diff --git a/lang/fpc/Makefile.units b/lang/fpc/Makefile.units
index e9e4fcf3e039..32f3c1f21b1b 100644
--- a/lang/fpc/Makefile.units
+++ b/lang/fpc/Makefile.units
@@ -101,6 +101,10 @@ OPT+= -Fuunits/${ARCH}-freebsd -Fu../units/${ARCH}-freebsd \
HAVE_EXAMPLES= true
.endif
+.if ${PKGNAMESUFFIX} == "-fcl-net"
+OPT+= -Fu${WRKDIR}/${WRKUNITDIR}/*
+.endif
+
.if ${PKGNAMESUFFIX} == "-fpgtk"
. if defined(WITH_GTK1)
.include <${PORTSDIR}/Mk/bsd.gnome.mk>