aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/bunny/Makefile38
-rw-r--r--devel/bunny/distinfo3
-rw-r--r--devel/bunny/pkg-descr13
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 68e7e90977e9..bdbfddfbfd8c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -115,6 +115,7 @@
SUBDIR += buildbot
SUBDIR += buildtool
SUBDIR += buildtool-doc
+ SUBDIR += bunny
SUBDIR += byaccj
SUBDIR += bzr-gtk
SUBDIR += bzrtools
diff --git a/devel/bunny/Makefile b/devel/bunny/Makefile
new file mode 100644
index 000000000000..817c9b67489b
--- /dev/null
+++ b/devel/bunny/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: bunny
+# Date created: 28 Jan 2008
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bunny
+PORTVERSION= 0.92
+CATEGORIES= devel
+MASTER_SITES= http://bunny-the-fuzzer.googlecode.com/files/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Closed loop, high-performance, general purpose protocol-blind fuzzer
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PORTDOCS= README
+PLIST_FILES= bin/bunny-trace bin/bunny-gcc bin/bunny-flow bin/bunny-exec \
+ bin/bunny-main
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+.for f in ${PLIST_FILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f:C/bin\///} ${PREFIX}/bin
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/bunny/distinfo b/devel/bunny/distinfo
new file mode 100644
index 000000000000..8bc5f47dd7a4
--- /dev/null
+++ b/devel/bunny/distinfo
@@ -0,0 +1,3 @@
+MD5 (bunny-0.92.tgz) = 37ee71ac134446b5560d912ea82da562
+SHA256 (bunny-0.92.tgz) = dae9be447ea202eb4d5eeb0cba317136fe15861630c1562730ff011f8ecb33c7
+SIZE (bunny-0.92.tgz) = 64537
diff --git a/devel/bunny/pkg-descr b/devel/bunny/pkg-descr
new file mode 100644
index 000000000000..849505d76a59
--- /dev/null
+++ b/devel/bunny/pkg-descr
@@ -0,0 +1,13 @@
+A closed loop, high-performance, general purpose protocol-blind fuzzer for C
+programs.
+
+Uses compiler-level integration to seamlessly inject precise and reliable
+instrumentation hooks into the traced program. These hooks enable the fuzzer to
+receive real-time feedback on changes to the function call path, call
+parameters, and return values in response to variations in input data.
+
+This architecture makes it possible to significantly improve the coverage of the
+testing process without a noticeable performance impact usually associated with
+other attempts to peek into run-time internals.
+
+WWW: http://code.google.com/p/bunny-the-fuzzer/