aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/ruby-net-geoip/Makefile3
-rw-r--r--www/mod_geoip/Makefile5
2 files changed, 5 insertions, 3 deletions
diff --git a/net/ruby-net-geoip/Makefile b/net/ruby-net-geoip/Makefile
index 8dbf24b4170b..d452fa2a3af0 100644
--- a/net/ruby-net-geoip/Makefile
+++ b/net/ruby-net-geoip/Makefile
@@ -7,6 +7,7 @@
PORTNAME= net-geoip
PORTVERSION= 0.06
+PORTREVISION= 1
CATEGORIES= net ruby
MASTER_SITES= http://www.rubynet.org/modules/net/geoip/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ MAINTAINER= seanc@FreeBSD.org
COMMENT= A Ruby extension that wraps around libGeoIP
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
- GeoIP.2:${PORTSDIR}/net/GeoIP
+ GeoIP.3:${PORTSDIR}/net/GeoIP
USE_BZIP2= yes
USE_RUBY= yes
diff --git a/www/mod_geoip/Makefile b/www/mod_geoip/Makefile
index f6977bc14749..3c9d88bf625c 100644
--- a/www/mod_geoip/Makefile
+++ b/www/mod_geoip/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_geoip
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.maxmind.com/download/geoip/api/mod_geoip/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -16,7 +17,7 @@ COMMENT= An Apache module that provides the country code of the client's IP
BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
RUN_DEPENDS= ${APXS}:${APACHE_PORT}
-LIB_DEPENDS= GeoIP.2:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= GeoIP.3:${PORTSDIR}/net/GeoIP
APXS?= ${LOCALBASE}/sbin/apxs
APACHE_PORT?= ${PORTSDIR}/www/apache13
@@ -25,7 +26,7 @@ DOCS= Changes INSTALL README README.php
do-build:
@cd ${WRKSRC} && \
- ${APXS} -c -L${LOCALBASE}/lib -I${LOCALBASE}/include mod_geoip.c
+ ${APXS} -c -L${LOCALBASE}/lib -I${LOCALBASE}/include -lGeoIP mod_geoip.c
do-install:
${APXS} -i -A -n geoip ${WRKSRC}/mod_geoip.so