aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-actioncable52/Makefile27
-rw-r--r--www/rubygem-actioncable52/distinfo3
-rw-r--r--www/rubygem-actioncable52/pkg-descr11
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5122616783b3..559045632128 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1944,6 +1944,7 @@
SUBDIR += rubygem-ace-rails-ap
SUBDIR += rubygem-actioncable5
SUBDIR += rubygem-actioncable50
+ SUBDIR += rubygem-actioncable52
SUBDIR += rubygem-actionpack4
SUBDIR += rubygem-actionpack5
SUBDIR += rubygem-actionpack50
diff --git a/www/rubygem-actioncable52/Makefile b/www/rubygem-actioncable52/Makefile
new file mode 100644
index 000000000000..c27ad35ccbfc
--- /dev/null
+++ b/www/rubygem-actioncable52/Makefile
@@ -0,0 +1,27 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= actioncable
+PORTVERSION= 5.2.3
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 52
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Integrated WebSockets for Rails
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack52>=${PORTVERSION}:www/rubygem-actionpack52 \
+ rubygem-nio4r>=2.0:devel/rubygem-nio4r \
+ rubygem-websocket-driver>=0.6.1:www/rubygem-websocket-driver
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^5\.2\.
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-actioncable52/distinfo b/www/rubygem-actioncable52/distinfo
new file mode 100644
index 000000000000..8d153de3ecde
--- /dev/null
+++ b/www/rubygem-actioncable52/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1566756751
+SHA256 (rubygem/actioncable-5.2.3.gem) = 755e335b8b064592717157057a647ba1c4d519be2a912f11c3993e8d5c4e8d13
+SIZE (rubygem/actioncable-5.2.3.gem) = 41472
diff --git a/www/rubygem-actioncable52/pkg-descr b/www/rubygem-actioncable52/pkg-descr
new file mode 100644
index 000000000000..0d488d870dbd
--- /dev/null
+++ b/www/rubygem-actioncable52/pkg-descr
@@ -0,0 +1,11 @@
+Action Cable - Integrated WebSockets for Rails
+
+Action Cable seamlessly integrates WebSockets with the rest of your Rails
+application. It allows for real-time features to be written in Ruby in the same
+style and form as the rest of your Rails application, while still being
+performant and scalable. It's a full-stack offering that provides both a
+client-side JavaScript framework and a server-side Ruby framework. You have
+access to your full domain model written with Active Record or your ORM of
+choice.
+
+WWW: https://rubyonrails.org/