aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CVSROOT/modules7
-rw-r--r--irc/Makefile1
-rw-r--r--irc/miau/Makefile50
-rw-r--r--irc/miau/distinfo2
-rw-r--r--irc/miau/pkg-descr10
-rw-r--r--irc/miau/pkg-plist7
6 files changed, 74 insertions, 3 deletions
diff --git a/CVSROOT/modules b/CVSROOT/modules
index cd97f72b99c1..dfbf115205fd 100644
--- a/CVSROOT/modules
+++ b/CVSROOT/modules
@@ -4427,6 +4427,7 @@ libgmp-freebsd ports/math/libgmp-freebsd
libgmp4 ports/math/libgmp4
libgnetwork ports/net/libgnetwork
libgnome ports/x11/libgnome
+libgnome-java ports/x11/libgnome-java
libgnomecanvas ports/graphics/libgnomecanvas
libgnomecanvasmm ports/graphics/libgnomecanvasmm
libgnomecups ports/print/libgnomecups
@@ -4436,7 +4437,6 @@ libgnomeprint ports/print/libgnomeprint
libgnomeprintui ports/x11-toolkits/libgnomeprintui
libgnomeui ports/x11-toolkits/libgnomeui
libgnomeuimm ports/x11-toolkits/libgnomeuimm
-libgnome-java ports/x11/libgnome-java
libgnugetopt ports/devel/libgnugetopt
libgpg-error ports/security/libgpg-error
libgphoto2 ports/graphics/libgphoto2
@@ -4518,6 +4518,7 @@ libpathan ports/textproc/libpathan
libpci ports/devel/libpci
libpdel ports/devel/libpdel
libpdf++ ports/print/libpdf++
+libpdtp ports/net/libpdtp
libprelude ports/security/libprelude
libpreps ports/devel/libpreps
libpreps-devel ports/devel/libpreps-devel
@@ -5007,6 +5008,7 @@ mhc-xemacs21-mule ports/deskutils/mhc-xemacs21-mule
mhonarc ports/www/mhonarc
mhwaveedit ports/audio/mhwaveedit
mi-aspell ports/textproc/mi-aspell
+miau ports/irc/miau
mico ports/devel/mico
micq ports/net/micq
micro_httpd ports/www/micro_httpd
@@ -7240,6 +7242,7 @@ pdnmesh ports/cad/pdnmesh
pdnsd ports/dns/pdnsd
pdq ports/print/pdq
pdss ports/lang/pdss
+pdtpd ports/net/pdtpd
pdumpfs ports/sysutils/pdumpfs
peacock ports/www/peacock
pear-APC ports/www/pear-APC
@@ -10948,5 +10951,3 @@ zthread ports/devel/zthread
ztrack ports/games/ztrack
zu-aspell ports/textproc/zu-aspell
zziplib ports/devel/zziplib
-pdtpd ports/net/pdtpd
-libpdtp ports/net/libpdtp
diff --git a/irc/Makefile b/irc/Makefile
index d9c862602968..ee959f70d7a5 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -46,6 +46,7 @@
SUBDIR += liece-dcc
SUBDIR += liece-emacs20
SUBDIR += lostirc
+ SUBDIR += miau
SUBDIR += muh
SUBDIR += nethirc
SUBDIR += ngircd
diff --git a/irc/miau/Makefile b/irc/miau/Makefile
new file mode 100644
index 000000000000..cf0e03ae5315
--- /dev/null
+++ b/irc/miau/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: miau
+# Date created: 23 Apr 2004
+# Whom: Oliver Eikemeier
+#
+# $FreeBSD$
+#
+
+PORTNAME= miau
+PORTVERSION= 0.5.2
+CATEGORIES= irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= miau
+
+MAINTAINER= eik@FreeBSD.org
+COMMENT= A fully featured easy to use IRC-bouncer
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+USE_REINPLACE= yes
+
+INFO= miau
+
+CONFIGURE_ARGS= --enable-dccbounce \
+ --enable-automode \
+ --enable-releasenick \
+ --enable-ctcp-replies \
+ --enable-mkpasswd \
+ --enable-uptime \
+ --enable-chanlog \
+ --enable-privlog \
+ --enable-onconnect \
+ --enable-empty-awaymsg \
+ --disable-dependency-tracking
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ LIBS="${LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,\$$datadir/doc/miau/examples,${EXAMPLESDIR},g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/miau/distinfo b/irc/miau/distinfo
new file mode 100644
index 000000000000..78ed548aa351
--- /dev/null
+++ b/irc/miau/distinfo
@@ -0,0 +1,2 @@
+MD5 (miau-0.5.2.tar.bz2) = 8c3f141532959206f4a1cb0280360eb5
+SIZE (miau-0.5.2.tar.bz2) = 158960
diff --git a/irc/miau/pkg-descr b/irc/miau/pkg-descr
new file mode 100644
index 000000000000..9a088b00e5f9
--- /dev/null
+++ b/irc/miau/pkg-descr
@@ -0,0 +1,10 @@
+miau is a fully featured easy to use IRC-bouncer that can keep your nick
+even when you disconnect.
+
+Additionally, miau can set you away automatically when you disconnect and
+auto-op (or auto-voice) people. While you're disconnected, miau can also log
+everything and/or pipe private messages to an external program. And when you
+connect miau again, miau can replay some of the old messages so that you know
+what's going on.
+
+WWW: http://miau.sourceforge.net/
diff --git a/irc/miau/pkg-plist b/irc/miau/pkg-plist
new file mode 100644
index 000000000000..58cb90371f5a
--- /dev/null
+++ b/irc/miau/pkg-plist
@@ -0,0 +1,7 @@
+bin/miau
+bin/miau-check
+bin/miau-rotatelog
+%%EXAMPLESDIR%%/miaurc
+@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%@dirrm %%DOCSDIR%%