aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/wordplay/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/games/wordplay/Makefile b/games/wordplay/Makefile
index 4072f320a02d..5fee4216200f 100644
--- a/games/wordplay/Makefile
+++ b/games/wordplay/Makefile
@@ -19,8 +19,7 @@ PORTDOCS= readme
PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/words721.txt
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|CC=gcc|CC?=g++|' ${WRKSRC}/makefile
@@ -31,12 +30,11 @@ do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${PORTNAME}.c -o ${PORTNAME}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/words721.txt ${DATADIR}
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/words721.txt ${STAGEDIR}${DATADIR}
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
p;id=592d108b32345f1b64792a157b182e4f7c31f162'>Add googlecl 0.9.5, command line tools for the Google Data APIs.lwhsu2010-06-195-0/+81 * Mark as broken on sparc64.linimon2010-06-191-0/+4 * Depend on neon 29 if found.kwm2010-06-191-2/+6 * Reset longtime inactive maintainer due to timeouts.linimon2010-06-191-1/+1 * Note removal of sysutils/tinybsd.linimon2010-06-191-0/+1 * Remove tinybsd: now incorporated into base system of all supported versionslinimon2010-06-195-126/+0 * Remove obsolete port tinybsd.linimon2010-06-191-1/+0 * Reset jmelo@FreeBSD.org due to many months of inactivity and no responselinimon2010-06-1926-32/+22 * - Security update to 1.4.4dinoex2010-06-192-0/+37 * - Unbreak with fixed pkg-plistglarkin2010-06-192-6/+3 * - Update KOffice (and its l10n packs) to 2.2.0 releasefluffy2010-06-19110-1390/+2303 * Ports modules update at Saturday 19 June 2010 at 00:09edwin2010-06-190-0/+0 * Update to the 20100617 snapshot of GCC 4.5.1.gerald2010-06-192-16/+16 * - Fix distinfotabthorpe2010-06-191-3/+3 * - Update to 2.6tabthorpe2010-06-193-7/+7 * - Update to 1.58tabthorpe2010-06-193-10/+10 * - Update to 4.178tabthorpe2010-06-192-4/+4 * Over to new volunteer. Previous maintainer had been inactive forlinimon2010-06-191-1/+1 * Take maintainershipmakc2010-06-191-1/+1 * Update to 0.99.6makc2010-06-1920-265/+20 * Update to RC4 of Wine 1.2. This brings many further translation updatesgerald2010-06-194-8/+8 * Fix pkg-plist.osa2010-06-192-0/+2 * Fix pkg-plist.osa2010-06-192-4/+1 * Fix unknown error.osa2010-06-193-4/+2 * Fix pkg-plist.osa2010-06-192-2/+3 * Mark MAKE_JOBS_UNSAFE.mandree2010-06-191-0/+1 * Security: CVE-2010-2063timur2010-06-182-0/+44 * Switch default MySQL version from 5.0-EOL to 5.1-GA.ale2010-06-181-3/+3 * - Update deskutils/plasma-applet-yawp to 0.3.3 releasefluffy2010-06-186-36/+35 * Security: CVE-2010-2063timur2010-06-182-1/+44 * Update to 5.1.48 releaseale2010-06-182-4/+4 * Remove wrong hard-coded dependencies to MySQL 5.0.ale2010-06-183-5/+2 * Feature freeze for 8.1 is now in effect.erwin2010-06-181-1/+1 * Take maintainership, I am using this port on a regular basisehaupt2010-06-181-1/+1 * Reset nobutaka@FreeBSD.org on certain ports at his request due tolinimon2010-06-183-3/+3 * Reset q@onthenet.com.au due to maintiner-timeouts and no response to email.linimon2010-06-187-7/+7 * Fix dependenciesaz2010-06-181-1/+3 * Reset pesho.petrov@gmail.com due to maintainer-timeouts and no responselinimon2010-06-183-3/+3 * Reset geraud@gcu.info due to maintainer-timeouts and no response to email.linimon2010-06-183-3/+3 * Reset david@trucs.org, who currently does not have time to work onlinimon2010-06-188-12/+5 * Update WWWehaupt2010-06-181-1/+1 * - Fix build with new vtkpav2010-06-182-4/+65 * Update for version 2.32dougb2010-06-181-1/+1 * build_l also needs to be unset in pm_make_s()dougb2010-06-181-1/+1 * - Update to 0.7.3mva2010-06-182-5/+4 * Drop maintainership to ports@az2010-06-181-1/+1 * Unset build_l in pm_make()dougb2010-06-181-1/+1 * - Update to 0.21.1mva2010-06-182-5/+4 * Do not take setuptools into account, if they are installed.mva2010-06-181-0/+2 * - Update to 0.50.3.mva2010-06-182-4/+4 * Update for version 2.30dougb2010-06-181-1/+1 * If the user specified --no-confirm don't build the list. With a lot ofdougb2010-06-181-1/+6 * Change broken MASTER_SITES for third-party fancyindex module to MASTER_SITE_L...osa2010-06-183-6/+8 * Turns out that the bind.keys.h file is not a new dependency, so my previousdougb2010-06-182-53/+4 * Correct my locationbrian2010-06-181-1/+1 * The newly added bind.keys.h file requires perl for its creation,dougb2010-06-181-0/+53 * vuln 4e8344a3-ca52-11de-8ee8-00215c6a37bb has been fixed withdelphij2010-06-181-2/+2 * - simplify dependencyleeym2010-06-181-6/+9 * Ports modules update at Friday 18 June 2010 at 00:09edwin2010-06-181-0/+1 * Remove mention of previous maintainer.linimon2010-06-181-3/+0 * Clean up this port so it deinstalls cleanly. Remove one level oflinimon2010-06-182-81/+131 * Update to version 9.7.1, the latest from ISC.dougb2010-06-182-8/+8 * Describe the changes to gnupg and dirmngr to utilize the new libassuandougb2010-06-181-1/+29 * Update to version 2.0.15, which has the following changes:dougb2010-06-182-13/+10 * Upgrade to version 1.1.0, which has the following changes:dougb2010-06-182-8/+19 * - Fix SSL related error, lighttpd bug #2157garga2010-06-182-1/+12 * - Update to 2010.06.15dhn2010-06-183-4/+5 * Upgrade to r104832 (the version in head.)brooks2010-06-185-25/+17 * Add missing file uwsgi_params.osa2010-06-172-1/+3 * Add swank-clojure, a server that allows SLIME (the Superior Lispolgeni2010-06-174-0/+50 * Mark ignore, useless without uep(4).osa2010-06-171-1/+8 * Install additional documentation and examples in the correct place.naddy2010-06-175-239/+279 * add pkg-message when gamess won't run and bump portrevision accordingly.maho2010-06-172-1/+14 * Switch to USE_ANT and MAKE_ARGS.olgeni2010-06-171-4/+3 * - Add basic docs to portdocsmm2010-06-173-2/+36 * Properly sort RUN and BUILD DEPENDS that I inherited when I took overdougb2010-06-171-2/+2 * - Update to 0.604wen2010-06-172-6/+5 * Update p4d to 2009.2 rev 249896.gordon2010-06-178-23/+23 * - Update to 1.7.9wen2010-06-173-4/+14 * - Update to 1.5.4wen2010-06-172-4/+4 * - Update to 0.06wen2010-06-172-5/+5 * - Update to 0.07wen2010-06-172-5/+5 * Ports modules update at Thursday 17 June 2010 at 00:09edwin2010-06-171-0/+1 * Update to week 24 snapshotjpaetzel2010-06-172-5/+6 * Add LGPL20 or GNU Library General Public License version 2.0.kwm2010-06-171-1/+4 * - Update to 1.1.1lme2010-06-172-27/+41 * - Upgrade to 2.0.0;thierry2010-06-172-7/+8 * - Add a license;thierry2010-06-171-1/+4 * Update tls patch to 0.6garga2010-06-172-5/+5 * - Mark BROKEN: does not buildpav2010-06-171-0/+2 * Mark BROKEN on pointyhatjpaetzel2010-06-171-0/+5 * Security: CVE-2010-2063timur2010-06-16