aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pystun/Makefile19
-rw-r--r--net/py-pystun/distinfo2
-rw-r--r--net/py-pystun/pkg-descr3
4 files changed, 25 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 520b825a55f1..e2be7bea3afb 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -966,6 +966,7 @@
SUBDIR += py-pysmb
SUBDIR += py-pysocks
SUBDIR += py-pysphere
+ SUBDIR += py-pystun
SUBDIR += py-python-bitcoinrpc
SUBDIR += py-pyvmomi
SUBDIR += py-pyzmq
diff --git a/net/py-pystun/Makefile b/net/py-pystun/Makefile
new file mode 100644
index 000000000000..0adbf5f90853
--- /dev/null
+++ b/net/py-pystun/Makefile
@@ -0,0 +1,19 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pystun
+PORTVERSION= 0.1.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python STUN client for getting NAT type and external IP
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/py-pystun/distinfo b/net/py-pystun/distinfo
new file mode 100644
index 000000000000..4f900abe2026
--- /dev/null
+++ b/net/py-pystun/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pystun-0.1.0.tar.gz) = 787a2d1c1328ae8ac31152a0d6d96b2f02ab8677febdc25e463c2c8fee34679f
+SIZE (pystun-0.1.0.tar.gz) = 6286
diff --git a/net/py-pystun/pkg-descr b/net/py-pystun/pkg-descr
new file mode 100644
index 000000000000..d2dbf507ac00
--- /dev/null
+++ b/net/py-pystun/pkg-descr
@@ -0,0 +1,3 @@
+A Python STUN client for getting NAT type and external IP.
+
+WWW: https://pypi.python.org/pypi/pystun