aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.options.desc.mk1
-rw-r--r--astro/google-earth/Makefile1
-rw-r--r--emulators/linux-c6/Makefile8
-rw-r--r--emulators/linux-c7/Makefile8
-rw-r--r--games/linux-darwinia-demo/Makefile16
-rw-r--r--games/linux-defcon/Makefile16
-rw-r--r--games/linux-doom3-demo/Makefile10
-rw-r--r--games/linux-enemyterritory/Makefile9
-rw-r--r--games/linux-nerogame/Makefile17
-rw-r--r--games/linux-nwnclient/Makefile14
-rw-r--r--games/linux-rtcw/Makefile17
-rw-r--r--games/linux-unigine-heaven/Makefile9
-rw-r--r--games/linux-unigine-valley/Makefile9
-rw-r--r--games/linux-uplink-demo/Makefile16
-rw-r--r--games/linux-ut2003-demo/Makefile14
-rw-r--r--games/linux-virtual-jay-peak/Makefile12
-rw-r--r--games/linux-worldofgoo-demo/Makefile15
-rw-r--r--graphics/linux-c6-glx-utils/Makefile14
-rw-r--r--graphics/linux-c7-glx-utils/Makefile8
-rw-r--r--net-im/skype-devel/Makefile18
-rw-r--r--net-im/skype/Makefile17
-rw-r--r--net-im/skype4/Makefile6
-rw-r--r--x11-toolkits/linux-c6-qt47-x11/Makefile10
-rw-r--r--x11-toolkits/linux-c7-qt-x11/Makefile9
24 files changed, 64 insertions, 210 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index 3410734c3599..dce378507270 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -356,7 +356,6 @@ NOTIFY_DESC?= Desktop notification support
NSS_DESC?= SSL/TLS support via NSS
NTLM_DESC?= NTLM authentication support
NUMPY_DESC?= NumPy mathematical computing support
-NVIDIA_GL_DESC?= libGL support via nvidia-driver
OBJC_DESC?= Objective-C language support
ODBC_DESC?= ODBC database backend
ODF_DESC?= Open Document Format (ODF) file support
diff --git a/astro/google-earth/Makefile b/astro/google-earth/Makefile
index 4ba94a54ea34..1da68d76b782 100644
--- a/astro/google-earth/Makefile
+++ b/astro/google-earth/Makefile
@@ -19,6 +19,7 @@ OPTIONS_DEFAULT= LINUX_DRI
OPTIONS_SINGLE= LIBGL
OPTIONS_SINGLE_LIBGL= LINUX_DRI NVIDIA_GL NVIDIA_GL_340 NVIDIA_GL_304
LINUX_DRI_DESC= libGL support via Linux DRI libraries
+NVIDIA_GL_DESC= libGL support via nvidia-driver
NVIDIA_GL_340_DESC= libGL support via nvidia-driver-340
NVIDIA_GL_304_DESC= libGL support via nvidia-driver-304
diff --git a/emulators/linux-c6/Makefile b/emulators/linux-c6/Makefile
index ef5cd3c0c0ed..d2effb3429af 100644
--- a/emulators/linux-c6/Makefile
+++ b/emulators/linux-c6/Makefile
@@ -3,6 +3,7 @@
PORTNAME= linux-c6
PORTVERSION= ${LINUX_DIST_VER}
+PORTREVISION= 1
CATEGORIES= emulators linux
MAINTAINER= emulation@FreeBSD.org
@@ -68,6 +69,7 @@ RUN_DEPENDS= linux-c6-libasyncns>0:dns/linux-c6-libasyncns \
linux-c6-expat>0:textproc/linux-c6-expat \
linux-c6-aspell>0:textproc/linux-c6-aspell \
linux-c6-libxml2>0:textproc/linux-c6-libxml2 \
+ linux-c6-dri>0:graphics/linux-c6-dri \
linux-c6-sdl_image>0:graphics/linux-c6-sdl_image \
linux-c6-sdl_ttf>0:graphics/linux-c6-sdl_ttf \
linux-c6-png>0:graphics/linux-c6-png \
@@ -79,10 +81,4 @@ RUN_DEPENDS= linux-c6-libasyncns>0:dns/linux-c6-libasyncns \
USES= linux:c6 metaport
-OPTIONS_DEFINE= NVIDIA_GL
-
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver \
- linux-c6-libGLU>0:graphics/linux-c6-libGLU
-NVIDIA_GL_RUN_DEPENDS_OFF= linux-c6-dri>0:graphics/linux-c6-dri
-
.include <bsd.port.mk>
diff --git a/emulators/linux-c7/Makefile b/emulators/linux-c7/Makefile
index 7df4c7661614..2ca31a571a5a 100644
--- a/emulators/linux-c7/Makefile
+++ b/emulators/linux-c7/Makefile
@@ -3,6 +3,7 @@
PORTNAME= linux-c7
PORTVERSION= ${LINUX_DIST_VER}
+PORTREVISION= 1
CATEGORIES= emulators linux
MAINTAINER= emulation@FreeBSD.org
@@ -61,6 +62,7 @@ RUN_DEPENDS= linux-c7-libasyncns>0:dns/linux-c7-libasyncns \
linux-c7-expat>0:textproc/linux-c7-expat \
linux-c7-aspell>0:textproc/linux-c7-aspell \
linux-c7-libxml2>0:textproc/linux-c7-libxml2 \
+ linux-c7-dri>0:graphics/linux-c7-dri \
linux-c7-png>0:graphics/linux-c7-png \
linux-c7-tiff>0:graphics/linux-c7-tiff \
linux-c7-jpeg>0:graphics/linux-c7-jpeg \
@@ -84,10 +86,4 @@ RUN_DEPENDS+= linux-c7-sdl_image>0:graphics/linux-c7-sdl_image \
linux-c7-qtwebkit>0:www/linux-c7-qtwebkit
.endif
-OPTIONS_DEFINE= NVIDIA_GL
-
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver \
- linux-c7-libGLU>0:graphics/linux-c7-libGLU
-NVIDIA_GL_RUN_DEPENDS_OFF= linux-c7-dri>0:graphics/linux-c7-dri
-
.include <bsd.port.post.mk>
diff --git a/games/linux-darwinia-demo/Makefile b/games/linux-darwinia-demo/Makefile
index 4533fa60dfd8..0fcef2e54aa8 100644
--- a/games/linux-darwinia-demo/Makefile
+++ b/games/linux-darwinia-demo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= darwinia-demo
PORTVERSION= 1.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://download.introversion.co.uk/mirror/introversion/darwinia/downloads/
PKGNAMEPREFIX= linux-
@@ -14,7 +14,7 @@ COMMENT= Real-time action strategy with programs
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= sdl12 libogg libvorbis xorglibs
+USE_LINUX= dri libogg libvorbis sdl12 xorglibs
NO_CDROM= Redistribution is limited, see license
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -22,17 +22,7 @@ NO_WRKSUBDIR= yes
DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
SUB_FILES= darwinia
-OPTIONS_DEFINE= NVIDIA DOCS
-NVIDIA_DESC= Enable nvidia graphics driver support
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNVIDIA}
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX+= libglu
-.else
-USE_LINUX+= dri
-.endif
+OPTIONS_DEFINE= DOCS
do-extract:
@cd ${WRKSRC} && ${TAIL} +376 ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
diff --git a/games/linux-defcon/Makefile b/games/linux-defcon/Makefile
index dc35f420c943..0384874b72b4 100644
--- a/games/linux-defcon/Makefile
+++ b/games/linux-defcon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= defcon
PORTVERSION= 1.42
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://download.introversion.co.uk/defcon/linux/
PKGNAMEPREFIX= linux-
@@ -14,24 +14,14 @@ COMMENT= Defcon for Linux
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= sdl12 libogg libvorbis xorglibs
+USE_LINUX= dri libogg libvorbis sdl12 xorglibs
NO_CDROM= Redistribution is limited, see license
NO_BUILD= yes
DATADIR= ${PREFIX}/lib/${PKGNAMEPREFIX}${PORTNAME}
SUB_FILES= defcon
-OPTIONS_DEFINE= NVIDIA DOCS
-NVIDIA_DESC= support for nvidia
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNVIDIA}
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX+= libglu
-.else
-USE_LINUX+= dri
-.endif
+OPTIONS_DEFINE= DOCS
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/games/linux-doom3-demo/Makefile b/games/linux-doom3-demo/Makefile
index a82755664b81..8c8d334ee0a2 100644
--- a/games/linux-doom3-demo/Makefile
+++ b/games/linux-doom3-demo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= doom3-demo
PORTVERSION= 1.1.1286
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games linux
MASTER_SITES= http://www.hup.hu/~trey/DOOM3/ \
http://darkstar.ist.utl.pt/pub/games/ \
@@ -18,7 +18,7 @@ COMMENT= DOOM III demo for Linux
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= xorglibs
+USE_LINUX= dri xorglibs
NO_CDROM= Redistribution is limited, see license; Requested by id Software
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -28,11 +28,7 @@ DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
SUB_FILES= doom3-demo
SUB_LIST= DOOMDIR="${DOOMDIR}"
-OPTIONS_DEFINE= DOCS NVIDIA_GL
-
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE_OFF= LINUX=dri
-
+OPTIONS_DEFINE= DOCS
do-extract:
@${MKDIR} ${WRKSRC}
diff --git a/games/linux-enemyterritory/Makefile b/games/linux-enemyterritory/Makefile
index d5489e0f390d..2cf3113398ed 100644
--- a/games/linux-enemyterritory/Makefile
+++ b/games/linux-enemyterritory/Makefile
@@ -3,7 +3,7 @@
PORTNAME= enemyterritory
PORTVERSION= 2.60b
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games linux
MASTER_SITES= IDSOFTWARE/et/:patch \
IDSOFTWARE/et/linux/:full
@@ -16,15 +16,12 @@ COMMENT= Wolfenstein: Enemy Territory (Linux version)
ONLY_FOR_ARCHS= i386 amd64
USES= linux zip:infozip
-USE_LINUX= xorglibs
+USE_LINUX= dri xorglibs
NO_CDROM= Redistribution limited
ETDIR= ${PREFIX}/lib/${PORTNAME}
PATCH_260B_DIR= Enemy Territory 2.60b
-OPTIONS_DEFINE= DOCS NVIDIA_GL
-
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE_OFF= LINUX=dri
+OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
diff --git a/games/linux-nerogame/Makefile b/games/linux-nerogame/Makefile
index e1f92a19fb7f..aa63e960fa9f 100644
--- a/games/linux-nerogame/Makefile
+++ b/games/linux-nerogame/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nerogame
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://nn.cs.utexas.edu/nero/downloads/
PKGNAMEPREFIX= linux-
@@ -13,7 +13,7 @@ MAINTAINER= craig001@lerwick.hopto.org
COMMENT= Neuro evolving robotic operatives the game
USES= linux
-USE_LINUX= libvorbis sdl12 libtheora
+USE_LINUX= dri libtheora libvorbis sdl12
NO_BUILD= yes
RESTRICTED= Nero is freeware, but i am not sure of its license
@@ -21,19 +21,6 @@ SUB_FILES= nerogame pkg-message
DATADIR= share/${PKGNAMEPREFIX}${PORTNAME}
WRKSRC= ${WRKDIR}/${DISTNAME}
-OPTIONS_DEFINE= NVIDIA
-NVIDIA_DESC= Nvidia support
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNVIDIA}
-. if !exists(${LINUXBASE}/usr/lib/libGL.so.1)
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-. endif
-.else
-USE_LINUX+= dri
-.endif
-
do-install:
${BRANDELF} -t Linux ${WRKSRC}/nero.bin
${INSTALL_PROGRAM} ${WRKSRC}/nero.bin ${STAGEDIR}${PREFIX}/libexec/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 31be7ee0ddf5..6525c9cd2ead 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nwnclient
PORTVERSION= 1.69
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games linux
MASTER_SITES= http://na.llnet.bioware.cdn.ea.com/u/f/eagames/bioware/neverwinternights/updates/linux/${PORTVERSION:S/.//}/:CLIENT \
http://nwdownloads.bioware.com/neverwinternights/linux/129/:ORIG \
@@ -24,21 +24,13 @@ RUN_DEPENDS= ${LOCALBASE}/share/nwndata/docs/readme.txt:games/nwndata
NO_BUILD= yes
RESTRICTED= Distribution not allowed
USES= linux
-USE_LINUX= sdl12 xorglibs
+USE_LINUX= dri sdl12 xorglibs
NWNDATADIR= ${LOCALBASE}/share/nwndata
-.ifdef WITH_NVIDIA_GL
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX+= libglu
-.else
-USE_LINUX+= dri
-.endif
-
OPTIONS_DEFINE= NWMOVIES
NWMOVIES_DESC= Support for movies using BinkPlayer
.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
# Client detection. Currently, detects only original and Diamond editions.
.if exists(${LOCALBASE}/share/nwndata/xp2.key)
@@ -98,4 +90,4 @@ do-install:
.endif
${INSTALL_SCRIPT} ${WRKDIR}/nwn ${STAGEDIR}${PREFIX}/bin/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/linux-rtcw/Makefile b/games/linux-rtcw/Makefile
index a4cb91ad0b5e..99108078081c 100644
--- a/games/linux-rtcw/Makefile
+++ b/games/linux-rtcw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rtcw
DISTVERSION= 1.41b
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games linux
MASTER_SITES= IDSOFTWARE/wolf/linux
PKGNAMEPREFIX= linux-
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Return to Castle Wolfenstein (Linux version)
USES= linux makeself
-USE_LINUX= xorglibs
+USE_LINUX= dri xorglibs
NO_WRKSUBDIR= yes
WRAPPERS= wolf wolfded wolfsp
@@ -24,16 +24,7 @@ PORTSCOUT= skipv:1.41-3
PORTDOCS= *
-OPTIONS_DEFINE= DOCS NVIDIA_GL
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNVIDIA_GL}
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_EXTVER= '__GL_ExtensionStringVersion=18999 '
-.else
-USE_LINUX+= dri
-.endif
+OPTIONS_DEFINE= DOCS
# XXX: should probably be converted to use the LICENSE framework
post-extract:
@@ -43,7 +34,7 @@ do-build:
.for f in ${WRAPPERS}
(${ECHO_CMD} "#!${SH}"; ${ECHO_CMD}; \
${ECHO_CMD} "cd ${DATADIR} || exit 1"; \
- ${ECHO_CMD} '${NVIDIA_GL_EXTVER}exec ./${f} "$$@"') > ${WRKDIR}/${f}
+ ${ECHO_CMD} 'exec ./${f} "$$@"') > ${WRKDIR}/${f}
.endfor
do-install:
diff --git a/games/linux-unigine-heaven/Makefile b/games/linux-unigine-heaven/Makefile
index ca818c755669..28f7cebda955 100644
--- a/games/linux-unigine-heaven/Makefile
+++ b/games/linux-unigine-heaven/Makefile
@@ -3,7 +3,7 @@
PORTNAME= unigine-heaven
PORTVERSION= 4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games benchmarks linux
MASTER_SITES= http://de1-dl.techpowerup.com/Benchmarking/ \
http://nl1-dl.techpowerup.com/Benchmarking/ \
@@ -24,15 +24,10 @@ LICENSE_PERMS= no-dist-sell no-pkg-sell no-dist-mirror no-pkg-mirror
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= xorglibs openal-soft
+USE_LINUX= dri openal-soft xorglibs
USE_LDCONFIG= yes
NO_BUILD= yes
-OPTIONS_DEFINE= NVIDIA_GL
-NVIDIA_GL_DESC= Use GL driver from nvidia-driver
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_VARS_OFF= USE_LINUX+= dri
-
do-extract:
@${MKDIR} ${WRKSRC}
cd ${WRKSRC} && ${TAIL} -n 1098568 ${_DISTDIR}/${DISTFILES} | ${TAR} zxf -
diff --git a/games/linux-unigine-valley/Makefile b/games/linux-unigine-valley/Makefile
index 32093bf7dcc8..ded3de38dc6f 100644
--- a/games/linux-unigine-valley/Makefile
+++ b/games/linux-unigine-valley/Makefile
@@ -3,7 +3,7 @@
PORTNAME= unigine-valley
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games benchmarks linux
MASTER_SITES= http://de1-dl.techpowerup.com/Benchmarking/ \
http://nl1-dl.techpowerup.com/Benchmarking/ \
@@ -24,15 +24,10 @@ LICENSE_PERMS= no-dist-sell no-pkg-sell no-dist-mirror no-pkg-mirror
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= xorglibs openal-soft
+USE_LINUX= dri openal-soft xorglibs
USE_LDCONFIG= yes
NO_BUILD= yes
-OPTIONS_DEFINE= NVIDIA_GL
-NVIDIA_GL_DESC= Use GL driver from nvidia-driver
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_VARS_OFF= USE_LINUX+= dri
-
do-extract:
@${MKDIR} ${WRKSRC}
cd ${WRKSRC} && ${TAIL} -n 1491255 ${_DISTDIR}/${DISTFILES} | ${TAR} zxf -
diff --git a/games/linux-uplink-demo/Makefile b/games/linux-uplink-demo/Makefile
index b5e7c359e511..130ef3cc3e59 100644
--- a/games/linux-uplink-demo/Makefile
+++ b/games/linux-uplink-demo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uplink-demo
PORTVERSION= 1.55
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= http://www.introversion.co.uk/uplink/downloads/
PKGNAMEPREFIX= linux-
@@ -15,7 +15,7 @@ COMMENT= High tech computer crime and industrial espionage on the Internet
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= sdl12 jpeg sdlmixer mikmod libvorbis xorglibs
+USE_LINUX= dri jpeg libvorbis mikmod sdl12 sdlmixer xorglibs
USE_LDCONFIG= yes
NO_CDROM= Redistribution is limited, see license
NO_BUILD= yes
@@ -26,17 +26,7 @@ SUB_FILES= uplink
SUB_LIST= LINUXBASE=${LINUXBASE}
DOCFILES= license.txt mods.txt Readme-UplinkSupport.txt readme.txt
-OPTIONS_DEFINE= NVIDIA DOCS
-NVIDIA_DESC= support for nvidia
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNVIDIA}
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX+= libglu
-.else
-USE_LINUX+= dri
-.endif
+OPTIONS_DEFINE= DOCS
do-extract:
@cd ${WRKSRC} && ${TAIL} +376 ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
diff --git a/games/linux-ut2003-demo/Makefile b/games/linux-ut2003-demo/Makefile
index 195ec22ce831..8f1acfa4ff91 100644
--- a/games/linux-ut2003-demo/Makefile
+++ b/games/linux-ut2003-demo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ut2003-demo
PORTVERSION= 2206
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games linux
MASTER_SITES= GENTOO
PKGNAMEPREFIX= linux-
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Unreal Tournament 2003 demo
USES= linux
-USE_LINUX= sdl12 xorglibs
+USE_LINUX= dri sdl12 xorglibs
RESTRICTED= Redistribution is limited, see license
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -35,15 +35,7 @@ PORTDOCS= *
LIBDIRS= Animations Benchmark ForceFeedback KarmaData Maps Music \
Sounds StaticMeshes System Textures Web
-OPTIONS_DEFINE= DOCS NVIDIA_GL
-
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-
-.include <bsd.port.options.mk>
-
-.if ! ${PORT_OPTIONS:MNVIDIA_GL}
-USE_LINUX+= dri
-.endif
+OPTIONS_DEFINE= DOCS
do-extract:
@${MKDIR} ${WRKSRC}
diff --git a/games/linux-virtual-jay-peak/Makefile b/games/linux-virtual-jay-peak/Makefile
index b27411a7abfa..750fbb0383da 100644
--- a/games/linux-virtual-jay-peak/Makefile
+++ b/games/linux-virtual-jay-peak/Makefile
@@ -3,7 +3,7 @@
PORTNAME= virtual-jay-peak
PORTVERSION= 1.1a
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games linux
MASTER_SITES= http://www.soulride.com/products/images/
PKGNAMEPREFIX= linux-
@@ -12,23 +12,17 @@ DISTNAME= virtual_jay_peak_linux_1_1a
MAINTAINER= ports@FreeBSD.org
COMMENT= Simulation of snowboarding at the Jay Peak resort in Vermont
-OPTIONS_DEFINE= DOCS NVIDIA
+OPTIONS_DEFINE= DOCS
WRKSRC= ${WRKDIR}/soulride
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= xorglibs
+USE_LINUX= dri xorglibs
NO_BUILD= yes
SUB_FILES= virtual-jay-peak
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNVIDIA}
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-.else
-USE_LINUX+= dri
-.endif
-
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/virtual-jay-peak ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/soulride-static ${STAGEDIR}${PREFIX}/libexec
diff --git a/games/linux-worldofgoo-demo/Makefile b/games/linux-worldofgoo-demo/Makefile
index b2e54a4ddefa..9cce2bef1d3c 100644
--- a/games/linux-worldofgoo-demo/Makefile
+++ b/games/linux-worldofgoo-demo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= worldofgoo
PORTVERSION= 1.41
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games linux
MASTER_SITES= http://freebsd.nsu.ru/distfiles/
PKGNAMEPREFIX= linux-
@@ -15,7 +15,7 @@ COMMENT= Demo version of incredible physics based puzzle/construction game
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= libvorbis mikmod sdl12 sdlmixer
+USE_LINUX= dri libvorbis mikmod sdl12 sdlmixer
NO_BUILD= yes
WRKSRC= ${WRKDIR}/WorldOfGooDemo
DATADIR= ${PREFIX}/share/WorldOfGoo
@@ -23,14 +23,7 @@ DOCSDIR= ${PREFIX}/share/doc/WorldOfGoo
OPTIONS_DEFINE= DOCS
-.if defined(WITH_NVIDIA_GL)
-RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX+= libglu
-.else
-USE_LINUX+= dri
-.endif
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
TARGET_BIN= WorldOfGoo.bin32
@@ -61,4 +54,4 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/linux-c6-glx-utils/Makefile b/graphics/linux-c6-glx-utils/Makefile
index ca5e39a655a7..051307d55bf1 100644
--- a/graphics/linux-c6-glx-utils/Makefile
+++ b/graphics/linux-c6-glx-utils/Makefile
@@ -3,24 +3,18 @@
PORTNAME= glx-utils
PORTVERSION= 11.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
COMMENT= RPM of the GLX utils (Linux CentOS ${LINUX_DIST_VER})
-USES= linux:c6
-USE_LINUX_RPM= nolib
RPMVERSION= 4.el6
+USES= linux:c6
USE_LDCONFIG= yes
+USE_LINUX= dri xorglibs
+USE_LINUX_RPM= nolib
-OPTIONS_DEFINE= NVIDIA_GL
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE= LINUX=libglu
-NVIDIA_GL_USE_OFF= LINUX=dri
-
-.if defined(PACKAGE_BUILDING)
SRC_DISTFILES= mesa-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}:SOURCE
-.endif
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-glx-utils/Makefile b/graphics/linux-c7-glx-utils/Makefile
index 36f3a32c1b37..751db7044c53 100644
--- a/graphics/linux-c7-glx-utils/Makefile
+++ b/graphics/linux-c7-glx-utils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= glx-utils
PORTVERSION= 8.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
@@ -14,13 +14,9 @@ CONFLICTS= linux-f10-${PORTNAME}-[0-9]* linux-c6-${PORTNAME}-[0-9]*
RPMVERSION= 2.el7
USES= linux:c7
USE_LDCONFIG= yes
+USE_LINUX= dri xorglibs
USE_LINUX_RPM= nolib
-OPTIONS_DEFINE= NVIDIA_GL
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE= LINUX=libglu
-NVIDIA_GL_USE_OFF= LINUX=dri
-
SRC_DISTFILES= mesa-10.6.5-3.20150824.el7${SRC_SUFX}:SOURCE
.include <bsd.port.mk>
diff --git a/net-im/skype-devel/Makefile b/net-im/skype-devel/Makefile
index fa75d1150f0b..148753855c67 100644
--- a/net-im/skype-devel/Makefile
+++ b/net-im/skype-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= skype
PORTVERSION= 2.2.0.35
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-im
MASTER_SITES= http://download.skype.com/linux/
PKGNAMESUFFIX= -devel
@@ -14,18 +14,17 @@ COMMENT= P2P VoIP software, development version
CONFLICTS= skype-[0-9]*
-OPTIONS_DEFINE= NVIDIA_GL VIDEO
-OPTIONS_DEFAULT= VIDEO
+OPTIONS_DEFINE= VIDEO
+OPTIONS_DEFAULT=VIDEO
VIDEO_DESC= [broken] Video support
-
CONFLICTS= skype-1* skype-2.0* skype-2.1*
NO_BUILD= yes
USES= cpe linux tar:bzip2
-USE_LINUX= alsalib alsa-plugins-oss expat fontconfig libasyncns \
- libsigcpp20
+USE_LINUX= alsalib alsa-plugins-oss dri expat fontconfig libasyncns \
+ libsigcpp20 xorglibs
RESTRICTED= Redistribution prohibited.
WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}
@@ -37,13 +36,6 @@ SUB_LIST+= SKYPEDIR=${SKYPEDIR}
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNVIDIA_GL}
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX+= xorglibs
-.else
-USE_LINUX+= dri
-.endif
-
.if ${PORT_OPTIONS:MVIDEO}
RUN_DEPENDS+= webcamd:multimedia/webcamd
USE_LINUX+= libv4l
diff --git a/net-im/skype/Makefile b/net-im/skype/Makefile
index 4b6ac33cd614..26f03995367b 100644
--- a/net-im/skype/Makefile
+++ b/net-im/skype/Makefile
@@ -3,7 +3,7 @@
PORTNAME= skype
PORTVERSION= 2.1.0.81
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net-im
MASTER_SITES= http://download.skype.com/linux/
@@ -14,14 +14,14 @@ COMMENT= P2P VoIP software
CONFLICTS= skype-devel-[0-9]*
-OPTIONS_DEFINE= NVIDIA_GL VIDEO
-OPTIONS_DEFAULT= VIDEO
+OPTIONS_DEFINE= VIDEO
+OPTIONS_DEFAULT=VIDEO
NO_BUILD= yes
USES= cpe linux tar:bzip2
-USE_LINUX= alsalib alsa-plugins-oss expat fontconfig libasyncns \
- libsigcpp20
+USE_LINUX= alsalib alsa-plugins-oss dri expat fontconfig libasyncns \
+ libsigcpp20 xorglibs
RESTRICTED= Redistribution prohibited.
WRKSRC= ${WRKDIR}/${PORTNAME}_static-${DISTVERSION}
@@ -33,13 +33,6 @@ SUB_LIST+= SKYPEDIR=${SKYPEDIR}
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNVIDIA_GL}
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-USE_LINUX+= xorglibs
-.else
-USE_LINUX+= dri
-.endif
-
.if ${PORT_OPTIONS:MVIDEO}
RUN_DEPENDS+= webcamd:multimedia/webcamd
USE_LINUX+= libv4l
diff --git a/net-im/skype4/Makefile b/net-im/skype4/Makefile
index 560d95907c42..0eff39574b11 100644
--- a/net-im/skype4/Makefile
+++ b/net-im/skype4/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${LINUXBASE}/lib/skype_oss_wrapper/libpulse.so.0:audio/linux-skype_
CONFLICTS= skype-devel-[0-9]*
OPTIONS_DEFINE= VIDEO
-OPTIONS_DEFAULT= VIDEO
+OPTIONS_DEFAULT=VIDEO
NO_BUILD= yes
@@ -32,10 +32,6 @@ PLIST_SUB+= SKYPEDIR=${SKYPEDIR}
SUB_FILES= skype.sh
SUB_LIST+= SKYPEDIR=${SKYPEDIR}
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE= LINUX=xorglibs
-NVIDIA_GL_USE_OFF= LINUX=dri
-
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100075 || ${OSVERSION} >= 1000000 && ${OSVERSION} < 1002507)
diff --git a/x11-toolkits/linux-c6-qt47-x11/Makefile b/x11-toolkits/linux-c6-qt47-x11/Makefile
index b79933036dd1..49808eba9415 100644
--- a/x11-toolkits/linux-c6-qt47-x11/Makefile
+++ b/x11-toolkits/linux-c6-qt47-x11/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qt47-x11
PORTVERSION= 4.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits linux
MASTER_SITES= https://www.mirrorservice.org/sites/dl.atrpms.net/el6-x86_64/atrpms/testing/\
https://www.mirrorservice.org/sites/dl.atrpms.net/el6-i386/atrpms/testing/ \
@@ -18,15 +18,9 @@ SRC_DISTFILES= # unretrievable.
RPMVERSION= 1_18.el6
USES= linux:c6
USE_LDCONFIG= yes
-USE_LINUX= fontconfig png xorglibs png alsalib jpeg tiff qt47 openssl
+USE_LINUX= alsalib dri fontconfig jpeg openssl png qt47 tiff xorglibs
USE_LINUX_RPM= yes
-OPTIONS_DEFINE= NVIDIA_GL
-
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE= LINUX=libglu
-NVIDIA_GL_USE_OFF= LINUX=dri
-
DESCR= ${.CURDIR}/../../devel/qt4/pkg-descr
post-patch:
diff --git a/x11-toolkits/linux-c7-qt-x11/Makefile b/x11-toolkits/linux-c7-qt-x11/Makefile
index 0bfe188540f0..fb47b472b536 100644
--- a/x11-toolkits/linux-c7-qt-x11/Makefile
+++ b/x11-toolkits/linux-c7-qt-x11/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qt-x11
PORTVERSION= 4.8.5
+PORTREVISION= 1
CATEGORIES= x11-toolkits linux
SRC_DISTFILES= qt-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}:SOURCE
@@ -14,15 +15,9 @@ CONFLICTS= linux-c6-qt47-x11-[0-9]*
RPMVERSION= 11.el7
USES= linux:c7
USE_LDCONFIG= yes
-USE_LINUX= fontconfig png xorglibs alsalib jpeg tiff qt openssl
+USE_LINUX= alsalib dri fontconfig jpeg openssl png qt tiff xorglibs
USE_LINUX_RPM= yes
-OPTIONS_DEFINE= NVIDIA_GL
-
-NVIDIA_GL_RUN_DEPENDS= ${LINUXBASE}/usr/lib/libGL.so.1:x11/nvidia-driver
-NVIDIA_GL_USE= LINUX=libglu
-NVIDIA_GL_USE_OFF= LINUX=dri
-
DESCR= ${.CURDIR}/../../devel/qt4/pkg-descr
.include <bsd.port.mk>