aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/exim/Makefile36
-rw-r--r--mail/exim/Makefile.options8
-rw-r--r--mail/exim/distinfo6
-rw-r--r--mail/exim/files/patch-OS::Makefile-FreeBSD11
-rw-r--r--mail/exim/files/patch-src-daemon.c19
-rw-r--r--mail/exim/files/patch-src::EDITME31
-rw-r--r--mail/exim/files/patch-src_dbstuff.h14
-rw-r--r--mail/exim/options4
-rw-r--r--mail/exim/pkg-plist1
9 files changed, 48 insertions, 82 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 4162a9196b5b..4765a3b1e54a 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,6 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
-PORTREVISION= 4
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_EXIM:S/$/:exim/}
MASTER_SITE_SUBDIR= exim4/:exim
@@ -34,7 +33,7 @@ MASTER_SITE_SUBDIR+= sa-exim/:sa_exim
DISTFILES+= sa-exim-${SA_EXIM_VERSION}.tar.gz:sa_exim
.endif
-EXIM_VERSION= 4.69
+EXIM_VERSION= 4.70
SA_EXIM_VERSION=4.2
.if !defined(EXIMON_ONLY)
@@ -69,7 +68,7 @@ PORTDOC_FILES= ChangeLog Exim3.upgrade Exim4.upgrade NewStuff \
experimental-spec.txt filter.txt pcrepattern.txt \
pcretest.txt spec.txt
-PORT_EXAMPLES= convert4r3 convert4r4 pcretest transport-filter.pl
+PORT_EXAMPLES= convert4r3 convert4r4 transport-filter.pl
DAILY_SCRIPTS= 150.exim-tidydb 460.exim-mail-rejects
@@ -116,6 +115,14 @@ PLIST_SUB= EXIM_VERSION="${EXIM_VERSION}-${PORTREVISION}" \
# The default setting is defined by this setting:
WITH_DEFAULT_CHARSET?= ISO-8859-1
+# You should not need to fiddle with anything below this point.
+
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+
+.if defined(WITH_DCC)
+SEDLIST+= -e 's,^\# (EXPERIMENTAL_DCC=),\1,'
+.endif
+
.if defined(WITH_XCLIENT)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-xclient
.endif
@@ -125,8 +132,6 @@ BUILD_DEPENDS+= libspamtest>=0:${PORTSDIR}/mail/libspamtest
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-kas
.endif
-# You should not need to fiddle with anything below this point.
-
.if defined(WITH_WISHLIST)
EXTRA_PATCHES+= `${FIND} ${PATCHDIR} -name 'wishlist-*.patch'`
.endif
@@ -267,7 +272,7 @@ SEDLIST+= -e 's,^\# (AUTH_SPA=),\1,'
.endif
.if defined(WITH_AUTH_SASL)
-LIB_DEPENDS= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
SEDLIST+= -e 's,^\# (AUTH_CYRUS_SASL=),\1,' \
-e 's,^\# (AUTH_LIBS=),\1,'
.endif
@@ -370,23 +375,6 @@ SEDLIST+= -e 's,XX_SPF_FLAGS_XX,,' \
-e 's,XX_SPF_LIBS_XX,,'
.endif
-.if defined(WITH_DOMAINKEYS)
-LIB_DEPENDS+= domainkeys.3:${PORTSDIR}/mail/libdomainkeys
-SEDLIST+= -e 's,XX_DOMAINKEYS_LIBS_XX,-ldomainkeys,' \
- -e 's,^\# (EXPERIMENTAL_DOMAINKEYS=),\1,'
-.else
-SEDLIST+= -e 's,XX_DOMAINKEYS_LIBS_XX,,'
-.endif
-
-.if defined(WITH_DKIM)
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-LIB_DEPENDS+= dkim.1:${PORTSDIR}/mail/libdkim
-SEDLIST+= -e 's,XX_DKIM_LIBS_XX,-ldkim -lstdc++ -lssl,' \
- -e 's,^\# (EXPERIMENTAL_DKIM=),\1,'
-.else
-SEDLIST+= -e 's,XX_DKIM_LIBS_XX,,'
-.endif
-
.if defined(WITH_SRS)
LIB_DEPENDS+= srs2.0:${PORTSDIR}/mail/libsrs2
SEDLIST+= -e 's,XX_SRS_FLAGS_XX,-DSRS,' \
@@ -478,6 +466,8 @@ do-configure:
@${REINPLACE_CMD} -e 's,/usr/bin/spamc,${LOCALBASE}/bin/spamc,' \
${WRKDIR}/sa-exim-${SA_EXIM_VERSION}/sa-exim.conf
.endif
+ @${REINPLACE_CMD} -E -e 's/XX_STRIPCMD_XX/${STRIP_CMD:S,/,\/,g}/' \
+ ${WRKSRC}/OS/Makefile-FreeBSD
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} configure)
post-build:
diff --git a/mail/exim/Makefile.options b/mail/exim/Makefile.options
index 0e51d82139ed..0dbc9d2e863b 100644
--- a/mail/exim/Makefile.options
+++ b/mail/exim/Makefile.options
@@ -39,8 +39,8 @@ ALT_CONFIG_PREFIX = "Allow alternate configuration files"
AUTH_RADIUS = "Enable radius (RFC 2865) authentication"
AUTH_SASL = "Enable use of Cyrus SASL auth library"
CONTENT_SCAN = "Enable exiscan email content scanner"
-DKIM = "Enable DKIM (DomainKeys Identified Mail)"
-DOMAINKEYS = "Enable Yahoo DomainKeys support"
+DCC = "Enable DCC at ACL support via dccifd"
+DEBUG = "Build with debugging symbols"
EXIMON = "Build eximon monitor (require XFree86!)"
KAS = "Build with Kaspersky AntiSpam local scan"
MYSQL = "Link against libmysqlclient library"
@@ -86,8 +86,8 @@ DISABLED_OPTIONS+= \
AUTH_RADIUS \
AUTH_SASL \
CONTENT_SCAN \
- DKIM \
- DOMAINKEYS \
+ DCC \
+ DEBUG \
EXIMON \
KAS \
MYSQL \
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index 34112eead576..ff90e2af6c8f 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,6 +1,6 @@
-MD5 (exim/exim-4.69.tar.bz2) = 6f29f073328c858d8554b08cc0c3c2be
-SHA256 (exim/exim-4.69.tar.bz2) = 18e856cfdb682ba8e8ccb943ab538734d34d0ecefd63465ecc5430bc15915069
-SIZE (exim/exim-4.69.tar.bz2) = 1658939
+MD5 (exim/exim-4.70.tar.bz2) = 30e77669ee25e3606da74b0ff88daf83
+SHA256 (exim/exim-4.70.tar.bz2) = 528782809f877619265b5bf971c3fd20626ef633eb8fce6d4deb3b9c0b56d667
+SIZE (exim/exim-4.70.tar.bz2) = 1560329
MD5 (exim/sa-exim-4.2.tar.gz) = ad76f73c6b3d01caa88078e3e622745a
SHA256 (exim/sa-exim-4.2.tar.gz) = 72e0a735547f18b05785e6c58a71d24623858f0f5234a5dc0e24cb453999e99a
SIZE (exim/sa-exim-4.2.tar.gz) = 66575
diff --git a/mail/exim/files/patch-OS::Makefile-FreeBSD b/mail/exim/files/patch-OS::Makefile-FreeBSD
new file mode 100644
index 000000000000..239f5bca9637
--- /dev/null
+++ b/mail/exim/files/patch-OS::Makefile-FreeBSD
@@ -0,0 +1,11 @@
+--- OS/Makefile-FreeBSD.orig 2009-11-14 21:13:45.000000000 +0300
++++ OS/Makefile-FreeBSD 2009-11-14 21:15:39.000000000 +0300
+@@ -7,7 +7,7 @@
+ PORTOBJFORMAT!= test -x /usr/bin/objformat && /usr/bin/objformat || echo aout
+
+ CHOWN_COMMAND=/usr/sbin/chown
+-STRIP_COMMAND=/usr/bin/strip
++STRIP_COMMAND=XX_STRIPCMD_XX
+ CHMOD_COMMAND=/bin/chmod
+
+ HAVE_SA_LEN=YES
diff --git a/mail/exim/files/patch-src-daemon.c b/mail/exim/files/patch-src-daemon.c
deleted file mode 100644
index d7148a33b040..000000000000
--- a/mail/exim/files/patch-src-daemon.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/daemon.c.orig Sat Aug 30 03:49:46 2008
-+++ src/daemon.c Mon Sep 1 00:46:09 2008
-@@ -1613,7 +1613,7 @@
- struct sockaddr_in accepted;
- #endif
-
-- EXIM_SOCKLEN_T len = sizeof(accepted);
-+ EXIM_SOCKLEN_T len;
- pid_t pid;
-
- /* This code is placed first in the loop, so that it gets obeyed at the
-@@ -1808,6 +1808,7 @@
- {
- if (FD_ISSET(listen_sockets[sk], &select_listen))
- {
-+ len = sizeof(accepted);
- accept_socket = accept(listen_sockets[sk],
- (struct sockaddr *)&accepted, &len);
- FD_CLR(listen_sockets[sk], &select_listen);
diff --git a/mail/exim/files/patch-src::EDITME b/mail/exim/files/patch-src::EDITME
index 12344a9e5d61..c11da9eb79a3 100644
--- a/mail/exim/files/patch-src::EDITME
+++ b/mail/exim/files/patch-src::EDITME
@@ -1,8 +1,8 @@
$FreeBSD$
---- src/EDITME.orig
-+++ src/EDITME
+--- src/EDITME.orig 2008-07-26 00:23:25.000000000 +0400
++++ src/EDITME 2009-11-14 19:28:32.000000000 +0300
@@ -100,7 +100,7 @@
# /usr/local/sbin. The installation script will try to create this directory,
# and any superior directories, if they do not exist.
@@ -47,7 +47,7 @@ $FreeBSD$
# If you don't set any of these, Exim assumes the original University of
# Michigan (OpenLDAP 1) library.
-@@ -308,8 +309,10 @@
+@@ -321,8 +322,10 @@
# specified in INCLUDE. The settings below are just examples; -lpq is for
# PostgreSQL, -lgds is for Interbase, -lsqlite3 is for SQLite.
@@ -60,7 +60,7 @@ $FreeBSD$
#------------------------------------------------------------------------------
-@@ -320,7 +323,7 @@
+@@ -333,7 +336,7 @@
# files are defaulted in the OS/Makefile-Default file, but can be overridden in
# local OS-specific make files.
@@ -69,16 +69,15 @@ $FreeBSD$
#------------------------------------------------------------------------------
-@@ -372,6 +375,8 @@
+@@ -385,6 +388,7 @@
-+# EXPERIMENTAL_DOMAINKEYS=yes
-+# EXPERIMENTAL_DKIM=yes
++# EXPERIMENTAL_DCC=yes
###############################################################################
# THESE ARE THINGS YOU MIGHT WANT TO SPECIFY #
###############################################################################
-@@ -440,6 +445,7 @@
+@@ -453,6 +457,7 @@
# ALT_CONFIG_PREFIX=/some/directory/
# ALT_CONFIG_PREFIX=/some/directory/exim.conf-
@@ -86,7 +85,7 @@ $FreeBSD$
#------------------------------------------------------------------------------
-@@ -494,7 +500,7 @@
+@@ -507,7 +512,7 @@
# one that is set in the headers_charset option. The default setting is
# defined by this setting:
@@ -95,7 +94,7 @@ $FreeBSD$
# If you are going to make use of $header_xxx expansions in your configuration
# file, or if your users are going to use them in filter files, and the normal
-@@ -579,7 +585,7 @@
+@@ -592,7 +597,7 @@
# SUPPORT_TLS=yes
# Uncomment this setting if you are using OpenSSL
@@ -104,7 +103,7 @@ $FreeBSD$
# Uncomment these settings if you are using GnuTLS
# USE_GNUTLS=yes
-@@ -630,7 +636,7 @@
+@@ -643,7 +648,7 @@
# Once you have done this, "make install" will build the info files and
# install them in the directory you have defined.
@@ -113,7 +112,7 @@ $FreeBSD$
#------------------------------------------------------------------------------
-@@ -643,7 +649,7 @@
+@@ -656,7 +661,7 @@
# %s. This will be replaced by one of the strings "main", "panic", or "reject"
# to form the final file names. Some installations may want something like this:
@@ -122,7 +121,7 @@ $FreeBSD$
# which results in files with names /var/log/exim_mainlog, etc. The directory
# in which the log files are placed must exist; Exim does not try to create
-@@ -719,7 +725,7 @@
+@@ -732,7 +737,7 @@
# that the local_scan API is made available by the linker. You may also need
# to add -ldl to EXTRALIBS so that dlopen() is available to Exim.
@@ -131,7 +130,7 @@ $FreeBSD$
#------------------------------------------------------------------------------
-@@ -811,13 +817,21 @@
+@@ -824,13 +829,21 @@
# library for TCP wrappers, so you probably need something like this:
#
# USE_TCP_WRAPPERS=yes
@@ -139,7 +138,7 @@ $FreeBSD$
-# EXTRALIBS_EXIM=-L/usr/local/lib -lwrap
-#
+CFLAGS=XX_CFLAGS_XX XX_SPF_FLAGS_XX XX_SRS_FLAGS_XX XX_SQLITE_FLAGS_XX
-+EXTRALIBS=XX_TCP_WRAPPERS_LIBS_XX XX_PAM_LIBS_XX XX_ICONV_LIBS_XX XX_SPF_LIBS_XX XX_SRS_LIBS_XX XX_DOMAINKEYS_LIBS_XX XX_DKIM_LIBS_XX XX_RADIUS_LIBS_XX XX_SQLITE_LIBS_XX
++EXTRALIBS=XX_TCP_WRAPPERS_LIBS_XX XX_PAM_LIBS_XX XX_ICONV_LIBS_XX XX_SPF_LIBS_XX XX_SRS_LIBS_XX XX_RADIUS_LIBS_XX XX_SQLITE_LIBS_XX
+
# but of course there may need to be other things in CFLAGS and EXTRALIBS_EXIM
# as well.
@@ -156,7 +155,7 @@ $FreeBSD$
#------------------------------------------------------------------------------
# The default action of the exim_install script (which is run by "make
# install") is to install the Exim binary with a unique name such as
-@@ -1082,7 +1096,7 @@
+@@ -1097,7 +1110,7 @@
# (process id) to a file so that it can easily be identified. The path of the
# file can be specified here. Some installations may want something like this:
diff --git a/mail/exim/files/patch-src_dbstuff.h b/mail/exim/files/patch-src_dbstuff.h
deleted file mode 100644
index f17c509120e4..000000000000
--- a/mail/exim/files/patch-src_dbstuff.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/dbstuff.h.orig
-+++ src/dbstuff.h
-@@ -331,7 +331,7 @@
-
- /* EXIM_DBSCAN - returns TRUE if data is returned, FALSE at end */
- #define EXIM_DBSCAN(db, key, data, first, cursor) \
-- ((db)->seq(db, &key, &data, (first? R_FIRST : 0)) == 0)
-+ ((db)->seq(db, &key, &data, (first? R_FIRST : R_NEXT)) == 0)
-
- /* EXIM_DBDELETE_CURSOR - terminate scanning operation (null). Make it
- refer to cursor, to keep picky compilers happy. */
diff --git a/mail/exim/options b/mail/exim/options
index 9688c3852cfd..ff1035d40218 100644
--- a/mail/exim/options
+++ b/mail/exim/options
@@ -9,9 +9,9 @@ OPTIONS+= \
CDB "Enable CDB-style lookups" on \
CONTENT_SCAN "Enable exiscan email content scanner" off \
DAEMON "Don't install scripts to run as a daemon" on \
- DKIM "Enable DKIM (DomainKeys Identified Mail)" off \
+ DCC "Enable DCC at ACL support via dccifd" off \
+ DEBUG "Build with debugging symbols" off \
DNSDB "Enable DNS-style lookups" on \
- DOMAINKEYS "Enable Yahoo DomainKeys support" off \
DSEARCH "Enable directory-list lookups" on \
EMBEDDED_PERL "Enable embedded Perl interpreter" on \
EXIMON "Build eximon monitor (require XFree86!)" off \
diff --git a/mail/exim/pkg-plist b/mail/exim/pkg-plist
index f4cea7f9ea6e..31de806fdf32 100644
--- a/mail/exim/pkg-plist
+++ b/mail/exim/pkg-plist
@@ -38,7 +38,6 @@ sbin/exiwhat
%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
%%PORTDOCS%%%%EXAMPLESDIR%%/convert4r3
%%PORTDOCS%%%%EXAMPLESDIR%%/convert4r4
-%%PORTDOCS%%%%EXAMPLESDIR%%/pcretest
%%PORTDOCS%%%%EXAMPLESDIR%%/transport-filter.pl
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
%%DAEMON%%etc/periodic/daily/150.exim-tidydb