aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-webunit/Makefile28
-rw-r--r--www/py-webunit/distinfo3
-rw-r--r--www/py-webunit/files/patch-setup.py11
-rw-r--r--www/py-webunit/pkg-descr16
-rw-r--r--www/py-webunit/pkg-plist31
6 files changed, 90 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 4ffc7162fdb6..6abef6e9a553 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -976,6 +976,7 @@
SUBDIR += py-twistedWeb
SUBDIR += py-twistedWeb2
SUBDIR += py-urljr
+ SUBDIR += py-webunit
SUBDIR += py-webware
SUBDIR += py-webware-component
SUBDIR += py-wsgiref
diff --git a/www/py-webunit/Makefile b/www/py-webunit/Makefile
new file mode 100644
index 000000000000..ae333ee7c1f8
--- /dev/null
+++ b/www/py-webunit/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-webunit
+# Date created: Mar. 03, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webunit
+PORTVERSION= 1.3.8
+CATEGORIES= www python
+MASTER_SITES= http://mechanicalcat.net/tech/webunit/ \
+ http://funkload.nuxeo.org/3dparty/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Unit test your websites with code that acts like a web browser
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/run_tests ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/demo ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/www/py-webunit/distinfo b/www/py-webunit/distinfo
new file mode 100644
index 000000000000..dbd61a56b4f4
--- /dev/null
+++ b/www/py-webunit/distinfo
@@ -0,0 +1,3 @@
+MD5 (webunit-1.3.8.tar.gz) = 97b9e6b5149dadce48b86adbf2db3b0a
+SHA256 (webunit-1.3.8.tar.gz) = 8f927380a507d9ccbbe0b05136e47eba62b875107bb2d829a9f90e0bd11531e8
+SIZE (webunit-1.3.8.tar.gz) = 22950
diff --git a/www/py-webunit/files/patch-setup.py b/www/py-webunit/files/patch-setup.py
new file mode 100644
index 000000000000..62aec4df6881
--- /dev/null
+++ b/www/py-webunit/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Sat Mar 3 03:16:17 2007
++++ setup.py Sat Mar 3 03:16:26 2007
+@@ -34,7 +34,7 @@
+ author_email = "richard@mechanicalcat.net",
+ url = 'http://mechanicalcat.net/tech/webunit/',
+ download_url = 'http://mechanicalcat.net/tech/webunit/webunit-%s.tar.gz'%__version__,
+- packages = ['webunit', 'demo'],
++ packages = ['webunit'],
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
diff --git a/www/py-webunit/pkg-descr b/www/py-webunit/pkg-descr
new file mode 100644
index 000000000000..f3a48c6b2e1d
--- /dev/null
+++ b/www/py-webunit/pkg-descr
@@ -0,0 +1,16 @@
+Webunit is a framework for unit testing websites:
+
+Features in a nutshell:
+
+1. Browser-like page fetching including fetching the images and stylesheets
+ needed for a page and following redirects
+2. Cookies stored and trackable (all automatically handled)
+3. HTTP, HTTPS, GET, POST, basic auth all handled, control over expected status
+ codes, ...
+4. DOM parsing of pages to retrieve and analyse structure, including simple
+ form re-posting
+5. Two-line page-fetch followed by form-submit possible, with error checking
+6. Ability to register error page content across multiple tests
+7. Uses python's standard unittest module as the underlying framework
+
+WWW: http://www.python.org/pypi/webunit
diff --git a/www/py-webunit/pkg-plist b/www/py-webunit/pkg-plist
new file mode 100644
index 000000000000..3d08f7d7f26f
--- /dev/null
+++ b/www/py-webunit/pkg-plist
@@ -0,0 +1,31 @@
+%%PYTHON_SITELIBDIR%%/webunit/HTMLParser.py
+%%PYTHON_SITELIBDIR%%/webunit/HTMLParser.pyc
+%%PYTHON_SITELIBDIR%%/webunit/HTMLParser.pyo
+%%PYTHON_SITELIBDIR%%/webunit/IMGSucker.py
+%%PYTHON_SITELIBDIR%%/webunit/IMGSucker.pyc
+%%PYTHON_SITELIBDIR%%/webunit/IMGSucker.pyo
+%%PYTHON_SITELIBDIR%%/webunit/SimpleDOM.py
+%%PYTHON_SITELIBDIR%%/webunit/SimpleDOM.pyc
+%%PYTHON_SITELIBDIR%%/webunit/SimpleDOM.pyo
+%%PYTHON_SITELIBDIR%%/webunit/__init__.py
+%%PYTHON_SITELIBDIR%%/webunit/__init__.pyc
+%%PYTHON_SITELIBDIR%%/webunit/__init__.pyo
+%%PYTHON_SITELIBDIR%%/webunit/config.py
+%%PYTHON_SITELIBDIR%%/webunit/config.pyc
+%%PYTHON_SITELIBDIR%%/webunit/config.pyo
+%%PYTHON_SITELIBDIR%%/webunit/cookie.py
+%%PYTHON_SITELIBDIR%%/webunit/cookie.pyc
+%%PYTHON_SITELIBDIR%%/webunit/cookie.pyo
+%%PYTHON_SITELIBDIR%%/webunit/utility.py
+%%PYTHON_SITELIBDIR%%/webunit/utility.pyc
+%%PYTHON_SITELIBDIR%%/webunit/utility.pyo
+%%PYTHON_SITELIBDIR%%/webunit/webunittest.py
+%%PYTHON_SITELIBDIR%%/webunit/webunittest.pyc
+%%PYTHON_SITELIBDIR%%/webunit/webunittest.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/webunit
+%%EXAMPLESDIR%%/run_tests
+%%EXAMPLESDIR%%/demo/__init__.py
+%%EXAMPLESDIR%%/demo/google.py
+%%EXAMPLESDIR%%/demo/python_org.py
+@dirrm %%EXAMPLESDIR%%/demo
+@dirrm %%EXAMPLESDIR%%