aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/wine-devel/Makefile8
-rw-r--r--emulators/wine/Makefile8
2 files changed, 12 insertions, 4 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 39e2cc2dab04..0593d425e061 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= Microsoft Windows compatibility layer for Unix-like systems
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
@@ -52,7 +51,8 @@ OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" Off \
GNUTLS "Use GnuTLS" Off \
HAL "Use HAL (Hardware Abstraction Layer)" Off \
LDAP "Use LDAP" Off \
- LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
+ LIBXSLT "Use libxslt (only used by msxml3.dll)" Off \
+ WINEMAKER "Fully support winemaker (requires Perl)" Off
.include <bsd.port.pre.mk>
@@ -91,6 +91,10 @@ LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
CONFIGURE_ARGS+= --without-xslt
.endif
+.ifdef WITH_WINEMAKER
+RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
+.endif
+
.if ${OSVERSION} < 603000
IGNORE= fails to properly work on versions of FreeBSD before 6.3
.endif
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 39e2cc2dab04..0593d425e061 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= Microsoft Windows compatibility layer for Unix-like systems
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
@@ -52,7 +51,8 @@ OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" Off \
GNUTLS "Use GnuTLS" Off \
HAL "Use HAL (Hardware Abstraction Layer)" Off \
LDAP "Use LDAP" Off \
- LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
+ LIBXSLT "Use libxslt (only used by msxml3.dll)" Off \
+ WINEMAKER "Fully support winemaker (requires Perl)" Off
.include <bsd.port.pre.mk>
@@ -91,6 +91,10 @@ LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
CONFIGURE_ARGS+= --without-xslt
.endif
+.ifdef WITH_WINEMAKER
+RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
+.endif
+
.if ${OSVERSION} < 603000
IGNORE= fails to properly work on versions of FreeBSD before 6.3
.endif