aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/slurm-wlm/Makefile2
-rw-r--r--sysutils/slurm-wlm/files/patch-src_plugins_jobacct__gather_common_common__jag.c26
2 files changed, 27 insertions, 1 deletions
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index 2728ce763a75..5e70ae1d2b92 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -2,7 +2,7 @@
PORTNAME= slurm
DISTVERSION= 19.05.1-2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils python
MASTER_SITES= https://download.schedmd.com/slurm/
PKGNAMESUFFIX= -wlm
diff --git a/sysutils/slurm-wlm/files/patch-src_plugins_jobacct__gather_common_common__jag.c b/sysutils/slurm-wlm/files/patch-src_plugins_jobacct__gather_common_common__jag.c
new file mode 100644
index 000000000000..0cc66b4216ad
--- /dev/null
+++ b/sysutils/slurm-wlm/files/patch-src_plugins_jobacct__gather_common_common__jag.c
@@ -0,0 +1,26 @@
+--- src/plugins/jobacct_gather/common/common_jag.c.orig 2019-09-13 13:35:31 UTC
++++ src/plugins/jobacct_gather/common/common_jag.c
+@@ -250,6 +250,12 @@ static int _get_sys_interface_freq_line(uint32_t cpu,
+ return 0;
+ }
+
++
++/*
++ * Check for lightweight processes (POSIX threads)
++ * Should be rewritten for FreeBSD so it doesn't depend on /proc
++ */
++
+ static int _is_a_lwp(uint32_t pid)
+ {
+ char *filename = NULL;
+@@ -258,6 +264,10 @@ static int _is_a_lwp(uint32_t pid)
+ ssize_t n;
+ char *tgids = NULL;
+ pid_t tgid = -1;
++
++ // Disable check for now, this will only skew process accounting
++ // slightly by including threads
++ return 0;
+
+ xstrfmtcat(filename, "/proc/%u/status", pid);
+