aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Loki97/Makefile24
-rw-r--r--security/p5-Crypt-Loki97/distinfo3
-rw-r--r--security/p5-Crypt-Loki97/pkg-descr6
-rw-r--r--security/p5-Crypt-Loki97/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 623aab7876a6..2946e072964a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -314,6 +314,7 @@
SUBDIR += p5-Crypt-Khazad
SUBDIR += p5-Crypt-License
SUBDIR += p5-Crypt-Lite
+ SUBDIR += p5-Crypt-Loki97
SUBDIR += p5-Crypt-MySQL
SUBDIR += p5-Crypt-NULL
SUBDIR += p5-Crypt-OFB
diff --git a/security/p5-Crypt-Loki97/Makefile b/security/p5-Crypt-Loki97/Makefile
new file mode 100644
index 000000000000..bdff16b7bcd4
--- /dev/null
+++ b/security/p5-Crypt-Loki97/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-Loki97
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-Loki97
+PORTVERSION= 1.0.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for Loki97 block cipher
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Loki97.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Loki97/distinfo b/security/p5-Crypt-Loki97/distinfo
new file mode 100644
index 000000000000..9eef4f4eb24b
--- /dev/null
+++ b/security/p5-Crypt-Loki97/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Loki97-1.0.1.tar.gz) = d8bbfa58571c05cb4e60f21b495df170
+SHA256 (Crypt-Loki97-1.0.1.tar.gz) = 88b410741e102c28effc8cab35f772a81eef77319706c62c0ca1980fbf7ac17a
+SIZE (Crypt-Loki97-1.0.1.tar.gz) = 40756
diff --git a/security/p5-Crypt-Loki97/pkg-descr b/security/p5-Crypt-Loki97/pkg-descr
new file mode 100644
index 000000000000..60ee61d79fac
--- /dev/null
+++ b/security/p5-Crypt-Loki97/pkg-descr
@@ -0,0 +1,6 @@
+Loki97 is 128-bit block cipher that accepts a variable-length key. It was
+designed by Lawrie Brown, Josef Pieprzyk, and Jennifer Seberry. The default
+key length in this implementation is 128 bits. Loki97 was one of the 15
+candidates for the AES.
+
+WWW: http://search.cpan.org/dist/Crypt-Loki97
diff --git a/security/p5-Crypt-Loki97/pkg-plist b/security/p5-Crypt-Loki97/pkg-plist
new file mode 100644
index 000000000000..088f57911af8
--- /dev/null
+++ b/security/p5-Crypt-Loki97/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/Loki97.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Loki97/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Loki97/Loki97.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Loki97/Loki97.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Loki97/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Crypt 2>/dev/null || true