aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/qmapshack/Makefile1
-rw-r--r--astro/qmapshack/files/patch-src_qmapshack_dem_IDem.h13
2 files changed, 14 insertions, 0 deletions
diff --git a/astro/qmapshack/Makefile b/astro/qmapshack/Makefile
index 23a18c5c9d39..6fe565cc2f97 100644
--- a/astro/qmapshack/Makefile
+++ b/astro/qmapshack/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qmapshack
PORTVERSION= 1.11.0
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= https://bitbucket.org/maproom/qmapshack/downloads/
diff --git a/astro/qmapshack/files/patch-src_qmapshack_dem_IDem.h b/astro/qmapshack/files/patch-src_qmapshack_dem_IDem.h
new file mode 100644
index 000000000000..679385fd0bc7
--- /dev/null
+++ b/astro/qmapshack/files/patch-src_qmapshack_dem_IDem.h
@@ -0,0 +1,13 @@
+Provide full definition of IDrawContext, needed when #including
+this file in a context (ha!) without that definition already.
+
+--- src/qmapshack/dem/IDem.h.orig 2018-02-23 16:39:15 UTC
++++ src/qmapshack/dem/IDem.h
+@@ -19,6 +19,7 @@
+ #ifndef IDEM_H
+ #define IDEM_H
+
++#include "canvas/IDrawContext.h"
+ #include "canvas/IDrawObject.h"
+ #include <QObject>
+ #include <QPointer>