aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/mppdec/Makefile27
-rw-r--r--audio/mppdec/distinfo1
-rw-r--r--audio/mppdec/files/patch-mppdec.h11
-rw-r--r--audio/mppdec/pkg-descr14
-rw-r--r--audio/mppdec/pkg-plist1
6 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 1e79bb564f89..61148d6e117c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -163,6 +163,7 @@
SUBDIR += mpg123.el
SUBDIR += mpg321
SUBDIR += mpmf20
+ SUBDIR += mppdec
SUBDIR += mpt
SUBDIR += mq3
SUBDIR += muse
diff --git a/audio/mppdec/Makefile b/audio/mppdec/Makefile
new file mode 100644
index 000000000000..2ca45f6802b1
--- /dev/null
+++ b/audio/mppdec/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mppdec
+# Date created: 2002-12-28
+# Whom: Stefan Ehmann <shoesoft@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mppdec
+PORTVERSION= 1.1
+CATEGORIES= audio
+MASTER_SITES= http://www.personal.uni-jena.de/~pfk/MPP/src/ \
+ http://stud4.tuwien.ac.at/~e0125637/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= shoesoft@gmx.net
+COMMENT= Command-line player/decoder for musepack audio
+
+BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound
+
+MAKEFILE= Makefile.bsd
+USE_BZIP2= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/mppdec ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/audio/mppdec/distinfo b/audio/mppdec/distinfo
new file mode 100644
index 000000000000..12fceae085ea
--- /dev/null
+++ b/audio/mppdec/distinfo
@@ -0,0 +1 @@
+MD5 (mppdec-1.1.tar.bz2) = 53172eef6b409725b885ca39f98a56bc
diff --git a/audio/mppdec/files/patch-mppdec.h b/audio/mppdec/files/patch-mppdec.h
new file mode 100644
index 000000000000..d838afd8cb47
--- /dev/null
+++ b/audio/mppdec/files/patch-mppdec.h
@@ -0,0 +1,11 @@
+--- mppdec.h.orig Mon Mar 31 15:42:01 2003
++++ mppdec.h Mon Mar 31 15:42:13 2003
+@@ -129,7 +129,7 @@
+ # elif defined __bsdi__
+ # include <sys/soundcard.h>
+ # elif defined __FreeBSD__
+-# include <machine/soundcard.h>
++# include <sys/soundcard.h>
+ # elif defined __NetBSD__ || defined __OpenBSD__
+ # include <soundcard.h>
+ # else
diff --git a/audio/mppdec/pkg-descr b/audio/mppdec/pkg-descr
new file mode 100644
index 000000000000..2c719a386aae
--- /dev/null
+++ b/audio/mppdec/pkg-descr
@@ -0,0 +1,14 @@
+mppdec -- the MPEGplus compressed audio decoder
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+This is a speed and portability optimized version of Andree Buschmann's
+MPEG-Plus decoder. Speed enhancement is about 1:4...1:5 relative to the
+original source. Some of these optimizations flood back to the original
+decoder, but especially on AMD K6-2/AMD K6-III/AMD Athlon/AMD Duron/Intel
+Pentium III/Intel Pentium 4 there's still some hand written assembler code
+so this decoder ist still much faster.
+
+WWW: http://www.uni-jena.de/~pfk/mpp/
+
+--
+Frank Klemm <pfk@schnecke.offl.uni-jena.de>
diff --git a/audio/mppdec/pkg-plist b/audio/mppdec/pkg-plist
new file mode 100644
index 000000000000..0db411b31de4
--- /dev/null
+++ b/audio/mppdec/pkg-plist
@@ -0,0 +1 @@
+bin/mppdec