aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/spl/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/spl/Makefile b/lang/spl/Makefile
index 9c344705bb00..4fc444690a61 100644
--- a/lang/spl/Makefile
+++ b/lang/spl/Makefile
@@ -15,7 +15,6 @@ USES= bison gmake
ALL_EXAMPLES= Makefile fibonacci.spl fibonacci2.spl guess.spl hello.spl \
primes.spl reverse.spl shakesbeer.spl
-NO_STAGE= yes
post-patch:
.for f in . examples
${REINPLACE_CMD} -e 's,= gcc,?= gcc,' -e 's,^CCFLAGS.*,CFLAGS += -Wall,' \
@@ -25,10 +24,10 @@ post-patch:
-e 's,free(,//free(,g' ${WRKSRC}/makescanner.c
do-install:
- ${TAR} -C ${WRKSRC}/spl -cf - . | ${TAR} -C ${PREFIX} -xf -
+ ${TAR} -C ${WRKSRC}/spl -cf - . | ${TAR} -C ${STAGEDIR}${PREFIX} -xf -
.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${INSTALL_DATA} ${ALL_EXAMPLES} ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_DATA} ${ALL_EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>