aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-savage/Makefile99
-rw-r--r--games/linux-savage/distinfo18
-rw-r--r--games/linux-savage/files/pkg-message.in23
-rw-r--r--games/linux-savage/files/savage.in5
-rw-r--r--games/linux-savage/files/savage_editor.in5
-rw-r--r--games/linux-savage/files/savage_server.in5
-rw-r--r--games/linux-savage/pkg-descr13
-rw-r--r--games/linux-savage/pkg-install25
-rw-r--r--games/linux-savage/pkg-plist248
10 files changed, 442 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index edf3c4481e1d..2285cf5392ec 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -396,6 +396,7 @@
SUBDIR += linux-quake3-demo
SUBDIR += linux-quake4
SUBDIR += linux-quake4-demo
+ SUBDIR += linux-savage
SUBDIR += linux-spheresofchaos-demo
SUBDIR += linux-steam
SUBDIR += linux-ut
diff --git a/games/linux-savage/Makefile b/games/linux-savage/Makefile
new file mode 100644
index 000000000000..ab02133414a5
--- /dev/null
+++ b/games/linux-savage/Makefile
@@ -0,0 +1,99 @@
+# New ports collection makefile for: linux-savage
+# Date created: 2006-09-06
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= savage
+PORTVERSION= 2.00c
+CATEGORIES= games linux
+MASTER_SITES= http://downloads.s2games.com/online_orders/:full \
+ http://patches.s2games.com/:patch
+PKGNAMEPREFIX= linux-
+DISTNAME= ${PORTNAME:S/$/_/}
+DISTFILES= ${DISTNAME:S/$/linux/}.sh.gz:full \
+ ${PORTNAME}20030905a-patch.tar.gz:patch \
+ ${PORTNAME}20030905d-patch.tar.gz:patch \
+ ${PORTNAME}20030908a-patch.tar.gz:patch \
+ ${PORTNAME}20031004b-patch.tar.gz:patch \
+ ${PORTNAME}20031022a-patch.tar.gz:patch
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= The Savage game (linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis \
+ ${LINUXBASE}/usr/lib/libtiff.so.3:${PORTSDIR}/graphics/linux-tiff
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= yes
+NO_BUILD= yes
+RESTRICTED= Savage is freeware, but i am not sure of its license
+NO_PACKAGE= Package will be 350MB, set FORCE_PACKAGE if you really want it
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}${PORTNAME}
+SAVAGEDIR= lib/${PKGNAMEPREFIX}${PORTNAME}
+
+SUB_FILES= pkg-message savage savage_editor savage_server
+PLIST_SUB+= SAVAGEDIR="${SAVAGEDIR}"
+SUB_LIST+= SAVAGEDIR="${PREFIX}/${SAVAGEDIR}"
+
+do-extract:
+# Extract savage base
+ @${MKDIR} ${WRKSRC}
+ @${GZIP_CMD} -dc ${_DISTDIR}/${DISTNAME:S/$/linux/}.sh.gz > \
+ ${WRKDIR}/${DISTNAME:S/$/linux/}.sh
+ @cd ${WRKSRC} && \
+ ${TAIL} +175 ${WRKDIR}/${DISTNAME:S/$/linux/}.sh | \
+ ${GZIP_CMD} -dc | ${TAR} xf -
+# Extract savage 2.00c
+ @${MKDIR} ${WRKDIR}/patch
+.for FILE in 20030905a 20030905d 20030908a 20031004b 20031022a
+ @${TAR} xfz ${_DISTDIR}/savage${FILE}-patch.tar.gz --directory ${WRKDIR}/patch
+.endfor
+
+post-extract:
+ @${CP} -Rf ${WRKSRC}/linux/* ${WRKSRC}/Savage/
+ @${CP} -Rf ${WRKSRC}/bin/x86/* ${WRKSRC}/Savage/
+ @${MV} ${WRKDIR}/patch/savage.bin.new ${WRKDIR}/patch/savage.bin
+ @${CP} -Rf ${WRKDIR}/patch/* ${WRKSRC}/Savage/
+ @${FIND} -E ${WRKSRC}/Savage -type f -iregex ".*\.(dll|exe|bat)" -exec ${RM} "{}" \;
+ @${FIND} ${WRKSRC}/Savage -type d -name CVS | ${XARGS} ${RM} -rf
+
+do-install:
+ @${MKDIR} ${PREFIX}/${SAVAGEDIR}
+.for DIRE in editor game updater
+ @${MKDIR} ${PREFIX}/${SAVAGEDIR}/${DIRE}
+ @cd ${WRKSRC}/Savage/${DIRE} && \
+ ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${SAVAGEDIR}/${DIRE}/{}" \; && \
+ ${FIND} * -type f -name "*.so" -exec ${INSTALL_PROGRAM} "{}" \
+ "${PREFIX}/${SAVAGEDIR}/${DIRE}/{}" \; && \
+ ${FIND} -E * -type f -iregex ".*\.(bik|cfg|tga|txt|ttf|s2g|s2z|ogg)" \
+ -exec ${INSTALL_DATA} "{}" "${PREFIX}/${SAVAGEDIR}/${DIRE}/{}" \;
+.endfor
+ @${MKDIR} ${PREFIX}/${SAVAGEDIR}/libs
+ @cd ${WRKSRC}/Savage/libs && \
+ ${FIND} * -type f -exec ${INSTALL_PROGRAM} "{}" "${PREFIX}/${SAVAGEDIR}/libs/{}" \;
+
+.for FILE in dedicated_server.bin savage savage.bin silverback.bin update
+ ${INSTALL_PROGRAM} ${WRKSRC}/Savage/${FILE} ${PREFIX}/${SAVAGEDIR}
+.endfor
+
+.for FILE in savage savage_editor savage_server
+ ${INSTALL_SCRIPT} ${WRKDIR}/${FILE} ${PREFIX}/bin/${PKGNAMEPREFIX}${FILE}
+.endfor
+
+.for FILE in agp_error.txt icon.xpm logo.png eula.txt
+ ${INSTALL_DATA} ${WRKSRC}/Savage/${FILE} ${PREFIX}/${SAVAGEDIR}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Savage/docs/* ${DOCSDIR}
+.endif
+
+post-install:
+ @PKG_PREFIX=${PREFIX}/${SAVAGEDIR} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/games/linux-savage/distinfo b/games/linux-savage/distinfo
new file mode 100644
index 000000000000..7b447ed4b93d
--- /dev/null
+++ b/games/linux-savage/distinfo
@@ -0,0 +1,18 @@
+MD5 (savage/savage_linux.sh.gz) = 3655ed9ef7407af3ef8d544297a08784
+SHA256 (savage/savage_linux.sh.gz) = e620d39df94c124c5a4889998512d80176e6470bcdd316091f20b34fe059293f
+SIZE (savage/savage_linux.sh.gz) = 330693936
+MD5 (savage/savage20030905a-patch.tar.gz) = cbeeb6ac9e33e876ff1d63f4ef59ddc8
+SHA256 (savage/savage20030905a-patch.tar.gz) = a84beefb0028d1327f913fe45b4d51dd104d4e9350b13964d9912ce07c16c65c
+SIZE (savage/savage20030905a-patch.tar.gz) = 702180
+MD5 (savage/savage20030905d-patch.tar.gz) = 8366a4e55b3a261b0d9d45d00c951467
+SHA256 (savage/savage20030905d-patch.tar.gz) = 03a80bef4fe7cfc2fbdfe349c68d454b2ab71f68c27e07642e059b8997abf116
+SIZE (savage/savage20030905d-patch.tar.gz) = 1392
+MD5 (savage/savage20030908a-patch.tar.gz) = 1b8c64b0e4e78a97ab718d245413fe2e
+SHA256 (savage/savage20030908a-patch.tar.gz) = b874679f0846965bb23f87fff3074ca18f97e0233134eb61b1aaa0766eb8722f
+SIZE (savage/savage20030908a-patch.tar.gz) = 842
+MD5 (savage/savage20031004b-patch.tar.gz) = 61c8dbbdad1347a573bfe8e6355ee681
+SHA256 (savage/savage20031004b-patch.tar.gz) = ad5e85d1d8ccddc24c9651a86805720cd0c45d77c36b6ee95771d1ca657f7ec5
+SIZE (savage/savage20031004b-patch.tar.gz) = 2820408
+MD5 (savage/savage20031022a-patch.tar.gz) = af72c2db8b6084bf600e02c58d4036ee
+SHA256 (savage/savage20031022a-patch.tar.gz) = cdcc9a6215103ac1d121ad0265c3dc78c18d117840507b0cf1f37cf00fc4df03
+SIZE (savage/savage20031022a-patch.tar.gz) = 680297
diff --git a/games/linux-savage/files/pkg-message.in b/games/linux-savage/files/pkg-message.in
new file mode 100644
index 000000000000..e7122dad4458
--- /dev/null
+++ b/games/linux-savage/files/pkg-message.in
@@ -0,0 +1,23 @@
+###############################################################################
+
+The Savage game (Linux version) was installed
+
+1) You can to run the editor map using:
+
+ # linux-savage_editor
+
+ Dedicated server
+
+ # linux-savage_server
+
+ Client
+
+ # linux-savage
+
+2) Nowadays, this port doesn't work with SEP and SAMURAI mods. It has some
+ problems. If you can to do that savage runs with some of these mods, feel
+ free to contact me.
+
+3) Enjoy it ;)
+
+###############################################################################
diff --git a/games/linux-savage/files/savage.in b/games/linux-savage/files/savage.in
new file mode 100644
index 000000000000..283a2da83d29
--- /dev/null
+++ b/games/linux-savage/files/savage.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd %%SAVAGEDIR%% || exit 1
+export LD_LIBRARY_PATH=libs:$LD_LIBRARY_PATH
+exec ./savage.bin "$@"
diff --git a/games/linux-savage/files/savage_editor.in b/games/linux-savage/files/savage_editor.in
new file mode 100644
index 000000000000..600ecd2c5d1f
--- /dev/null
+++ b/games/linux-savage/files/savage_editor.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd %%SAVAGEDIR%% || exit 1
+export LD_LIBRARY_PATH=libs:$LD_LIBRARY_PATH
+exec ./silverback.bin set mod editor
diff --git a/games/linux-savage/files/savage_server.in b/games/linux-savage/files/savage_server.in
new file mode 100644
index 000000000000..e2bd5b604a12
--- /dev/null
+++ b/games/linux-savage/files/savage_server.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd %%SAVAGEDIR%% || exit 1
+export LD_LIBRARY_PATH=libs:$LD_LIBRARY_PATH
+exec ./dedicated_server.bin "$@"
diff --git a/games/linux-savage/pkg-descr b/games/linux-savage/pkg-descr
new file mode 100644
index 000000000000..9153d01e3789
--- /dev/null
+++ b/games/linux-savage/pkg-descr
@@ -0,0 +1,13 @@
+Choose to be a commander and you will play an in-depth RTS managing the
+stronghold, or choose to be a warrior and you will play an intense game of
+first person combat. With the creation of a new game play genre, RTSS (Real
+Time Strategy Shooter), Savage expertly redefines the first-person shooter
+and real-time strategy genres by combining elements of both into one cohesive
+experience.
+
+As the commander in RTS mode, you will tackle resource management, develop a
+robust tech tree, plan your assault and lead real human players into battle.
+As a warrior in action mode, you will master many unique weapons, powerful
+units, and siege vehicles to fight a fast paced battle.
+
+WWW: http://www.s2games.com/savage/
diff --git a/games/linux-savage/pkg-install b/games/linux-savage/pkg-install
new file mode 100644
index 000000000000..e578ef32bf19
--- /dev/null
+++ b/games/linux-savage/pkg-install
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+[ "$2" != "POST-INSTALL" ] && exit 0
+
+scripts_file=$PKG_PREFIX/scripts.log
+laspatch_file=$PKG_PREFIX/updater/lastpatch.txt
+patchindex_file=$PKG_PREFIX/updater/patchindex.txt
+
+if ! [ -e $scripts_file ]; then
+ touch $scripts_file
+ chown root:wheel $scripts_file 2>/dev/null
+ chmod 666 $scripts_file
+fi
+
+if ! [ -e $laspatch_file ]; then
+ echo "savage20031022a-patch.tar.gz" > $laspatch_file
+ chown root:wheel $laspatch_file 2>/dev/null
+ chmod 666 $laspatch_file
+fi
+
+if ! [ -e $patchindex_file ]; then
+ touch $patchindex_file
+ chown root:wheel $patchindex_file 2>/dev/null
+ chmod 666 $patchindex_file
+fi
diff --git a/games/linux-savage/pkg-plist b/games/linux-savage/pkg-plist
new file mode 100644
index 000000000000..abc9d5d9793e
--- /dev/null
+++ b/games/linux-savage/pkg-plist
@@ -0,0 +1,248 @@
+bin/linux-savage
+bin/linux-savage_editor
+bin/linux-savage_server
+%%SAVAGEDIR%%/editor/brushes/standard/brush1.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush10.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush11.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush12.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush13.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush14.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush15.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush16.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush17.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush18.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush19.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush2.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush20.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush21.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush22.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush23.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush24.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush25.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush26.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush27.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush28.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush29.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush3.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush30.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush31.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush32.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush4.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush5.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush6.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush7.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush8.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush9.tga
+%%SAVAGEDIR%%/editor/brushes/standard/brush1.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush10.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush11.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush12.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush13.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush14.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush15.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush16.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush17.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush18.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush19.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush2.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush20.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush21.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush22.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush23.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush24.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush25.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush26.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush27.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush28.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush29.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush3.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush30.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush31.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush32.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush4.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush5.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush6.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush7.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush8.s2g
+%%SAVAGEDIR%%/editor/brushes/standard/brush9.s2g
+%%SAVAGEDIR%%/editor/gui/jesse/1_nl_selected120x16.tga
+%%SAVAGEDIR%%/editor/gui/jesse/black.tga
+%%SAVAGEDIR%%/editor/gui/jesse/bl_jesse.tga
+%%SAVAGEDIR%%/editor/gui/jesse/brushselected.tga
+%%SAVAGEDIR%%/editor/gui/jesse/br_jesse.tga
+%%SAVAGEDIR%%/editor/gui/jesse/button120x16.tga
+%%SAVAGEDIR%%/editor/gui/jesse/button120x16_down.tga
+%%SAVAGEDIR%%/editor/gui/jesse/button120x16_over.tga
+%%SAVAGEDIR%%/editor/gui/jesse/button120x16_selected.tga
+%%SAVAGEDIR%%/editor/gui/jesse/b_jesse.tga
+%%SAVAGEDIR%%/editor/gui/jesse/createvars.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/keys.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/l_jesse.tga
+%%SAVAGEDIR%%/editor/gui/jesse/r_jesse.tga
+%%SAVAGEDIR%%/editor/gui/jesse/selected120x16.tga
+%%SAVAGEDIR%%/editor/gui/jesse/spinner.tga
+%%SAVAGEDIR%%/editor/gui/jesse/spinner_down.tga
+%%SAVAGEDIR%%/editor/gui/jesse/tl_jesse.tga
+%%SAVAGEDIR%%/editor/gui/jesse/tr_jesse.tga
+%%SAVAGEDIR%%/editor/gui/jesse/t_jesse.tga
+%%SAVAGEDIR%%/editor/gui/jesse/ui_background.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_brushes.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_brushrows.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_deform.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_deform_mode.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_enviro_mode.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_fog.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_frame.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_grass.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_hider.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_light.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_mode.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_objects.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_object_mode.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_paint.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_paint_mode.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_sky.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_startup.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_swatchpanel.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_util.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_texture.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_texture_mode.cfg
+%%SAVAGEDIR%%/editor/gui/jesse/ui_util_mode.cfg
+%%SAVAGEDIR%%/editor/gui/standard/hsliderbg.tga
+%%SAVAGEDIR%%/editor/gui/standard/hsliderfill.tga
+%%SAVAGEDIR%%/editor/gui/standard/hsliderhandle.tga
+%%SAVAGEDIR%%/editor/gui/standard/sliderbg.tga
+%%SAVAGEDIR%%/editor/gui/standard/sliderfill.tga
+%%SAVAGEDIR%%/editor/gui/standard/sliderhandle.tga
+%%SAVAGEDIR%%/editor/world/blank128.s2z
+%%SAVAGEDIR%%/editor/world/blank192.s2z
+%%SAVAGEDIR%%/editor/world/blank256.s2z
+%%SAVAGEDIR%%/editor/world/blank32.s2z
+%%SAVAGEDIR%%/editor/world/blank384.s2z
+%%SAVAGEDIR%%/editor/world/blank512.s2z
+%%SAVAGEDIR%%/editor/world/blank64.s2z
+%%SAVAGEDIR%%/editor/world/blank96.s2z
+%%SAVAGEDIR%%/editor/game.so
+%%SAVAGEDIR%%/editor/autoexec.cfg
+%%SAVAGEDIR%%/editor/default.cfg
+%%SAVAGEDIR%%/editor/gamefont.ttf
+%%SAVAGEDIR%%/editor/ui.cfg
+%%SAVAGEDIR%%/game/music/a_new_earth.ogg
+%%SAVAGEDIR%%/game/music/bg_test.ogg
+%%SAVAGEDIR%%/game/music/lost_hills.ogg
+%%SAVAGEDIR%%/game/music/menu.ogg
+%%SAVAGEDIR%%/game/music/the_legion_advances_by_moonlight.ogg
+%%SAVAGEDIR%%/game/music/the_savage_age.ogg
+%%SAVAGEDIR%%/game/music/to_rebuild_and_restore.ogg
+%%SAVAGEDIR%%/game/music/victory.ogg
+%%SAVAGEDIR%%/game/screenshots/screenshots.txt
+%%SAVAGEDIR%%/game/settings/default_gfxsettings_high.cfg
+%%SAVAGEDIR%%/game/settings/default_gfxsettings_low.cfg
+%%SAVAGEDIR%%/game/settings/default_gfxsettings_med.cfg
+%%SAVAGEDIR%%/game/settings/default_playerkeys.cfg
+%%SAVAGEDIR%%/game/settings/default_vidsettings.cfg
+%%SAVAGEDIR%%/game/settings/profile.cfg
+%%SAVAGEDIR%%/game/settings/set_options.cfg
+%%SAVAGEDIR%%/game/settings/userkeys.cfg
+%%SAVAGEDIR%%/game/settings/user_clgraphics_options.cfg
+%%SAVAGEDIR%%/game/settings/user_graphics_options.cfg
+%%SAVAGEDIR%%/game/settings/user_network_options.cfg
+%%SAVAGEDIR%%/game/settings/user_sound_options.cfg
+%%SAVAGEDIR%%/game/settings/user_tlgraphics_options.cfg
+%%SAVAGEDIR%%/game/world/alpinevalley.s2z
+%%SAVAGEDIR%%/game/world/alpinevalley_overhead.tga
+%%SAVAGEDIR%%/game/world/battlefront.s2z
+%%SAVAGEDIR%%/game/world/battlefront_overhead.tga
+%%SAVAGEDIR%%/game/world/borderwar.s2z
+%%SAVAGEDIR%%/game/world/borderwar_overhead.tga
+%%SAVAGEDIR%%/game/world/bunker.s2z
+%%SAVAGEDIR%%/game/world/bunker_overhead.tga
+%%SAVAGEDIR%%/game/world/crossroads.s2z
+%%SAVAGEDIR%%/game/world/crossroads_overhead.tga
+%%SAVAGEDIR%%/game/world/eden.s2z
+%%SAVAGEDIR%%/game/world/eden2.s2z
+%%SAVAGEDIR%%/game/world/eden2_overhead.tga
+%%SAVAGEDIR%%/game/world/eden_overhead.tga
+%%SAVAGEDIR%%/game/world/losthills.s2z
+%%SAVAGEDIR%%/game/world/losthills_overhead.tga
+%%SAVAGEDIR%%/game/world/morning.s2z
+%%SAVAGEDIR%%/game/world/morning_overhead.tga
+%%SAVAGEDIR%%/game/world/moss.s2z
+%%SAVAGEDIR%%/game/world/moss_overhead.tga
+%%SAVAGEDIR%%/game/world/savagegrounds.s2z
+%%SAVAGEDIR%%/game/world/savagegrounds_overhead.tga
+%%SAVAGEDIR%%/game/world/snowblind.s2z
+%%SAVAGEDIR%%/game/world/snowblind_overhead.tga
+%%SAVAGEDIR%%/game/world/tropical.s2z
+%%SAVAGEDIR%%/game/world/tropical_overhead.tga
+%%SAVAGEDIR%%/game/world/tuskanflats.s2z
+%%SAVAGEDIR%%/game/world/tuskanflats_overhead.tga
+%%SAVAGEDIR%%/game/game.so
+%%SAVAGEDIR%%/game/autoexec.cfg
+%%SAVAGEDIR%%/game/buddies.cfg
+%%SAVAGEDIR%%/game/commander_keys.cfg
+%%SAVAGEDIR%%/game/default.cfg
+%%SAVAGEDIR%%/game/gamefont.ttf
+%%SAVAGEDIR%%/game/gui0.s2z
+%%SAVAGEDIR%%/game/gui1.s2z
+%%SAVAGEDIR%%/game/gui2.s2z
+%%SAVAGEDIR%%/game/images0.s2z
+%%SAVAGEDIR%%/game/images1.s2z
+%%SAVAGEDIR%%/game/intro.cfg
+%%SAVAGEDIR%%/game/playerkeys.cfg
+%%SAVAGEDIR%%/game/rotation.cfg
+%%SAVAGEDIR%%/game/savage0.s2z
+%%SAVAGEDIR%%/game/savage1.s2z
+%%SAVAGEDIR%%/game/savage_intro.bik
+%%SAVAGEDIR%%/game/savage_intro.ogg
+%%SAVAGEDIR%%/game/sounds0.s2z
+%%SAVAGEDIR%%/game/ui_game.cfg
+%%SAVAGEDIR%%/game/ui_main.cfg
+%%SAVAGEDIR%%/updater/lastpatch.txt
+%%SAVAGEDIR%%/updater/patchindex.txt
+%%SAVAGEDIR%%/updater/updater.txt
+%%SAVAGEDIR%%/libs/libSDL-1.2.so.0
+%%SAVAGEDIR%%/libs/libcrypto.so.0.9.6
+%%SAVAGEDIR%%/libs/libcurl.so.2
+%%SAVAGEDIR%%/libs/libfmod-3.63.so
+%%SAVAGEDIR%%/libs/libfmod.so
+%%SAVAGEDIR%%/libs/libfreetype.so.6
+%%SAVAGEDIR%%/libs/libglib-2.0.so.0
+%%SAVAGEDIR%%/libs/libmd5.so.0
+%%SAVAGEDIR%%/libs/libpng.so.2
+%%SAVAGEDIR%%/libs/libssl.so.0.9.6
+%%SAVAGEDIR%%/libs/libstdc++-libc6.2-2.so.3
+%%SAVAGEDIR%%/dedicated_server.bin
+%%SAVAGEDIR%%/savage
+%%SAVAGEDIR%%/savage.bin
+%%SAVAGEDIR%%/silverback.bin
+%%SAVAGEDIR%%/scripts.log
+%%SAVAGEDIR%%/update
+%%SAVAGEDIR%%/agp_error.txt
+%%SAVAGEDIR%%/icon.xpm
+%%SAVAGEDIR%%/logo.png
+%%SAVAGEDIR%%/eula.txt
+%%PORTDOCS%%%%DOCSDIR%%/S2 Games Web Page.url
+%%PORTDOCS%%%%DOCSDIR%%/Savage Clans.url
+%%PORTDOCS%%%%DOCSDIR%%/Savage Mods.url
+%%PORTDOCS%%%%DOCSDIR%%/Savage Stats.url
+%%PORTDOCS%%%%DOCSDIR%%/Savage Tech Support.url
+%%PORTDOCS%%%%DOCSDIR%%/commander_controls.txt
+%%PORTDOCS%%%%DOCSDIR%%/important_performance_information.rtf
+%%PORTDOCS%%%%DOCSDIR%%/licenses.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SAVAGEDIR%%/updater
+@dirrm %%SAVAGEDIR%%/libs
+@dirrm %%SAVAGEDIR%%/game/world
+@dirrm %%SAVAGEDIR%%/game/settings
+@dirrm %%SAVAGEDIR%%/game/screenshots
+@dirrm %%SAVAGEDIR%%/game/music
+@dirrm %%SAVAGEDIR%%/game
+@dirrm %%SAVAGEDIR%%/editor/world
+@dirrm %%SAVAGEDIR%%/editor/gui/standard
+@dirrm %%SAVAGEDIR%%/editor/gui/jesse
+@dirrm %%SAVAGEDIR%%/editor/gui
+@dirrm %%SAVAGEDIR%%/editor/brushes/standard
+@dirrm %%SAVAGEDIR%%/editor/brushes
+@dirrm %%SAVAGEDIR%%/editor
+@dirrm %%SAVAGEDIR%%