aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/procenv/Makefile16
-rw-r--r--sysutils/procenv/distinfo4
2 files changed, 16 insertions, 4 deletions
diff --git a/sysutils/procenv/Makefile b/sysutils/procenv/Makefile
index b38871137941..4b71ba913baa 100644
--- a/sysutils/procenv/Makefile
+++ b/sysutils/procenv/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= procenv
-PORTVERSION= 0.23
+PORTVERSION= 0.24
CATEGORIES= sysutils
MASTER_SITES= https://launchpad.net/procenv/trunk/${PORTVERSION}/+download/ \
DEBIAN \
@@ -14,7 +14,9 @@ COMMENT= Utility to show process environment
LICENSE= GPLv3
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
+USE_AUTOTOOLS= aclocal automake
+
FETCH_ARGS= -Fpr
MAN1= procenv.1
@@ -26,4 +28,14 @@ PLIST_FILES= bin/procenv
BROKEN= does not build on old ${OPSYS} versions
.endif
+# Test to ensure procenv will actually run.
+#
+# This has the attractive side-effect of displaying the environment
+# of the build system which may be of interest to those fixing FTBFS
+# packages that build correctly locally.
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} check
+
+test: regression-test
+
.include <bsd.port.post.mk>
diff --git a/sysutils/procenv/distinfo b/sysutils/procenv/distinfo
index dc54dc1e867a..eda5f12374e7 100644
--- a/sysutils/procenv/distinfo
+++ b/sysutils/procenv/distinfo
@@ -1,2 +1,2 @@
-SHA256 (procenv-0.23.tar.gz) = 02f977bc7a61f7e366e193d76097f7390903c9a8c9270a09b96431b7db5e7ba9
-SIZE (procenv-0.23.tar.gz) = 212792
+SHA256 (procenv-0.24.tar.gz) = 576d1799c1e716c12b1ea11e6a658ec6fccb794c94013edc4f72d68e85e4b026
+SIZE (procenv-0.24.tar.gz) = 216260