aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/gwenhywfar/Makefile15
-rw-r--r--devel/gwenhywfar/pkg-descr2
2 files changed, 10 insertions, 7 deletions
diff --git a/devel/gwenhywfar/Makefile b/devel/gwenhywfar/Makefile
index 348b9701b02b..3c9cdd35df7c 100644
--- a/devel/gwenhywfar/Makefile
+++ b/devel/gwenhywfar/Makefile
@@ -43,25 +43,28 @@ PORTEXAMPLES= STYLE \
# Enable printing of memory debugger statistic at runtime.
.if defined(WITH_MEMDEBUG)
-CONFIGURE_ARGS+= --enable-memtrace
+CONFIGURE_ARGS+= --enable-memtrace
.endif
.if defined(WITH_PORTDOCS)
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
-CONFIGURE_ARGS+= --enable-full-doc
-PORTDOCS=*
+CONFIGURE_ARGS+= --enable-full-doc
+PORTDOCS= *
+.endif
+
+post-build:
+.if !defined(NOPORTDOCS) && defined(WITH_PORTDOCS)
+ @cd ${WRKSRC} && ${MAKE} srcdoc
.endif
post-install:
-.if !defined(NOPORTDOCS)
-.if defined(WITH_PORTDOCS)
+.if !defined(NOPORTDOCS) && defined(WITH_PORTDOCS)
@${ECHO_CMD} Installing documentation...
${MKDIR} ${DOCSDIR}
@cd ${WRKSRC} && ${FIND} apidoc -mindepth 1 \! -type d \
-exec ${ECHO_CMD} "{} -> ${DOCSDIR}/{}" \; \
-exec ${INSTALL_DATA} ${WRKSRC}/{} ${DOCSDIR} \;
.endif
-.endif
.if !defined(NOPORTEXAMPLES)
@${ECHO_CMD} Installing examples...
${MKDIR} ${EXAMPLESDIR}
diff --git a/devel/gwenhywfar/pkg-descr b/devel/gwenhywfar/pkg-descr
index 694133598b41..e1a3ceb325a0 100644
--- a/devel/gwenhywfar/pkg-descr
+++ b/devel/gwenhywfar/pkg-descr
@@ -5,7 +5,7 @@ It is used by several 'finance' ports, and possibly others.
Gwenhywfar includes the following features, among several others:
- OS abstraction functions for directory and Internet address handling
and library loading (src/os/)
-- Networking functions which allow to manage many connections to be used
+- Networking functions which allow managing many connections to be used
economically even in single threaded applications
- High-level functions for parsing files with a simplified "XML-like"
format and accessing them like a hierarchical database (src/parser/)