aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/xmlto/Makefile35
-rw-r--r--textproc/xmlto/distinfo6
-rw-r--r--textproc/xmlto/files/patch-xmlto.in16
3 files changed, 24 insertions, 33 deletions
diff --git a/textproc/xmlto/Makefile b/textproc/xmlto/Makefile
index e3d6ab2c4571..fba384890bbe 100644
--- a/textproc/xmlto/Makefile
+++ b/textproc/xmlto/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= xmlto
-PORTVERSION= 0.0.20
-PORTREVISION= 2
+PORTVERSION= 0.0.21
CATEGORIES= textproc
-MASTER_SITES= http://cyberelk.net/tim/data/xmlto/stable/
-# Master Site is subject to change with 0.0.21 release
+MASTER_SITES= https://fedorahosted.org/releases/x/m/xmlto/
MAINTAINER= matthias.andree@gmx.de
COMMENT= Front-end to an XSL toolchain
@@ -22,7 +20,10 @@ BUILD_DEPENDS= ${BASH_CMD}:${PORTSDIR}/shells/bash \
${XSL_DIR}:${PORTSDIR}/textproc/docbook-xsl
RUN_DEPENDS= ${BUILD_DEPENDS}
-OPTIONS= PASSIVETEX "Enable PassiveTeX support for DVI/PS/PDF" OFF
+OPTIONS= PASSIVETEX "Enable PassiveTeX support for DVI/PS/PDF" OFF \
+ FOP "Add dependency on FOP" OFF \
+ LIBPAPER "Add dependency on libpaper" OFF \
+ DBLATEX "Add dependency on Dblatex (EXPERIMENTAL)" OFF
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -49,20 +50,26 @@ PLIST_SUB= PASSIVETEX=""
PLIST_SUB= PASSIVETEX="@comment "
.endif
+.if defined(WITH_FOP)
+RUN_DEPENDS+= ${LOCALBASE}/bin/fop:${PORTSDIR}/textproc/fop
+.endif
+
+.if defined(WITH_LIBPAPER)
+RUN_DEPENDS+= ${LOCALBASE}/bin/paperconf:${PORTSDIR}/print/libpaper
+.endif
+
+.if defined(WITH_DBLATEX)
+RUN_DEPENDS+= ${LOCALBASE}/bin/dblatex:${PORTSDIR}/textproc/dblatex
+.endif
+
post-patch:
-.for i in docbook/htmlhelp docbook/xhtml-nochunks docbook/javahelp \
- docbook/html docbook/html-nochunks docbook/xhtml docbook/fo \
- docbook/man fo/dvi fo/pdf
- @${REINPLACE_CMD} -e 's|-a|-PpR|' ${WRKSRC}/format/${i}
-.endfor
+ @${REINPLACE_CMD} -E -e 's,/usr/bin/(dblatex|fop|links|lynx|paperconf|w3m),${LOCALBASE}/bin/\1,g' \
+ ${WRKSRC}/xmlto.in \
+ ${WRKSRC}/format/docbook/txt
.if !defined(WITH_PASSIVETEX)
@${REINPLACE_CMD} -e '/format\/fo\//d' ${WRKSRC}/Makefile.in
.endif
-post-build:
- @${REINPLACE_CMD} -e 's,/usr/bin,${LOCALBASE}/bin,g' \
- ${WRKSRC}/format/docbook/txt
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/textproc/xmlto/distinfo b/textproc/xmlto/distinfo
index d0c64bb9d6a1..81befa988359 100644
--- a/textproc/xmlto/distinfo
+++ b/textproc/xmlto/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmlto-0.0.20.tar.bz2) = ab814ae352fc028862cbea9d676ab93b
-SHA256 (xmlto-0.0.20.tar.bz2) = 9ffa1971b9a61851a794caf6cd9f0c81290926cef9a790af845c310f169ce1e8
-SIZE (xmlto-0.0.20.tar.bz2) = 98388
+MD5 (xmlto-0.0.21.tar.bz2) = cc2039dedc81f1a56b06e5fdac6f7570
+SHA256 (xmlto-0.0.21.tar.bz2) = b6435ce111c7578126b6cdcfbd67a229bd27ae3391225d6a1f52dc22b0597049
+SIZE (xmlto-0.0.21.tar.bz2) = 99554
diff --git a/textproc/xmlto/files/patch-xmlto.in b/textproc/xmlto/files/patch-xmlto.in
deleted file mode 100644
index 87c972bc773e..000000000000
--- a/textproc/xmlto/files/patch-xmlto.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- xmlto.in.orig 2008-01-17 10:39:02.000000000 +0100
-+++ xmlto.in 2008-05-25 13:43:48.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!@BASH@
- #
- # @PACKAGE@ - apply an XSL stylesheet to an XML document
- # Copyright (C) 2001, 2002, 2003 Tim Waugh <twaugh@redhat.com>
-@@ -326,6 +326,7 @@
- # Ask the format script what stylesheet to use.
- XSLT_PROCESSOR=xsltproc # We only know about xsltproc right now.
- export XSLT_PROCESSOR
-+export USE_BACKEND
- if [ -z "$STYLESHEET" ]
- then
- STYLESHEET="$(${BASH} "$FORMAT" stylesheet)" || exit 1