aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/pbzip2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/archivers/pbzip2/Makefile b/archivers/pbzip2/Makefile
index 317c0a4e8e79..4bb4f418980f 100644
--- a/archivers/pbzip2/Makefile
+++ b/archivers/pbzip2/Makefile
@@ -17,8 +17,11 @@ PLIST_FILES= bin/pbzip2 bin/pbunzip2 \
man/man1/pbzip2.1.gz man/man1/pbunzip2.1.gz
post-patch:
+ @${REINPLACE_CMD} -e 's,PRI[iu]MAX, & ,g' ${WRKSRC}/pbzip2.cpp \
+ ${WRKSRC}/BZ2StreamScanner.cpp
# Spell target sources to be understood by both BSD and GNU make(1)
- @${REINPLACE_CMD} -e 's,$$^,$$>&,' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/-O2/s,^,#, ; s,$$^,$$>&,' \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/