aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/pike74/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/pike74/Makefile b/lang/pike74/Makefile
index 0d9257714c83..a521636d2026 100644
--- a/lang/pike74/Makefile
+++ b/lang/pike74/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pike74
PORTVERSION= 7.4.31
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
ftp://ftp.oav.net/pkg_freebsd/distfiles/ \
@@ -61,8 +62,11 @@ CONFIGURE_ARGS+= --without-debug \
--without-gnome \
--without-glade \
--without-libglade-config \
+ --without-machine-code \
--prefix=${PREFIX}
+USE_REINPLACE= yes
+
.include <bsd.port.pre.mk>
PLIST_SUB+= PORTVERSION=${PORTVERSION}
@@ -348,6 +352,10 @@ pre-everything::
pre-configure:
@${ECHO} ${CONFIGURE_ARGS}
+post-patch:
+ @${REINPLACE_CMD} -e 's| -lgmp| -L${LOCALBASE}/lib -lgmp|' \
+ ${WRKSRC}/modules/Gmp/configure ${WRKSRC}/modules/_Image_XFace/configure
+
post-install:
${INSTALL_PROGRAM} ${WRKSRC}pike ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}hilfe ${PREFIX}/bin