aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/execinfo.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/Mk/Uses/execinfo.mk b/Mk/Uses/execinfo.mk
index 72bab07b2d1e..3c4d0b846a04 100644
--- a/Mk/Uses/execinfo.mk
+++ b/Mk/Uses/execinfo.mk
@@ -5,13 +5,23 @@
# Feature: execinfo
# Usage: USES=execinfo
#
-# Take no arguments
+# Takes no arguments
+#
+# Exported variables:
+#
+# EXECINFO_CPPFLAGS - preprocessor flags needed to correctly use
+# execinfo library
+# EXECINFO_LDFLAGS - linker flags needed to correctly use
+# execinfo library
+#
.if !defined(_INCLUDE_USES_EXECINFO_MK)
_INCLUDE_USES_EXECINFO_MK= yes
.if !exists(/usr/lib/libexecinfo.so)
LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+EXECINFO_CPPFLAGS= -I${LOCALBASE}/include
+EXECINFO_LDFLAGS= -L${LOCALBASE}/lib
.endif
.endif