aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/geany-plugin-geanypy/Makefile5
-rw-r--r--devel/geany-plugin-lua/Makefile6
-rw-r--r--devel/geany/Makefile3
3 files changed, 11 insertions, 3 deletions
diff --git a/devel/geany-plugin-geanypy/Makefile b/devel/geany-plugin-geanypy/Makefile
index 1f8a1018ed33..2e8769ff2ea7 100644
--- a/devel/geany-plugin-geanypy/Makefile
+++ b/devel/geany-plugin-geanypy/Makefile
@@ -2,6 +2,7 @@
PORTNAME= geany-plugin-geanypy
PORTVERSION= ${GEANY_VER}
+PORTREVISION= 1
PKGNAMESUFFIX= -gtk2
CATEGORIES= devel
@@ -12,9 +13,11 @@ LIB_DEPENDS= libgeany.so:devel/geany@gtk2
FLAVORS= # intentionally left empty
-USES= python:2.7
+USES= python:2.7 shebangfix
USE_GNOME= pygtk2
+SHEBANG_FILES= geanypy/geany/console.py
+
OPTIONS_DEFINE= DOCS
.include "${.CURDIR}/../geany-plugins/files/Makefile.common"
diff --git a/devel/geany-plugin-lua/Makefile b/devel/geany-plugin-lua/Makefile
index 966f04024ffe..4f275ae594bf 100644
--- a/devel/geany-plugin-lua/Makefile
+++ b/devel/geany-plugin-lua/Makefile
@@ -7,7 +7,11 @@ CATEGORIES= devel
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Geany plugin: ${${GEANY_PLUGIN}_DESC}
-USES= lua:51
+USES= lua:51 shebangfix
+
+SHEBANG_FILES= geanylua/util/mkiface.lua \
+ geanylua/util/mk-keytab.lua \
+ geanylua/util/keywords.lua
.include "${.CURDIR}/../geany-plugins/files/Makefile.common"
.include <bsd.port.mk>
diff --git a/devel/geany/Makefile b/devel/geany/Makefile
index 2d55fd76dba4..adb30332aad1 100644
--- a/devel/geany/Makefile
+++ b/devel/geany/Makefile
@@ -23,13 +23,14 @@ gtk2_PKGNAMESUFFIX= -gtk2
gtk3_CONFLICTS_INSTALL= geany-gtk2
USES= compiler:c++11-lang desktop-file-utils gettext-tools gmake \
- gnome libtool localbase pathfix pkgconfig tar:bzip2
+ gnome libtool localbase pathfix pkgconfig shebangfix tar:bzip2
USE_GNOME= cairo intltool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
+SHEBANG_FILES= scripts/gen-api-gtkdoc.py
OPTIONS_DEFINE= VTE NLS DOCS
OPTIONS_DEFAULT= VTE