aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-BFD/Makefile22
-rw-r--r--devel/p5-BFD/distinfo2
-rw-r--r--devel/p5-BFD/pkg-descr3
-rw-r--r--devel/p5-BFD/pkg-plist2
5 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c61e6712ce21..0592f955ddc3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -573,6 +573,7 @@
SUBDIR += p5-B-Deobfuscate
SUBDIR += p5-B-Graph
SUBDIR += p5-B-Keywords
+ SUBDIR += p5-BFD
SUBDIR += p5-BSD-Resource
SUBDIR += p5-BSD-stat
SUBDIR += p5-C-Scan
diff --git a/devel/p5-BFD/Makefile b/devel/p5-BFD/Makefile
new file mode 100644
index 000000000000..f1bda8f0faa3
--- /dev/null
+++ b/devel/p5-BFD/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: devel/p5-BFD
+# Date created: May 2004
+# Whom: Autrijus Tang <autrijus@autrijus.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BFD
+PORTVERSION= 0.31
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/R/RB/RBS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= autrijus@autrijus.org
+COMMENT= Impromptu dumping of data structures for debugging purposes
+
+PERL_CONFIGURE= yes
+
+MAN3= BFD.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-BFD/distinfo b/devel/p5-BFD/distinfo
new file mode 100644
index 000000000000..a7fc4856a55a
--- /dev/null
+++ b/devel/p5-BFD/distinfo
@@ -0,0 +1,2 @@
+MD5 (BFD-0.31.tar.gz) = 7715ecf4133b9ab1ddabf9221663d576
+SIZE (BFD-0.31.tar.gz) = 2773
diff --git a/devel/p5-BFD/pkg-descr b/devel/p5-BFD/pkg-descr
new file mode 100644
index 000000000000..59e22eb4ac9d
--- /dev/null
+++ b/devel/p5-BFD/pkg-descr
@@ -0,0 +1,3 @@
+BFD allows for impromptu dumping of output to STDERR. Useful when you
+want to take a peek at a nest Perl data structure by emitting (relatively)
+nicely formatted output with filename and line number prefixed to each line.
diff --git a/devel/p5-BFD/pkg-plist b/devel/p5-BFD/pkg-plist
new file mode 100644
index 000000000000..3067e8587165
--- /dev/null
+++ b/devel/p5-BFD/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/BFD.pm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/BFD 2>/dev/null || true