aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Net-SSL-ExpireDate/Makefile34
-rw-r--r--security/p5-Net-SSL-ExpireDate/distinfo2
-rw-r--r--security/p5-Net-SSL-ExpireDate/pkg-descr4
-rw-r--r--security/p5-Net-SSL-ExpireDate/pkg-plist7
5 files changed, 48 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 71721b351102..2dbf0ba61d05 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -525,6 +525,7 @@
SUBDIR += p5-Net-OpenID-Server
SUBDIR += p5-Net-Radius-Server
SUBDIR += p5-Net-SAML
+ SUBDIR += p5-Net-SSL-ExpireDate
SUBDIR += p5-Net-SSLeay
SUBDIR += p5-Net-Server-Mail-ESMTP-AUTH
SUBDIR += p5-Net-SinFP
diff --git a/security/p5-Net-SSL-ExpireDate/Makefile b/security/p5-Net-SSL-ExpireDate/Makefile
new file mode 100644
index 000000000000..4f1c10eada4e
--- /dev/null
+++ b/security/p5-Net-SSL-ExpireDate/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Net-SSL-ExpireDate
+# Date created: 2011-10-03
+# Whom: Stephon Chen <stephon@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SSL-ExpireDate
+PORTVERSION= 1.10
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Obtain expiration date of certificate
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Crypt-OpenSSL-X509>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-X509 \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Time-Duration-Parse>=0:${PORTSDIR}/devel/p5-Time-Duration-Parse \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Crypt-OpenSSL-X509>=0:${PORTSDIR}/security/p5-Crypt-OpenSSL-X509 \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Time-Duration-Parse>=0:${PORTSDIR}/devel/p5-Time-Duration-Parse \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SSL::ExpireDate.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Net-SSL-ExpireDate/distinfo b/security/p5-Net-SSL-ExpireDate/distinfo
new file mode 100644
index 000000000000..1f6283fd0728
--- /dev/null
+++ b/security/p5-Net-SSL-ExpireDate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-SSL-ExpireDate-1.10.tar.gz) = 60aafe97ddbadb7102d4dcbb876da635d8d1b4a8cd80e889fa38b36899f09b2b
+SIZE (Net-SSL-ExpireDate-1.10.tar.gz) = 51675
diff --git a/security/p5-Net-SSL-ExpireDate/pkg-descr b/security/p5-Net-SSL-ExpireDate/pkg-descr
new file mode 100644
index 000000000000..286d576c4a57
--- /dev/null
+++ b/security/p5-Net-SSL-ExpireDate/pkg-descr
@@ -0,0 +1,4 @@
+Net::SSL::ExpireDate get certificate from network (SSL) or local file and obtain
+its expiration date.
+
+WWW: http://search.cpan.org/dist/Net-SSL-ExpireDate/
diff --git a/security/p5-Net-SSL-ExpireDate/pkg-plist b/security/p5-Net-SSL-ExpireDate/pkg-plist
new file mode 100644
index 000000000000..5545dc6f93b3
--- /dev/null
+++ b/security/p5-Net-SSL-ExpireDate/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/SSL/ExpireDate.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSL/ExpireDate/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSL/ExpireDate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/SSL
+@dirrmtry %%SITE_PERL%%/Net