aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/py-shout/Makefile7
-rw-r--r--audio/sonata/Makefile8
-rw-r--r--cad/z88/Makefile7
-rw-r--r--emulators/nonpareil/Makefile2
-rw-r--r--games/mahjong/Makefile10
-rw-r--r--games/umark/Makefile7
-rw-r--r--games/wargus/Makefile2
-rw-r--r--graphics/pixelize/Makefile9
-rw-r--r--graphics/rgbpaint/Makefile8
-rw-r--r--sysutils/gkrellflynn/Makefile1
-rw-r--r--x11/wmcliphist/Makefile7
11 files changed, 20 insertions, 48 deletions
diff --git a/audio/py-shout/Makefile b/audio/py-shout/Makefile
index b60e39087e1f..dc3c185401d9 100644
--- a/audio/py-shout/Makefile
+++ b/audio/py-shout/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-shout
-# Date created: 2009-08-07
-# Whom: Olivier Duchateau <duchateau.olivier@gmail.com>
-#
+# Created by: Olivier Duchateau <duchateau.olivier@gmail.com>
# $FreeBSD$
-#
PORTNAME= shout
PORTVERSION= 0.2.1
@@ -19,6 +15,7 @@ LIB_DEPENDS= shout.5:${PORTSDIR}/audio/libshout2
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+USES= pkgconfig
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= ${PORTNAME}-python
diff --git a/audio/sonata/Makefile b/audio/sonata/Makefile
index 5e37a698bf37..e8999a70584f 100644
--- a/audio/sonata/Makefile
+++ b/audio/sonata/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sonata
-# Date created: 2007-01-22
-# Whom: Nicola Vitale <nivit@FreeBSD.org>
-#
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= sonata
PORTVERSION= 1.6.2.1
@@ -18,7 +14,7 @@ LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpd>=0.2.0:${PORTSDIR}/audio/py-mpd
-USES= gettext
+USES= gettext pkgconfig
USE_GNOME= pygtk2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/cad/z88/Makefile b/cad/z88/Makefile
index 9be7232c9f86..31359cd4c84b 100644
--- a/cad/z88/Makefile
+++ b/cad/z88/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Z88
-# Date created: Dec. 2004
-# Whom: Pedro F. Giffuni <giffunip@asme.org>
-#
+# Created by: Pedro F. Giffuni <giffunip@asme.org>
# $FreeBSD$
-#
PORTNAME= z88
PORTVERSION= 13.0
@@ -20,6 +16,7 @@ COMMENT= A compact Finite Element Analysis System
LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
NO_WRKSUBDIR= yes
+USES= pkgconfig
USE_GL= glu
USE_GNOME= gtk20
diff --git a/emulators/nonpareil/Makefile b/emulators/nonpareil/Makefile
index d3ff425761d8..e7a3ebb67f43 100644
--- a/emulators/nonpareil/Makefile
+++ b/emulators/nonpareil/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-USES= bison
+USES= bison pkgconfig
USE_GNOME= gtk20 libxml2
USE_SDL= sdl
USE_SCONS= yes
diff --git a/games/mahjong/Makefile b/games/mahjong/Makefile
index ed2aeaeb202b..6504d6323e2a 100644
--- a/games/mahjong/Makefile
+++ b/games/mahjong/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: mahjong
-# Date created: Jan 31, 2001
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mahjong
PORTVERSION= 1.12.1
@@ -19,10 +14,9 @@ COMMENT= A networked Mah Jong program, together with a computer player
LICENSE= GPLv2 # (or later)
-USES= perl5
+USES= perl5 gmake pkgconfig
USE_GNOME= gtk20
USE_PERL5= build
-USE_GMAKE= yes
MAKE_ENV= CCLINK="${CC}" CDEBUGFLAGS="${CFLAGS}" PERL="${PERL}" \
INCLUDES="-I."
diff --git a/games/umark/Makefile b/games/umark/Makefile
index 1c131ae1a743..e8a6b1a0ea82 100644
--- a/games/umark/Makefile
+++ b/games/umark/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: UMark
-# Date created: 31 Jul 2005
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= umark
DISTVERSION= 2.0.0-Beta3
@@ -17,6 +13,7 @@ COMMENT= Unreal Tournament 200x series benchmark utility
LICENSE= GPLv2
+USES= pkgconfig
USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/UMark/src
MAKEFILE= ${FILESDIR}/Makefile
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index c3f14bbe5f2c..5abe3401fdda 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= stratagus:${PORTSDIR}/games/stratagus
LICENSE= GPLv2
NOT_FOR_ARCHS= sparc64
-USES= pathfix gmake
+USES= pathfix gmake pkgconfig
USE_CSTD= gnu89
USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/graphics/pixelize/Makefile b/graphics/pixelize/Makefile
index fdefbcd5983b..55aa9e5f33b7 100644
--- a/graphics/pixelize/Makefile
+++ b/graphics/pixelize/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: pixelize
-# Date created: Oct 20, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= pixelize
PORTVERSION= 1.0.0
@@ -19,6 +14,8 @@ MAINTAINER= cs@FreeBSD.org
COMMENT= Use many scaled down images to try to duplicate another image
LICENSE= GPLv2
+
+USES= pkgconfig
USE_GNOME= gtk20 imlib
PLIST_FILES= bin/make_db bin/pixelize
diff --git a/graphics/rgbpaint/Makefile b/graphics/rgbpaint/Makefile
index e19f912737b7..e143578ee674 100644
--- a/graphics/rgbpaint/Makefile
+++ b/graphics/rgbpaint/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rgbpaint
-# Date created: 4 April 2007
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= rgbpaint
PORTVERSION= 0.8.7
@@ -14,7 +10,7 @@ MASTER_SITES= SF/mtpaint/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Very basic painting program
-USES= gettext
+USES= gettext pkgconfig
USE_BZIP2= yes
USE_GNOME= gtk20
HAS_CONFIGURE= yes
diff --git a/sysutils/gkrellflynn/Makefile b/sysutils/gkrellflynn/Makefile
index ee514b2f65c8..461b76b52f3a 100644
--- a/sysutils/gkrellflynn/Makefile
+++ b/sysutils/gkrellflynn/Makefile
@@ -15,6 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
PLIST_FILES= libexec/gkrellm2/plugins/gkrellflynn.so
+USES= pkgconfig
USE_GNOME= gtk20
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -c -fPIC"
ALL_TARGET= ${PORTNAME}.so
diff --git a/x11/wmcliphist/Makefile b/x11/wmcliphist/Makefile
index 461d586b9c8f..d3a70b96822a 100644
--- a/x11/wmcliphist/Makefile
+++ b/x11/wmcliphist/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmcliphist
-# Date created: Thu Jul 5 14:43:55 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= wmcliphist
PORTVERSION= 1.0
@@ -17,6 +13,7 @@ MAINTAINER= uqs@FreeBSD.org
COMMENT= Clipboard history management dockapp for Window Maker
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= pkgconfig
USE_XORG= xpm
USE_GNOME= gtk20