aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile2
-rw-r--r--textproc/scim-bridge-qt4/Makefile44
-rw-r--r--textproc/scim-bridge-qt4/distinfo3
-rw-r--r--textproc/scim-bridge-qt4/pkg-descr7
-rw-r--r--textproc/scim-bridge-qt4/pkg-plist6
-rw-r--r--textproc/scim-bridge/Makefile39
-rw-r--r--textproc/scim-bridge/distinfo3
-rw-r--r--textproc/scim-bridge/pkg-descr7
8 files changed, 111 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b7079c3bb796..44831a3133ea 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -963,6 +963,8 @@
SUBDIR += sc-aspell
SUBDIR += scew
SUBDIR += scim
+ SUBDIR += scim-bridge
+ SUBDIR += scim-bridge-qt4
SUBDIR += scim-input-pad
SUBDIR += scim-kmfl-imengine
SUBDIR += scim-kmfl-sil-ipa-unicode5
diff --git a/textproc/scim-bridge-qt4/Makefile b/textproc/scim-bridge-qt4/Makefile
new file mode 100644
index 000000000000..0fb32048bfc2
--- /dev/null
+++ b/textproc/scim-bridge-qt4/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: scim-bridge-qt4
+# Date created: 2008-08-17
+# Whom: Henry Hu <henry.hu.sh@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-bridge
+PORTVERSION= 0.4.15
+CATEGORIES= textproc
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= scim
+PKGNAMESUFFIX= -qt4
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= Qt4 client for Scim-bridge
+
+RUN_DEPENDS= scim-bridge:${PORTSDIR}/textproc/scim-bridge
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui corelib moc_build
+QT_NONSTANDARD= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-D__STDC_ISO_10646__"
+
+CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE} \
+ --disable-agent \
+ --disable-gtk2-immodule \
+ --disable-qt3-immodule \
+ --enable-qt4-immodule
+
+post-patch:
+ @${GREP} -lR "<malloc\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<malloc\.h>|<stdlib.h>|g'
+ @${GREP} -lR "<alloca\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<alloca\.h>|<stdlib.h>|g'
+ @${REINPLACE_CMD} -e '/^MOC/s|=.*|=${MOC}|' \
+ -e '/^moduledir/s|=.*|=${PREFIX}/lib/qt4/plugins/inputmethods|' \
+ ${WRKSRC}/client-qt/qt4/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/textproc/scim-bridge-qt4/distinfo b/textproc/scim-bridge-qt4/distinfo
new file mode 100644
index 000000000000..c347c6a9013b
--- /dev/null
+++ b/textproc/scim-bridge-qt4/distinfo
@@ -0,0 +1,3 @@
+MD5 (scim-bridge-0.4.15.tar.gz) = 03015dfdc01f8aa6ad933c695f47077b
+SHA256 (scim-bridge-0.4.15.tar.gz) = 802a65c412c44d7598397d2926ec6fe478fe6cc3c645047632a97ec54b2d8bcf
+SIZE (scim-bridge-0.4.15.tar.gz) = 753583
diff --git a/textproc/scim-bridge-qt4/pkg-descr b/textproc/scim-bridge-qt4/pkg-descr
new file mode 100644
index 000000000000..6df53122d040
--- /dev/null
+++ b/textproc/scim-bridge-qt4/pkg-descr
@@ -0,0 +1,7 @@
+Scim-bridge is wrapper library for SCIM, written in C. Scim-bridge
+is seperated in two parts, the agent and the clients. The agent is
+the IME server which communicates with SCIM. The clients are IMModules
+which communicate only with the agent so that there is no binary
+dependency between the clients and SCIM.
+
+WWW: http://www.scim-im.org/projects/scim_bridge/
diff --git a/textproc/scim-bridge-qt4/pkg-plist b/textproc/scim-bridge-qt4/pkg-plist
new file mode 100644
index 000000000000..8323e06c9c2b
--- /dev/null
+++ b/textproc/scim-bridge-qt4/pkg-plist
@@ -0,0 +1,6 @@
+lib/qt4/plugins/inputmethods/im-scim-bridge.a
+lib/qt4/plugins/inputmethods/im-scim-bridge.la
+lib/qt4/plugins/inputmethods/im-scim-bridge.so
+@dirrmtry lib/qt4/plugins/inputmethods
+@dirrmtry lib/qt4/plugins
+@dirrmtry lib/qt4
diff --git a/textproc/scim-bridge/Makefile b/textproc/scim-bridge/Makefile
new file mode 100644
index 000000000000..797cb2929272
--- /dev/null
+++ b/textproc/scim-bridge/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: scim-bridge
+# Date created: 2008-09-10
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-bridge
+PORTVERSION= 0.4.15
+CATEGORIES= textproc
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= scim
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= Scim-bridge agent (server)
+
+LIB_DEPENDS= scim-1.0.10:${PORTSDIR}/textproc/scim
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-D__STDC_ISO_10646__"
+
+CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE} \
+ --enable-agent \
+ --disable-gtk2-immodule \
+ --disable-qt3-immodule \
+ --disable-qt4-immodule
+
+PLIST_FILES= bin/scim-bridge
+
+post-patch:
+ @${GREP} -lR "<malloc\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<malloc\.h>|<stdlib.h>|g'
+ @${GREP} -lR "<alloca\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<alloca\.h>|<stdlib.h>|g'
+
+.include <bsd.port.mk>
diff --git a/textproc/scim-bridge/distinfo b/textproc/scim-bridge/distinfo
new file mode 100644
index 000000000000..c347c6a9013b
--- /dev/null
+++ b/textproc/scim-bridge/distinfo
@@ -0,0 +1,3 @@
+MD5 (scim-bridge-0.4.15.tar.gz) = 03015dfdc01f8aa6ad933c695f47077b
+SHA256 (scim-bridge-0.4.15.tar.gz) = 802a65c412c44d7598397d2926ec6fe478fe6cc3c645047632a97ec54b2d8bcf
+SIZE (scim-bridge-0.4.15.tar.gz) = 753583
diff --git a/textproc/scim-bridge/pkg-descr b/textproc/scim-bridge/pkg-descr
new file mode 100644
index 000000000000..6df53122d040
--- /dev/null
+++ b/textproc/scim-bridge/pkg-descr
@@ -0,0 +1,7 @@
+Scim-bridge is wrapper library for SCIM, written in C. Scim-bridge
+is seperated in two parts, the agent and the clients. The agent is
+the IME server which communicates with SCIM. The clients are IMModules
+which communicate only with the agent so that there is no binary
+dependency between the clients and SCIM.
+
+WWW: http://www.scim-im.org/projects/scim_bridge/